summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2020-06-29upgpkg: pjproject 2.10-1Andrea Pierangeli
upstream release Add aarch64 support
2020-04-20Add 'pjproject-git/' from commit '97e4d8dfa1950bc7a3818bcef03ac893be26d01e'Caleb Maclennan
git-subtree-dir: pjproject-git git-subtree-mainline: 02a8f0f7d6d2f3a70ec4d1af58156d6baa9127b2 git-subtree-split: 97e4d8dfa1950bc7a3818bcef03ac893be26d01e
2020-03-11Normalize .gitignore fileCaleb Maclennan
2020-03-11Normalize alphabetical order and formattingCaleb Maclennan
2020-03-11Remove obsolete build hacksCaleb Maclennan
2020-03-11Adapt stable packaging as VCS buildCaleb Maclennan
2020-02-23Force job server (multi-process is fine, no job server is not)Caleb Maclennan
2020-02-22Update to 2.10Caleb Maclennan
2020-02-10Use https URLCaleb Maclennan
2019-08-26Update .gitignore file for easy bulk repository managementCaleb Maclennan
2019-06-29Enable hardware accessWüstengecko
2019-06-18new upstream version 2.9Wüstengecko
This commit also switches to the md5sum integrity check, as that is what upstream provides.
2019-06-18Rewrite for python3 and bindings as split packageWüstengecko
Previously the package was applying a patch to build with python version 2. Since this is no longer necessary, and python 2 is nearing its end of life, this commit removes the patch. Furthermore this commit changes the PKGBUILD to now build the python language bindings in addition to the native PJSIP library. These bindings are built in a split package `python-pjproject`.
2019-06-18package: catch ARM binariesDenis 'GNUtoo' Carikli
In package(), the trailing '*' was added to pjsip-apps/bin/pjsua-*gnu in order to catch binaries like pjsip-apps/bin/pjsua-armv7l-unknown-linux-gnueabihf on ARM. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
2019-06-18disable libwebrtc on i686 to fix illegal instructionsDenis 'GNUtoo' Carikli
Both Parabola and archlinux32 whish to support all i686 machines that don't have SSE2: - Parabola's minimum system requirements states that: "Parabola GNU/Linux-libre should run on any i686 compatible machine [...]"[1] Wikipedia states that i686 has MMX and SSE[2] but doesn't mention SSE2 as a requirement[2]. - Archlinux32 states: "Currently some i686 packages require SSE2 - which is a bug we're trying to solve."[3] References: ----------- [1]https://wiki.parabola.nu/Beginners%27_guide#Minimum_system_requirements [2]https://en.wikipedia.org/wiki/P6_(microarchitecture) [3]https://archlinux32.org/architecture/ Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
2019-06-18Fix illegal instructions on x86_64 by disabling -march=nativeDenis 'GNUtoo' Carikli
Before this package was built with -march=native, so if you build it on a machine with a processor that supports avx (Advanced Vector Extensions), libpjsip.so.2 ended up with vpxor instructions that don't work anymore on machines with a processor that do not have such extension, and would result in an illegal instruction at asterisk startup on such machines. Signed-off-by: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org PKGBUILD | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
2018-12-05Update to 2.8Caleb Maclennan
2018-09-01Cleanup bash shell quoting using shellhardenCaleb Maclennan
2018-09-01Regenerate obsolete meta data using `makepkg --printsrcinfo`Caleb Maclennan
2018-09-01Update .gitignore file for easy bulk repository managementCaleb Maclennan
2018-07-24Update to 2.7.2Caleb Maclennan
2018-03-01Add .gitignore file for easier repository managementCaleb Maclennan
2018-02-15Adopt and move post install message to optdependsCaleb Maclennan
2017-12-08Bump to 2.7.1Xavier Devlamynck
2017-09-26Bump to 2.7Xavier Devlamynck
2017-07-31Change util-linux-ng dependency to util-linuxXavier Devlamynck
2017-06-12Add DNDEBUG CFLAGXavier Devlamynck
2017-02-28Use march=native flagsXavier Devlamynck
2017-02-27Add CXXFLAGS for x86 buildsXavier Devlamynck
2017-01-26Bump to 2.6Xavier Devlamynck
2016-08-24Add arm achitectureXavier Devlamynck
2016-07-21Bump to 2.5.5, 2Xavier Devlamynck
2016-07-21Bump to 2.5.5Xavier Devlamynck
2016-05-21Bump to release 2Xavier Devlamynck
2016-05-11Bump to 2.5Xavier Devlamynck
2015-12-27Bump to 2.4.5Xavier Devlamynck
2015-06-10Initial commitXavier Devlamynck