summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2021-06-11upgpkg: marktext 0.16.3-2Caleb Maclennan
2020-12-29upgpkg: marktext 0.16.3-1Caleb Maclennan
upstream release
2020-12-26upgpkg: marktext 0.16.2-4Caleb Maclennan
2020-09-25Default to Electron 8 dependencyCaleb Maclennan
Previously Electron 7 was in [community] so we preferred that over needing to install 8 from the AUR, but now 7 has gone away too. Since users are forced to use an AUR bin package, we might as well default to 8 again. This dependency is provided by `electron8-bin` as of this time. If anybody wants to provide a source package `electron8` that would be awesome, and that would become a viable option for fulfilling this dependency.
2020-06-19Downgrade Electron to 7Caleb Maclennan
Upstream actually has 8.x, but Arch has 7 or 9 in [community]. Building under 9 works, but I get an infinite loading spinner. 7 works and is functional, so posting with that until we either get a build of 9 that works or spin up AUR packaging for 8.
2020-06-19upgpkg: marktext 0.16.2-1Caleb Maclennan
upstream release
2020-04-24upgpkg: marktext 0.16.1-6Caleb Maclennan
Patch to fix arg handling from Electron wrapper
2020-04-23upgpkg: marktext 0.16.1-5Caleb Maclennan
Properly rebuild all modules against system Electron version
2020-04-23upgpkg: marktext 0.16.1-4Caleb Maclennan
Fix issues with build on newer nodejs & search module not being included
2020-04-02Remove deps that were for an experimental removal of Electron from the buildCaleb Maclennan
2020-04-01Overhaul in line with Arch packaging guidelinesCaleb Maclennan
* NEVER ADD or REMOVE files in *_install() hooks! * Use system Electron. This is an early adaptation of this and could use a lot of optimization. It currently builds stuff it doesn't use, bundles quite a few things that could be stripped out, and generally makes a nuisance of itself, but at least it uses the system default electron. Besides being 2 major versions plus lots of patches ahead and staying secure as Arch Linux updates the system, it also shaves 50+ MB off the package size and 166+ MB off the installed size. * Add missing libsecret dependency. * Use current upstream URL. * Remove makedeps that are part of base-devel. * Don't duplicate a mess of provides/conflicts, the -bin and -git packages take tare of this the other direction and pacman maps it even between each other. * Drop obsolete mime/desktop updates, these are handled by hooks. * Use system yarn for build rather than dynamically fetching it at build time. * Python 2 is not a dependency, node-gyp is which now uses Python 3. Depend directly on the thing we need to build. * Don't provide() a duplicate of the package name. * Don't let build stuff happen in prepare(). * Install LICENSE and documentation files.
2020-03-28v0.16.1Gabriel Saillard
2020-03-27Update to v0.16.0Gabriel Saillard
2019-11-07Adoption, packaging rewriteGitSquared
2019-10-25Install app.asar.unpacked to fix runtime errorSebastiaan Lokhorst
2019-10-15Update SRCINFOSebastiaan Lokhorst
2019-10-150.15.1 & fix buildSebastiaan Lokhorst
2019-06-10Add previous maintainers as contributorsDavid Birks
2019-05-15Change to use system electronDavid Birks
2019-05-15Change 4 spaces to 2 spacesDavid Birks
2019-05-15Change to my PKGBUILD preferencesDavid Birks
Remove unneeded licenses
2019-05-14Update to 0.14.0David Birks
Also changed to build with yarn.
2019-01-08upgpkg: marktext 0.13.65-1Simon Doppler
upstream release
2018-12-29upgpkg: marktext 0.13.53-1Simon Doppler
upstream release Merge subtree 'marktext'
2018-12-29upgpkg: marktext 0.13.53-1Simon Doppler
upstream release
2018-07-04Removed an accidentaly pasted lineDaniel Peukert
2018-06-27upgpkg: marktext 0.12.25-1Simon Doppler
upstream release
2018-06-12upgpkg: marktext 0.11.42-1Simon Doppler
upstream release
2018-05-01Fix commentsSimon Doppler
2018-05-01Initial commitSimon Doppler