summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
12 daysUpdate to version 4.4Daniel Bermond
2021-03-26Update to version 4.3.2Daniel Bermond
Also add lto to match repository package.
2021-01-09depends: switch pulseaudio to libpulseDaniel Bermond
2020-11-28Bring back rockchip-mpp support (upstream repo is now public again)Daniel Bermond
rockchip-mpp was disabled[1] a while ago because the upstream repository was temporarily set to private[2] (hidden from the public). Now the rockchip-mpp repositry is public[3] again and we can re-enable this feature. References ---------- [1] https://aur.archlinux.org/cgit/aur.git/commit/?h=ffmpeg-full&id=a224acc3d9b2d35eee6100a60e3df5822d1845dd [2] https://github.com/HermanChen/mpp/issues/15#issuecomment-690804709 [3] https://github.com/rockchip-linux/mpp/
2020-11-25Add fix for glslang 11.0. Update svt-vp9 patch.Daniel Bermond
2020-10-04Bring back smbclient support (fixed by upstream)Daniel Bermond
smbclient support was previously removed[1] due to a build failure with samba 4.9. It looks like that the recently released samba 4.13 fixed[2][3] the issue and now ffmpeg is building fine with it. References ---------- [1] https://aur.archlinux.org/cgit/aur.git/commit/?h=ffmpeg-full&id=f12ec9acea516c773870506abae2b0e7fd2a1067 [2] https://github.com/samba-team/samba/pull/212/ [3] https://github.com/samba-team/samba/commit/1114b02a72ce0c86a5301816560d270ec47f8be3
2020-09-29Fix build with srt 1.4.2Daniel Bermond
2020-09-17Disable rockchip mppDaniel Bermond
Upstream repository for rockchip mpp is gone. It was at: https://github.com/rockchip-linux/mpp/ I could not find any upstream word about it. The Rockchip Wiki still points to this repository, without saying if it was really dropped or moved to another place. Due to this, new users now cannot build rockchip-mpp package. Disabling it so new users can build ffmpeg-full.
2020-08-04Update svt-hevc patchesDaniel Bermond
2020-07-26Remove support for legacy nvidia-340xx driversDaniel Bermond
2020-07-23Add patch for cuda 11.0. Bring back svt-vp9 support.Daniel Bermond
cuda 11.0 minimum supported architecture is 5.2 (compute_52/sm_52). svt-vp9 support is better now with the current upstream stable version.
2020-07-12Fix svt-av1 patchDaniel Bermond
2020-07-11Updated to version 4.3.1Daniel Bermond
2020-06-30Update svt-av1 version to match repository packageDaniel Bermond
2020-06-19Updated to version 4.3Daniel Bermond
2020-06-10Fix checksumDaniel Bermond
2020-05-31Updated to version 4.2.3Daniel Bermond
2020-05-14Remove svt-vp9 supportDaniel Bermond
It's buggy at the current moment, not working properly at all.
2020-04-22Fix build with svt-av1 0.8.2Daniel Bermond
2020-02-29Add support for decklink-sdk 11.5Daniel Bermond
2020-01-28Match intel-media-sdk changesDaniel Bermond
intel-media-sdk is now installed on '/usr' prefix. No need to specify the pkg-config search path anymore.
2020-01-03Updated to version 4.2.2Daniel Bermond
2020-01-03Update svt versions. Update dependencies. General improvements.Daniel Bermond
2019-09-18Fix intel-media-sdk pkgconfig pathDaniel Bermond
2019-09-13Updated to version 4.2.1Daniel Bermond
2019-08-11Updated to version 4.2Daniel Bermond
2019-07-15Updated to version 4.1.4Daniel Bermond
2019-07-15Drop i686 supportDaniel Bermond
2019-07-06Use versioned patches for intel svt componentsDaniel Bermond
Patches for intel svt components will be different at each component release, so they better be versioned. This commit updates intel-svt-av1 patch from version 0.5.0 to 0.6.0.
2019-06-01Cosmetic changesDaniel Bermond
2019-06-01Update srcinfoDaniel Bermond
2019-06-01Fix build with decklink sdk 11Daniel Bermond
2019-06-01Add intel-svt support only on x86_64Daniel Bermond
2019-05-31Add intel-svt support for hevc, av1 and vp9Daniel Bermond
2019-04-24Fix tensorflow include dirDaniel Bermond
upstream ffmpeg excects[1] : /usr/include/tensorflow/ tensorflow package ships[2]: /usr/include/tensorflow/tensorflow/ References ---------- [1] https://git.videolan.org/?p=ffmpeg.git;a=blob;f=configure;h=a9644e211bebb342fb9066190f1be70e55f68ec0;hb=4154f8967820ca734a77ce91bb590cd77649dee8#l6138 [2] https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/tensorflow&id=d6b6fa4eb56d8e6055268504d6b0110c6fddde7e
2019-04-03Updated to version 4.1.3Daniel Bermond
2019-03-23Updated to version 4.1.2Daniel Bermond
2019-02-23Updated to version 4.1.1Daniel Bermond
2019-01-04depends: switch xavs2-git to xavs2Daniel Bermond
xavs2 1.3 stable was released and ffmpeg currently builds fine with it.
2018-11-21Temporarily disable libsmbclient due to upstream bugDaniel Bermond
ffmpeg fails to compile with the newly released smbclient 4.9[1]. Currently, there is a pull request[2] at upstream samba that aparently fixes this, but it still was not accepted at the time of writing. It is being discussed on the samba mailing list[3]. Disabling libsmbclient until there is a consistent upstream solution. References ---------- [1] https://bugs.gentoo.org/666548 [2] https://github.com/samba-team/samba/pull/212/ [3] https://lists.samba.org/archive/samba-technical/2018-October/130668.html
2018-11-17depends: switch davs2-git to davs2Daniel Bermond
Currently, it is now possible to build ffmpeg with the newly released davs2 stable version.
2018-11-10Updated to version 4.1Daniel Bermond
2018-10-15Add pgp check. Remove makepkg internal function. Cleanups.Daniel Bermond
2018-08-10Fix build with vmaf 1.3.9 (add back libvmaf support)Daniel Bermond
2018-08-10depends: fix lv2 dependencyDaniel Bermond
It requires both lv2 and lilv.
2018-07-21Temporarily disable libvmaf due to compile errorDaniel Bermond
ffmpeg fails to build with the newly released vmaf 1.3.7. Disabling vmaf support until upstream ffmpeg fixes this.
2018-07-20Updated to version 4.0.2Daniel Bermond
2018-06-27depends: switch libaom to aom (aom is now in official repositories)Daniel Bermond
References ---------- https://www.archlinux.org/packages/extra/x86_64/aom/
2018-06-26depends: switch aom-git to libaomDaniel Bermond
libaom 1.0.0 was released and now upstream ffmpeg is accepting to compile with this stable version, which was not possible with libaom 0.1.0. This will remove the dependency on a -git package, which is good and desirable when possible.
2018-06-16Updated to version 4.0.1Daniel Bermond