summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2020-11-14Update to 20.2.0Dimitris Kiziridis
2020-09-01Update to 20.1.5Dimitris Kiziridis
2020-08-12Update to 20.1.4Dimitris Kiziridis
2020-07-03Update to 20.1.3Dimitris Kiziridis
2020-06-12Update to 20.1.1Dimitris Kiziridis
2020-05-10Update to 19.2.6Dimitris Kiziridis
2020-04-05sanitize pkgbuildDimitris Kiziridis
2020-03-31Update to 19.2.5Dimitris Kiziridis
2020-01-21bump to 19.2.2 (released on 2019-12-10)J. Konrad Tegtmeier-Rottach
2019-11-25bump to 19.2.1 (released on 2019-11-25)J. Konrad Tegtmeier-Rottach
2019-11-15fix: cockroachdb has changed their license starting with v19.2J. Konrad Tegtmeier-Rottach
Note that old versions of cockroachdb (>3 years) automatically transition to Apache according to their new scheme, but this cannot be accurately reflected in the PKGBUILD. Some new licenses have also been added. I had not previously included these, so this commit fixes that issue, too. reported by @vasily ref: https://www.cockroachlabs.com/blog/oss-relicensing-cockroachdb/
2019-11-13bump to 19.2.0 (released on 2019-11-08)J. Konrad Tegtmeier-Rottach
2019-10-03bump to 19.1.5 (released on 2019-09-22)J. Konrad Tegtmeier-Rottach
2019-08-17bump to 19.1.4 (released on 2019-08-02)J. Konrad Tegtmeier-Rottach
2019-07-20bump to 19.1.3 (released on 2019-07-04)J. Konrad Tegtmeier-Rottach
2019-06-18bump to 19.1.2 (released on 2019-06-07)J. Konrad Tegtmeier-Rottach
2019-05-01add autogenerated zsh autocompletionJ. Konrad Tegtmeier-Rottach
2019-05-01bump to 19.1.0 (released on 2019-04-24)J. Konrad Tegtmeier-Rottach
The software's versioning schema was changed with this release.
2019-03-12bump to 2.1.6 (released on 2019-03-04)J. Konrad Tegtmeier-Rottach
2019-02-20bump to 2.1.5 (released on 2019-02-11)J. Konrad Tegtmeier-Rottach
2019-01-21bump to 2.1.4 (released on 2019-01-15)J. Konrad Tegtmeier-Rottach
2018-12-27bump to 2.1.3 (released on 2018-12-12)J. Konrad Tegtmeier-Rottach
ncurses is now compiled statically, so patching it is no longer necessary as of 2.1.3. I've skipped 2.1.1 and 2.1.2.
2018-11-01bump to 2.1.0 (released on 2018-10-25)J. Konrad Tegtmeier-Rottach
2018-10-02bump to 2.0.6 (released on 2018-10-01)J. Konrad Tegtmeier-Rottach
2018-08-14bump to 2.0.5 (released on 2018-08-06)J. Konrad Tegtmeier-Rottach
2018-07-17bump to 2.0.4 (released on 2018-07-17)J. Konrad Tegtmeier-Rottach
2018-06-22bump to 2.0.3 (released on 2018-06-18)J. Konrad Tegtmeier-Rottach
2018-05-27fix: also bump pkgrelJ. Konrad Tegtmeier-Rottach
2018-05-27remove hard-coded uid/gid via tmpfiles.dJ. Konrad Tegtmeier-Rottach
2018-05-21bump to 2.0.2 (released on 2018-05-14)J. Konrad Tegtmeier-Rottach
2018-04-27fix: also bump SRCINFOJ. Konrad Tegtmeier-Rottach
2018-04-27bump to 2.0.1 (released on 2018-04-16)J. Konrad Tegtmeier-Rottach
The systemd unit now defaults to running with --insecure mode (set in the env file). This allows an easier out-of-the-box experience, but sacrifices security. I deem this OK, as you'll need to properly configure cockroachdb before running it in production anyways.
2018-04-15update package for v2.0.0J. Konrad Tegtmeier-Rottach
New: - generated man pages - generated bash completion - systemd service Fixed: - applicable licenses - libtinfo.so.5 dependency
2017-10-28fix srcinfoMarcel O'Neil
2017-10-28v1.2-alpha.20171026Marcel O'Neil
2017-10-11v1.1.0-rc.1Marcel O'Neil
2017-09-28v1.1-beta.20170928Marcel O'Neil
2017-09-21v1.1-beta.20170921Marcel O'Neil
2017-09-08v1.1-beta.20170907Marcel O'Neil
2017-08-18v1.1-alpha.20170817Marcel O'Neil
2017-08-10v1.1-alpha.20170810Marcel O'Neil
2017-08-03v1.1-alpha.20170803Marcel O'Neil
2017-07-20v1.1-alpha.20170720Marcel O'Neil
2017-07-13v1.1-alpha.20170713Marcel O'Neil
2017-06-29v1.1-alpha.20170629Marcel O'Neil
2017-06-22v1.1-alpha.20170622Marcel O'Neil
2017-06-08v1.1-alpha.20170608Marcel O'Neil
2017-06-02v1.1-alpha.20170601Marcel O'Neil
2017-05-25v1.0.1Marcel O'Neil
2017-05-10v1.0Marcel O'Neil