summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 37 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f060c17cf5..9bf625f472b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,43 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-pyspeckit
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.1.21
-pkgrel=2
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+# "python2-${_pyname}"
+pkgver=0.1.23
+pkgrel=1
pkgdesc="Toolkit for fitting and manipulating spectroscopic data in python"
arch=('i686' 'x86_64')
url="https://pyspeckit.readthedocs.io/"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
+makedepends=('python-setuptools'
+# 'python2-setuptools'
+ 'python-astropy'
+ 'python-astropy-helpers>=3.1'
+# 'python2-astropy-helpers'
+ 'python-sphinx-astropy')
checkdepends=('tk' 'python-pytest-astropy' 'python-spectral-cube')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'correct_doc_examples.patch'
'fix_for_new_matplotlib.patch')
-md5sums=('e276915c2865e0e64dc132a3b9cb0b23'
+md5sums=('969c6d575e7f8a7a9d78921b4f977a43'
'b1ea9f4f4d2c467c26c34293bfbd387f'
- 'e1fb3919d6d3ae5e34fbbdcf95d5aae6')
+ 'a9a13077c3a3b3d039266450d9318aae')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
sed -i -e '/auto_use/s/True/False/' setup.cfg
- patch -Np1 -i "${srcdir}/correct_doc_examples.patch"
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
- patch -Np1 -i "${srcdir}/fix_for_new_matplotlib.patch"
+# patch -Np1 -i "${srcdir}/correct_doc_examples.patch"
+# cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
+# patch -Np1 -i "${srcdir}/fix_for_new_matplotlib.patch"
}
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build --use-system-libraries --offline
+# msg "Building Python2"
+# cd ${srcdir}/${_pyname}-${pkgver}-py2
+# python2 setup.py build --use-system-libraries --offline
- msg "Building Python3"
+# msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build --use-system-libraries --offline
@@ -42,30 +48,30 @@ build() {
check() {
# msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
+# python setup.py test
# msg "Checking Python2"
# cd ${srcdir}/${_pyname}-${pkgver}-py2
# python2 setup.py test
}
-package_python2-pyspeckit() {
- depends=('python2-numpy>=1.4' 'python2-astropy>=1.0' 'python2-matplotlib>=1.4')
- optdepends=('hdf5'
- 'python2-atpy'
- 'python2-spectral-cube'
- 'python2-lmfit'
- 'python-pyspeckit-doc: Documentation for PySpecKit'
- 'python2-pytest: For testing')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
-
- install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" licenses/*
- install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README*
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
- sed -i -e '/\#\/bin/s/ipython/ipython2/' ${pkgdir}/usr/bin/pyspeckit_script.py
- mv ${pkgdir}/usr/bin/astropy-package-template-example{,2}
- mv ${pkgdir}/usr/bin/pyspeckit_script{,2}.py
-}
+#package_python2-pyspeckit() {
+# depends=('python2-numpy>=1.4' 'python2-astropy>=1.0' 'python2-matplotlib>=1.4')
+# optdepends=('hdf5'
+# 'python2-atpy'
+# 'python2-spectral-cube'
+# 'python2-lmfit'
+# 'python-pyspeckit-doc: Documentation for PySpecKit'
+# 'python2-pytest: For testing')
+# cd ${srcdir}/${_pyname}-${pkgver}-py2
+#
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" licenses/*
+# install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README*
+# python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+# sed -i -e '/\#\/bin/s/ipython/ipython2/' ${pkgdir}/usr/bin/pyspeckit_script.py
+# mv ${pkgdir}/usr/bin/astropy-package-template-example{,2}
+# mv ${pkgdir}/usr/bin/pyspeckit_script{,2}.py
+#}
package_python-pyspeckit() {
depends=('python-numpy>=1.4' 'python-astropy>=1.0' 'python-matplotlib>=1.4')