summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO70
-rw-r--r--0001-disable-firmware-copy.patch27
-rw-r--r--0003-add-archlinux-as-build-option.patch26
-rw-r--r--PKGBUILD56
4 files changed, 32 insertions, 147 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fbefc88ce6..abedb9fa615 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = amdgpu-pro-installer
- pkgver = 19.30_838629
+ pkgver = 19.30_855429
pkgrel = 1
- url = https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-20-unified
+ url = https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux
arch = x86_64
groups = Radeon_Software_for_Linux
license = custom: multiple
makedepends = wget
- source = https://drivers.amd.com/drivers/linux/amdgpu-pro-19.30-838629-ubuntu-18.04.tar.xz
- source = 0001-disable-firmware-copy.patch
- source = 0003-add-archlinux-as-build-option.patch
- sha256sums = e2eb0a34745ecb9e244f81e0f3af8e4ab063d699dbc3e1a1e0867e8ce773d473
- sha256sums = 85359c89d7f1317cf5176bc9c489314aba2db20d962b120a43fc532575466345
- sha256sums = 2bf8eac2afac3bce0d17f840c15009838b578a72412ff66df6e8caa6c00fade7
+ source = https://drivers.amd.com/drivers/linux/amdgpu-pro-19.30-855429-ubuntu-18.04.tar.xz
+ sha256sums = 05161b3226e569b068f6dc9d85c50bb533bec8024b80e8f7459374d9d28654ba
pkgname = amdgpu-core-meta
pkgdesc = Config file /etc/ld.so.conf.d/20-amdgpu.conf
@@ -24,53 +20,36 @@ pkgname = amdgpu-pro-core-meta
install = amdgpu-pro-core-meta.install
arch = any
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-core-meta=19.30_838629-1
+ depends = amdgpu-core-meta=19.30_855429-1
pkgname = amf-amdgpu-pro
pkgdesc = AMDGPU Pro Advanced Multimedia Framework
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = gcc-libs
depends = glibc
depends = libx11
- depends = opencl-amdgpu-pro-orca=19.30_838629-1
- depends = opencl-amdgpu-pro-pal=19.30_838629-1
- depends = vulkan-amdgpu-pro=19.30_838629-1
+ depends = opencl-amdgpu-pro-orca=19.30_855429-1
+ depends = opencl-amdgpu-pro-pal=19.30_855429-1
+ depends = vulkan-amdgpu-pro=19.30_855429-1
pkgname = hip-amdgpu-pro
pkgdesc = HIP-CLANG runtime. HIP-CLANG allows developers to convert CUDA code to common C++
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = glibc
-pkgname = libdrm-amdgpu
- pkgdesc = Userspace interface to amdgpu-specific kernel DRM services -- runtime
- license = MIT
- depends = amdgpu-core-meta=19.30_838629-1
- depends = glibc
- provides = libdrm
-
-pkgname = lib32-libdrm-amdgpu
- pkgdesc = Userspace interface to amdgpu-specific kernel DRM services -- runtime (32-bit)
- license = MIT
- depends = amdgpu-core-meta=19.30_838629-1
- depends = lib32-glibc
- depends = libdrm-amdgpu=19.30_838629-1
- provides = lib32-libdrm
-
pkgname = amdgpu-pro-libgl
pkgdesc = AMDGPU Pro OpenGL driver
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = gcc-libs
depends = glibc
- depends = libdrm-amdgpu=19.30_838629-1
depends = libx11
depends = libxcb
depends = libxdamage
depends = libxext
depends = libxfixes
- depends = libxshmfence
depends = libxxf86vm
provides = libgl
backup = etc/gbm/gbm.conf
@@ -78,17 +57,15 @@ pkgname = amdgpu-pro-libgl
pkgname = lib32-amdgpu-pro-libgl
pkgdesc = AMDGPU Pro OpenGL driver (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
- depends = amdgpu-pro-libgl=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
+ depends = amdgpu-pro-libgl=19.30_855429-1
depends = lib32-gcc-libs
depends = lib32-glibc
- depends = lib32-libdrm-amdgpu=19.30_838629-1
depends = lib32-libx11
depends = lib32-libxcb
depends = lib32-libxdamage
depends = lib32-libxext
depends = lib32-libxfixes
- depends = lib32-libxshmfence
depends = lib32-libxxf86vm
provides = lib32-libgl
backup = etc/amd/amdrc
@@ -97,7 +74,7 @@ pkgname = lib32-amdgpu-pro-libgl
pkgname = opencl-amdgpu-pro-comgr
pkgdesc = Code object manager (COMGR)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = glibc
pkgname = opencl-amdgpu-pro-dev
@@ -108,47 +85,44 @@ pkgname = opencl-amdgpu-pro-dev
pkgname = opencl-amdgpu-pro-pal
pkgdesc = AMDGPU Pro OpenCL driver PAL
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = glibc
- depends = libdrm-amdgpu=19.30_838629-1
- depends = opencl-amdgpu-pro-comgr=19.30_838629-1
+ depends = opencl-amdgpu-pro-comgr=19.30_855429-1
provides = opencl-driver
backup = etc/OpenCL/vendors/amdocl64.icd
pkgname = opencl-amdgpu-pro-orca
pkgdesc = AMDGPU Pro OpenCL driver ORCA aka legacy
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = glibc
- depends = libdrm-amdgpu=19.30_838629-1
provides = opencl-driver
backup = etc/OpenCL/vendors/amdocl-orca64.icd
pkgname = lib32-opencl-amdgpu-pro-orca
pkgdesc = AMDGPU Pro OpenCL driver ORCA aka legacy (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = lib32-glibc
- depends = lib32-libdrm-amdgpu=19.30_838629-1
provides = lib32-opencl-driver
backup = etc/OpenCL/vendors/amdocl-orca32.icd
pkgname = roct-amdgpu-pro
pkgdesc = development environment for hsakmt-roct
license = MIT
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = glibc
depends = numactl
pkgname = roct-amdgpu-pro-dev
pkgdesc = development environment for hsakmt-roct
license = MIT
- depends = roct-amdgpu-pro=19.30_838629-1
+ depends = roct-amdgpu-pro=19.30_855429-1
pkgname = vulkan-amdgpu-pro
pkgdesc = AMDGPU Pro Vulkan driver
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = gcc-libs
depends = glibc
provides = vulkan-driver
@@ -156,7 +130,7 @@ pkgname = vulkan-amdgpu-pro
pkgname = lib32-vulkan-amdgpu-pro
pkgdesc = AMDGPU Pro Vulkan driver (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_838629-1
+ depends = amdgpu-pro-core-meta=19.30_855429-1
depends = lib32-gcc-libs
depends = lib32-glibc
provides = lib32-vulkan-driver
diff --git a/0001-disable-firmware-copy.patch b/0001-disable-firmware-copy.patch
deleted file mode 100644
index 99c0f1f7b2f..00000000000
--- a/0001-disable-firmware-copy.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 36b4ba44048aefb2a4d0096bc0ea1c4cc6fc5ef4 Mon Sep 17 00:00:00 2001
-From: David McFarland <corngood@gmail.com>
-Date: Sat, 28 Jan 2017 16:57:26 -0400
-Subject: [PATCH 1/3] disable firmware copy
-
----
-
-brainpower: changed a little to fit 17.40
-
- pre-build.sh | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/pre-build.sh b/pre-build.sh
-index 35d53e5..3c9d7d1 100755
---- a/pre-build.sh
-+++ b/pre-build.sh
-@@ -39,7 +39,3 @@
- | awk -F'[()]' '{print "#define "$2" amd"$2" //"$0}'\
- >> include/rename_symbol.h
-
--FW_DIR="/lib/firmware/$KERNELVER"
--mkdir -p $FW_DIR
--cp -ar /usr/src/amdgpu-17.40-492261/firmware/radeon $FW_DIR
--cp -ar /usr/src/amdgpu-17.40-492261/firmware/amdgpu $FW_DIR
---
-2.14.1
-
diff --git a/0003-add-archlinux-as-build-option.patch b/0003-add-archlinux-as-build-option.patch
deleted file mode 100644
index 3976de203a7..00000000000
--- a/0003-add-archlinux-as-build-option.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From a15dae29e472aff257f7aa8d536ab057a683c354 Mon Sep 17 00:00:00 2001
-From: David McFarland <corngood@gmail.com>
-Date: Sat, 8 Apr 2017 15:58:42 -0300
-Subject: [PATCH 3/3] add archlinux as build option
-
----
- Makefile | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/Makefile b/Makefile
-index 13b1f74..6b3686b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,6 +26,9 @@ else ifeq ("sles",$(OS_NAME))
- subdir-ccflags-y += -DOS_NAME_SLE
- else ifeq ("amzn",$(OS_NAME))
- subdir-ccflags-y += -DOS_NAME_AMZ
-+else ifeq ("arch",$(OS_NAME))
-+subdir-ccflags-y += -DOS_NAME_ARCH
-+OS_VERSION = "0.0"
- else
- subdir-ccflags-y += -DOS_NAME_UNKNOWN
- endif
---
-2.14.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 1072eb61fcb..966c7cfc982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Autogenerated from AMD's Packages file
major=19.30
-minor=838629
+minor=855429
pkgbase=amdgpu-pro-installer
pkgname=(
@@ -12,8 +12,6 @@ amdgpu-core-meta
amdgpu-pro-core-meta
amf-amdgpu-pro
hip-amdgpu-pro
-libdrm-amdgpu
-lib32-libdrm-amdgpu
amdgpu-pro-libgl
lib32-amdgpu-pro-libgl
opencl-amdgpu-pro-comgr
@@ -29,19 +27,15 @@ lib32-vulkan-amdgpu-pro
pkgver=${major}_${minor}
pkgrel=1
arch=('x86_64')
-url=https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-20-unified
+url=https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux
license=('custom: multiple')
groups=('Radeon_Software_for_Linux')
makedepends=('wget')
-DLAGENTS='https::/usr/bin/wget --referer https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-20-unified -N %u'
+DLAGENTS='https::/usr/bin/wget --referer https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux -N %u'
-source=(https://drivers.amd.com/drivers/linux/amdgpu-pro-${major}-${minor}-ubuntu-18.04.tar.xz
- 0001-disable-firmware-copy.patch
- 0003-add-archlinux-as-build-option.patch)
-sha256sums=(e2eb0a34745ecb9e244f81e0f3af8e4ab063d699dbc3e1a1e0867e8ce773d473
- 85359c89d7f1317cf5176bc9c489314aba2db20d962b120a43fc532575466345
- 2bf8eac2afac3bce0d17f840c15009838b578a72412ff66df6e8caa6c00fade7)
+source=(https://drivers.amd.com/drivers/linux/amdgpu-pro-${major}-${minor}-ubuntu-18.04.tar.xz)
+sha256sums=(05161b3226e569b068f6dc9d85c50bb533bec8024b80e8f7459374d9d28654ba)
PKGEXT=".pkg.tar"
@@ -118,41 +112,11 @@ package_hip-amdgpu-pro () {
move_copyright
}
-package_libdrm-amdgpu () {
- pkgdesc="Userspace interface to amdgpu-specific kernel DRM services -- runtime"
- license=('MIT')
- provides=('libdrm')
- depends=("amdgpu-core-meta=${major}_${minor}-${pkgrel}" "glibc")
-
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libdrm-amdgpu-amdgpu1_2.4.98-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libdrm-amdgpu-common_1.0.0-${minor}_all.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libdrm2-amdgpu_2.4.98-${minor}_amd64.deb
- move_copyright
-
- # extra_commands:
- mv ${pkgdir}/lib/* ${pkgdir}/usr/lib
- rmdir ${pkgdir}/lib
-}
-
-package_lib32-libdrm-amdgpu () {
- pkgdesc="Userspace interface to amdgpu-specific kernel DRM services -- runtime (32-bit)"
- license=('MIT')
- provides=('lib32-libdrm')
- depends=("amdgpu-core-meta=${major}_${minor}-${pkgrel}" "lib32-glibc" "libdrm-amdgpu=${major}_${minor}-${pkgrel}")
-
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libdrm-amdgpu-amdgpu1_2.4.98-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libdrm2-amdgpu_2.4.98-${minor}_i386.deb
- move_copyright
-
- # extra_commands:
- mv ${pkgdir}/lib ${pkgdir}/usr
-}
-
package_amdgpu-pro-libgl () {
pkgdesc="AMDGPU Pro OpenGL driver"
license=('custom: AMDGPU-PRO EULA')
provides=('libgl')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc" "libdrm-amdgpu=${major}_${minor}-${pkgrel}" "libx11" "libxcb" "libxdamage" "libxext" "libxfixes" "libxshmfence" "libxxf86vm")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc" "libx11" "libxcb" "libxdamage" "libxext" "libxfixes" "libxxf86vm")
backup=(etc/gbm/gbm.conf)
extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libegl1-amdgpu-pro_${major}-${minor}_amd64.deb
@@ -174,7 +138,7 @@ package_lib32-amdgpu-pro-libgl () {
pkgdesc="AMDGPU Pro OpenGL driver (32-bit)"
license=('custom: AMDGPU-PRO EULA')
provides=('lib32-libgl')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "amdgpu-pro-libgl=${major}_${minor}-${pkgrel}" "lib32-gcc-libs" "lib32-glibc" "lib32-libdrm-amdgpu=${major}_${minor}-${pkgrel}" "lib32-libx11" "lib32-libxcb" "lib32-libxdamage" "lib32-libxext" "lib32-libxfixes" "lib32-libxshmfence" "lib32-libxxf86vm")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "amdgpu-pro-libgl=${major}_${minor}-${pkgrel}" "lib32-gcc-libs" "lib32-glibc" "lib32-libx11" "lib32-libxcb" "lib32-libxdamage" "lib32-libxext" "lib32-libxfixes" "lib32-libxxf86vm")
backup=(etc/amd/amdrc etc/ld.so.conf.d/10-amdgpu-pro-i386.conf)
extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libegl1-amdgpu-pro_${major}-${minor}_i386.deb
@@ -213,7 +177,7 @@ package_opencl-amdgpu-pro-pal () {
pkgdesc="AMDGPU Pro OpenCL driver PAL"
license=('custom: AMDGPU-PRO EULA')
provides=('opencl-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc" "libdrm-amdgpu=${major}_${minor}-${pkgrel}" "opencl-amdgpu-pro-comgr=${major}_${minor}-${pkgrel}")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc" "opencl-amdgpu-pro-comgr=${major}_${minor}-${pkgrel}")
backup=(etc/OpenCL/vendors/amdocl64.icd)
extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-amdgpu-pro-icd_${major}-${minor}_amd64.deb
@@ -224,7 +188,7 @@ package_opencl-amdgpu-pro-orca () {
pkgdesc="AMDGPU Pro OpenCL driver ORCA aka legacy"
license=('custom: AMDGPU-PRO EULA')
provides=('opencl-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc" "libdrm-amdgpu=${major}_${minor}-${pkgrel}")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc")
backup=(etc/OpenCL/vendors/amdocl-orca64.icd)
extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-orca-amdgpu-pro-icd_${major}-${minor}_amd64.deb
@@ -235,7 +199,7 @@ package_lib32-opencl-amdgpu-pro-orca () {
pkgdesc="AMDGPU Pro OpenCL driver ORCA aka legacy (32-bit)"
license=('custom: AMDGPU-PRO EULA')
provides=('lib32-opencl-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-glibc" "lib32-libdrm-amdgpu=${major}_${minor}-${pkgrel}")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-glibc")
backup=(etc/OpenCL/vendors/amdocl-orca32.icd)
extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-orca-amdgpu-pro-icd_${major}-${minor}_i386.deb