summarylogtreecommitdiffstats
path: root/.SRCINFO
diff options
context:
space:
mode:
Diffstat (limited to '.SRCINFO')
-rw-r--r--.SRCINFO118
1 files changed, 96 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5159cbecb48..f8a90f11a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,56 @@
pkgbase = qemu-git
- pkgdesc = A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation. Git version.
- pkgver = 2.4.r39316.gb041114
+ pkgver = 2.4.r40384.g2d69736
pkgrel = 1
- url = http://wiki.qemu.org/Index.html
- install = qemu.install
+ url = http://wiki.qemu.org/
arch = i686
arch = x86_64
license = GPL2
- license = LGPL2
+ license = LGPL2.1
+ makedepends = pixman
+ makedepends = libjpeg
+ makedepends = libpng
+ makedepends = sdl
+ makedepends = alsa-lib
+ makedepends = nss
+ makedepends = glib2
+ makedepends = gnutls
+ makedepends = bluez-libs
+ makedepends = vde2
+ makedepends = util-linux
+ makedepends = curl
+ makedepends = libsasl
+ makedepends = libgl
+ makedepends = libpulse
+ makedepends = libcap-ng
+ makedepends = libaio
+ makedepends = libseccomp
+ makedepends = libiscsi
+ makedepends = python2
+ makedepends = usbredir
+ makedepends = ceph
+ makedepends = glusterfs
+ makedepends = libssh2
+ makedepends = lzo
+ makedepends = snappy
+ makedepends = dtc
+ makedepends = libepoxy
makedepends = git
makedepends = texi2html
makedepends = perl
- makedepends = python2
- makedepends = spice-protocol
+ makedepends = numactl
+ source = git://git.qemu.org/qemu.git
+ source = 65-kvm.rules
+ source = qemu.install
+ source = qemu.sysusers
+ sha256sums = SKIP
+ sha256sums = 60dcde5002c7c0b983952746e6fb2cf06d6c5b425d64f340f819356e561e7fc7
+ sha256sums = 0df69a77645c9a05f98635773666b6212084525d7801ef8382242b06baebe5aa
+ sha256sums = dd43e2ef062b071a0b9d0d5ea54737f41600ca8a84a8aefbebb1ff09f978acfb
+
+pkgname = qemu-git
+ pkgdesc = A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation. Git version.
+ install = qemu.install
+ depends = glibc
depends = pixman
depends = libjpeg
depends = libpng
@@ -20,44 +58,80 @@ pkgbase = qemu-git
depends = alsa-lib
depends = nss
depends = glib2
- depends = gnutls>=2.4.1
+ depends = gnutls
depends = bluez-libs
depends = vde2
depends = util-linux
- depends = curl
depends = libsasl
depends = libgl
- depends = libpulse
+ depends = seabios
+ depends = libcap
depends = libcap-ng
depends = libaio
depends = libseccomp
- depends = libiscsi
- depends = spice
+ depends = libcacard
depends = usbredir
- depends = dtc
+ depends = lzo
depends = snappy
+ depends = gcc-libs
+ depends = zlib
+ depends = bzip2
+ depends = nspr
+ depends = ncurses
+ depends = libx11
+ depends = libusb
+ depends = libpulse
+ depends = libssh2
+ depends = curl
optdepends = ovmf: Tianocore UEFI firmware for qemu
+ optdepends = samba: SMB/CIFS server support
+ optdepends = qemu-block-iscsi: iSCSI block support
+ optdepends = qemu-block-rbd: RBD block support
+ optdepends = qemu-block-gluster: glusterfs block support
provides = qemu
provides = qemu-kvm
provides = qemu-spice
- provides = libcacard
provides = seabios
provides = seabios-git
conflicts = qemu
conflicts = kvm
conflicts = kvm-git
conflicts = qemu-spice
- conflicts = libcacard
conflicts = seabios
conflicts = seabios-git
options = !strip
backup = etc/qemu/target-x86_64.conf
- source = git://git.qemu.org/qemu.git
- source = 65-kvm.rules
- source = qemu.install
- sha256sums = SKIP
- sha256sums = 9c8a15c34461a9481a34ca9e0ab4ae3825eabe8fd863227f2445325413cd755c
- sha256sums = 9970c3050e8dc6153c5955d018d114f9fcbc091843b85f9e7b247eb28f09ba10
-pkgname = qemu-git
+pkgname = qemu-block-iscsi-git
+ pkgdesc = QEMU iSCSI block module. Git version.
+ depends = glibc
+ depends = glib2
+ depends = libiscsi
+ provides = qemu-block-iscsi
+ conflicts = qemu-block-iscsi
+
+pkgname = qemu-block-rbd-git
+ pkgdesc = QEMU RBD block module. Git version.
+ depends = glibc
+ depends = glib2
+ depends = ceph
+ provides = qemu-block-rbd
+ conflicts = qemu-block-rbd
+
+pkgname = qemu-block-gluster-git
+ pkgdesc = QEMU GlusterFS block module. Git version.
+ depends = glibc
+ depends = glib2
+ depends = glusterfs
+ provides = qemu-block-gluster
+ conflicts = qemu-block-gluster
+
+pkgname = libcacard-git
+ pkgdesc = Common Access Card (CAC) Emulation. Git version.
+ depends = glibc
+ depends = nss
+ depends = nspr
+ depends = glib2
+ provides = libcacard
+ conflicts = libcacard