summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122018-08-05 08:50:32 +0200
committerwillemw122018-08-05 08:50:32 +0200
commit9e4e46d9bfce34f7f0b1dec218f17fc866a2eb3a (patch)
treebb4b02ee6afe71c21e7f7d4d1ee2257814023021 /PKGBUILD
parent1febe37781c272b08fc363e7acb180a6acf0db85 (diff)
downloadaur-9e4e46d9bfce34f7f0b1dec218f17fc866a2eb3a.tar.gz
Update description and upstream URL. Remove Qt4 (PyQt4). Add PySide2 dependency comments for future inclusion
As requested by CAM-Gerlach
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9618c17370..ee6df0a62d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.3.0.r1370.gc41693301
+pkgver=3.3.0.r1455.g678cedc97
pkgrel=1
arch=('any')
-url="https://github.com/spyder-ide/spyder"
+url="https://www.spyder-ide.org/"
license=('MIT')
makedepends=('python2-sphinx' 'python2-setuptools'
'python-sphinx' 'python-setuptools'
@@ -36,7 +36,7 @@ build() {
}
package_spyder-git() {
- pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)"
+ pkgdesc="The Scientific Python Development Environment (Python 2 version)"
# Note: 'ipython2-notebook' nor 'jupyter'/'jupyter-nbconvert' contain a Python 2 version of Nbconvert
# 'icu'
depends=('python2-jedi'
@@ -56,11 +56,10 @@ package_spyder-git() {
'desktop-file-utils'
'gtk-update-icon-cache')
+ #'python2-pyside2: Qt-Python bindings'
optdepends=('python2-matplotlib: 2D/3D plotting'
'python2-numpy: N-dimensional arrays'
'python2-pandas: DataFrame and Series support'
- 'python2-pyqt4: Qt-Python bindings'
- 'python2-pyside: Qt-Python bindings'
'python2-scipy: signal/image processing'
'python2-sympy: symbolic mathematics'
@@ -77,7 +76,7 @@ package_spyder-git() {
}
package_spyder3-git() {
- pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)"
+ pkgdesc="The Scientific Python Development Environment (Python 3 version)"
# 'icu'
depends=('jupyter-nbconvert'
'python-jedi'
@@ -97,11 +96,10 @@ package_spyder3-git() {
'desktop-file-utils'
'gtk-update-icon-cache')
+ #'pyside2: Qt-Python bindings'
optdepends=('python-matplotlib: 2D/3D plotting'
'python-numpy: N-dimensional arrays'
'python-pandas: DataFrame and Series support'
- 'python-pyqt4: Qt-Python bindings'
- 'python-pyside: Qt-Python bindings'
'python-scipy: signal/image processing'
'python-sympy: symbolic mathematics'