summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2019-04-12 11:42:49 +0200
committerStephan Springer2019-04-12 11:42:49 +0200
commit7d6401e7b266609a768d7fb2e284cb696cb9849c (patch)
treef3376415869a86199e262db5c7f5e0382ae72a04 /PKGBUILD
parent9fc2c19782cdc9e332e93a9c5a42001e69de44e1 (diff)
downloadaur-7d6401e7b266609a768d7fb2e284cb696cb9849c.tar.gz
merge python-sip-pyqt4 and python2-sip-pyqt4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 23 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd06c9d64ae..c26a7f47a30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Contributor inemum (https://gitlab.com/inemum)
-# Maintainer graysky <graysky AT archlinux DOT us>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: inemum (https://gitlab.com/inemum)
+# Contributor: graysky <graysky AT archlinux DOT us>
+# Contributor: Fredrick Brennan <copypaste@kittens.ph>
+
# based on https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/sip
-pkgname=('python-sip-pyqt4')
+pkgbase=('python-sip-pyqt4')
+pkgname=('python-sip-pyqt4' 'python2-sip-pyqt4')
pkgver=4.19.16
pkgrel=1
arch=('x86_64')
url='http://www.riverbankcomputing.com/software/sip/intro'
license=('custom:"sip"')
-makedepends=('python')
+makedepends=('python' 'python2')
source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
sha256sums=('184c790d58e9527fc6bdac2bbf8638f3d1b41dea922cad8eb83172b4ba70c620')
prepare() {
- mkdir -p build-pyqt4
+ mkdir -p build-pyqt4{,-py2}
}
build() {
cd "$srcdir"/build-pyqt4
python ../sip-$pkgver/configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS" --sip-module PyQt4.sip --no-tools
make
+
+ cd "$srcdir"/build-pyqt4-py2
+ python2 ../sip-$pkgver/configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS" --sip-module PyQt4.sip --no-tools
+ make
}
package_python-sip-pyqt4() {
@@ -31,3 +39,13 @@ package_python-sip-pyqt4() {
install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+
+package_python2-sip-pyqt4() {
+ pkgdesc="Python 2.x SIP bindings for C and C++ libraries (PyQt4 version)"
+ depends=('python2')
+
+ cd build-pyqt4-py2
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}