summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenzo Cappelletti2021-04-02 22:07:11 +0200
committerLorenzo Cappelletti2021-04-02 22:10:27 +0200
commite198a73847d7fafe58974f0fe716540d69b6ee77 (patch)
treeec6322e75430df7328da9180e753dfea5ae38e88 /PKGBUILD
parent3d1b4a75e09e21b3ea1ee2970656e16bacecd975 (diff)
downloadaur-e198a73847d7fafe58974f0fe716540d69b6ee77.tar.gz
Drop support to Python2
A few dependency packages are no longer available for Python2 (notably pyserial).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 1 insertions, 75 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25dc754503c..06214588ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,6 @@ pkgname=(
'python-mbed-ls'
'python-mbed-host-tests'
'python-mbed-greentea'
-
- 'python2-mbed-os-tools'
- 'python2-mbed-ls'
- 'python2-mbed-host-tests'
- 'python2-mbed-greentea'
)
pkgver=0.0.15
pkgrel=1
@@ -18,7 +13,7 @@ pkgdesc="The tools to test and work with Mbed OS"
arch=('any')
url="https://os.mbed.com/"
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/ARMmbed/mbed-os-tools/archive/v${pkgver}.tar.gz")
sha256sums=('60e77755e43d9dc0612ecbbb02ff3321dd79993a664a22c3ad2405f6de61c7e2')
@@ -54,31 +49,6 @@ package_python-mbed-os-tools() {
python setup.py clean --all
}
-package_python2-mbed-os-tools() {
- depends=(
- 'python2'
- 'python2-pyserial'
- 'python2-requests'
- 'python2-intelhex'
- 'python2-future'
- 'python2-prettytable'
- 'python2-fasteners'
- 'python2-appdirs'
- 'python2-junit-xml'
- 'python2-lockfile'
- 'python2-six'
- 'python2-colorama'
- 'python2-beautifulsoup4'
- )
-
- cd "mbed-os-tools-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- _remove_test
- python2 setup.py clean --all
-}
-
-### mbed-ls #################################################################
-
package_python-mbed-ls() {
conflicts=('python2-mbed-ls')
depends=(
@@ -93,22 +63,6 @@ package_python-mbed-ls() {
python setup.py clean --all
}
-package_python2-mbed-ls() {
- conflicts=('python-mbed-ls')
- depends=(
- 'python'
- 'python-prettytable'
- 'python-mbed-os-tools'
- )
-
- cd "mbed-os-tools-${pkgver}/packages/mbed-ls"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- _remove_test
- python2 setup.py clean --all
-}
-
-### mbed-host-tests #########################################################
-
package_python-mbed-host-tests() {
conflicts=('python2-mbed-host-tests')
depends=(
@@ -122,21 +76,6 @@ package_python-mbed-host-tests() {
python setup.py clean --all
}
-package_python2-mbed-host-tests() {
- conflicts=('python-mbed-host-tests')
- depends=(
- 'python'
- 'python-mbed-os-tools'
- )
-
- cd "mbed-os-tools-${pkgver}/packages/mbed-host-tests"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- _remove_test
- python2 setup.py clean --all
-}
-
-### mbed-greentea ###########################################################
-
package_python-mbed-greentea() {
conflicts=('python2-mbed-greentea')
depends=(
@@ -150,17 +89,4 @@ package_python-mbed-greentea() {
python setup.py clean --all
}
-package_python2-mbed-greentea() {
- conflicts=('python-mbed-greentea')
- depends=(
- 'python'
- 'python-mbed-os-tools'
- )
-
- cd "mbed-os-tools-${pkgver}/packages/mbed-greentea"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- _remove_test
- python2 setup.py clean --all
-}
-
# vim:set ts=2 sw=2 et: