summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortocic2019-05-22 17:24:28 +0300
committertocic2019-05-22 17:24:28 +0300
commit96b9c2471f31da6a1f7b97048f7a3deb450c4d13 (patch)
tree62e8ddb087e46835f25a7b66c577bc97da4b7c63 /PKGBUILD
parent2f539ff156df1843b1865b96a20fad4cf9e29bc2 (diff)
downloadaur-96b9c2471f31da6a1f7b97048f7a3deb450c4d13.tar.gz
merge with python2-flask-cors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e52536bb58c..9504eefec03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
-# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Maintainer: tocic <tocic at protonmail dot ch>
# Contributor: Gaël Donval <gdonval+aur at google mail>
pkgbase='python-flask-cors'
-pkgname=('python-flask-cors')
+pkgname=('python-flask-cors' 'python2-flask-cors')
+_name=Flask-Cors
pkgver=3.0.7
-pkgrel=1
-pkgdesc='cross origin resource sharing (CORS) support for Flask'
+pkgrel=2
+pkgdesc="A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible"
arch=('any')
-url='https://github.com/corydolphin/flask-cors'
-license=('BSD')
-makedepends=('python-setuptools')
-depends=('python-flask>=0.9'
- 'python-six'
- 'python>=3.4')
-source=("https://github.com/corydolphin/flask-cors/archive/${pkgver}.tar.gz")
-md5sums=('da02288a9734e26ef0a38afcf82ea6db')
-sha1sums=('21845aa4e9bdbd9051ab7e82a9784c72bf1e039e')
+url='https://pypi.org/project/Flask-Cors'
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("$pkgbase-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+md5sums=('4448765829502d74745a976aa0620c1a')
+sha1sums=('4e3b951c6ee56e19396ff8a3ff4534d821434b86')
+sha256sums=('7e90bf225fdf163d11b84b59fb17594d0580a16b97ab4e1146b1fb2737c1cfec')
-build() {
- cd "${srcdir}"/flask-cors-$pkgver
- python setup.py build
+package_python-flask-cors() {
+ depends=('python>=3.4' 'python-flask>=0.9' 'python-six')
+
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-package() {
- cd "${srcdir}"/flask-cors-$pkgver
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+package_python2-flask-cors() {
+ depends=('python2' 'python2-flask>=0.9' 'python2-six')
+
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}