summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2021-02-14 10:30:55 -0500
committerEli Schwartz2021-02-14 10:30:55 -0500
commitd6b997ac13ac8c2c534c8f1d7c851f88da80da86 (patch)
treef501b0f3df43af0d1fe8f3f0c007b7f1cf487389 /PKGBUILD
parenta71046c7e2e32e420e0f4f3794c5cf9a6157dabf (diff)
downloadaur-glibc-git.tar.gz
upgpkg: glibc-git 2.33.r62.gebcf45a16c-2
Fix using glibc on systems with older kernels than the built one; for mysterious reasons, core/glibc dropped the --enable-kernel option a while back and it's been re-added. This argument describes the oldest kernel that the glibc build desires to support, and core/glibc uses 4.4 which is pretty reasonable.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e673315cbba..e80ee0f38fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.32.r537.g2d651eb926
-pkgrel=1
+pkgver=2.33.r62.gebcf45a16c
+pkgrel=2
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
url='https://www.gnu.org/software/libc/'
@@ -59,6 +59,7 @@ build() {
--enable-add-ons \
--enable-bind-now \
--enable-cet \
+ --enable-kernel=4.4 \
--enable-lock-elision \
--enable-multi-arch \
--enable-stack-protector=strong \