summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-02-08 14:42:00 +0200
committerDet2017-02-08 14:42:00 +0200
commitfd639496041917f0d7bd56455927d53d4ad45679 (patch)
tree6210804439529034b855f03c5579aa3f161a1959
parent3c8456663bccea0302bcb950f9907c7aae518a44 (diff)
downloadaur-fd639496041917f0d7bd56455927d53d4ad45679.tar.gz
Sync .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD5
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c96dfec4d9f..045f9fe9a2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = xorg-server-dev
pkgver = 1.19.1
pkgrel = 2
- url = http://xorg.freedesktop.org
+ url = https://xorg.freedesktop.org
arch = i686
arch = x86_64
+ groups = xorg
license = custom
makedepends = pixman
makedepends = libx11
@@ -53,20 +54,21 @@ pkgbase = xorg-server-dev
makedepends = libxshmfence
makedepends = libunwind
makedepends = xfont2-git
- makedepends = wayland-protocols
- source = http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.19.1.tar.bz2
- source = http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.19.1.tar.bz2.sig
+ makedepends = wayland-protocols
+ source = https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.19.1.tar.bz2
+ source = https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.19.1.tar.bz2.sig
+ source = bug99358.patch
source = xvfb-run
source = xvfb-run.1
- sha256sums = f0c27ae3d20474674708d19b888f5d11c25c811e7ed8dba4e6318d581727e91f
+ sha256sums = 79ae2cf39d3f6c4a91201d8dad549d1d774b3420073c5a70d390040aa965a7fb
sha256sums = SKIP
+ sha256sums = f46a9d1a5ac43c5359fbd8c57b6e64b0bd313116b5cb638527bfe3701e6c3904
sha256sums = ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9
sha256sums = 2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776
pkgname = xorg-server-dev
pkgdesc = Xorg X server - Bleeding edge version
install = xorg-server-dev.install
- groups = xorg
depends = libepoxy
depends = libxdmcp
depends = libxfont
@@ -79,7 +81,7 @@ pkgname = xorg-server-dev
depends = libxshmfence
depends = libgl
depends = xf86-input-driver
- provides = X-ABI-VIDEODRV_VERSION=23.0
+ provides = X-ABI-VIDEODRV_VERSION=23
provides = X-ABI-XINPUT_VERSION=24.1
provides = X-ABI-EXTENSION_VERSION=10.0
provides = x-server
diff --git a/PKGBUILD b/PKGBUILD
index e99ff86df85..d429b7379b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -116,10 +116,7 @@ package_xorg-server-dev() {
# see src/xorg-server-*/hw/xfree86/common/xf86Module.h for ABI versions - we provide major numbers that drivers can depend on
# and /usr/lib/pkgconfig/xorg-server.pc in xorg-server-devel-dev pkg
- for VAR in VIDEODRV XINPUT EXTENSION; do
- provides+=("X-ABI-${VAR}_VERSION=$(grep -Po "${VAR}_V.*\(\K[^)]*" "${_pkgbase}-${pkgver}/hw/xfree86/common/xf86Module.h" |& sed 's/, /./')")
- done
- provides+=('x-server' 'xorg-server')
+ provides=('X-ABI-VIDEODRV_VERSION=23' 'X-ABI-XINPUT_VERSION=24.1' 'X-ABI-EXTENSION_VERSION=10.0' 'x-server' 'xorg-server')
conflicts=('nvidia-utils<=331.20' 'glamor-egl' 'xf86-video-modesetting' 'xorg-server')
replaces=('glamor-egl' 'xf86-video-modesetting')
install=xorg-server-dev.install