summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Cho2021-05-21 22:03:27 +0900
committerXavier Cho2021-05-21 22:03:27 +0900
commit657324cc0b3cfcbdfac0aee17aeb0fc7fe91c928 (patch)
treebb1f3699cd8550e19f9d844a1dfcdbdce9a024b7
parent64701cc72a265f909dfe5ca0425ecd46b5cee3ad (diff)
downloadaur-657324cc0b3cfcbdfac0aee17aeb0fc7fe91c928.tar.gz
Fix build problem after recent GCC 11 update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff849d5595c..ae9d436ed0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upbge-git
pkgdesc = Uchronia Project Blender Game Engine fork of Blender Game Engine
- pkgver = 110046.86bb8657741
+ pkgver = 110538.740c1695091
pkgrel = 1
url = https://upbge.org/
install = upbge.install
@@ -12,6 +12,8 @@ pkgbase = upbge-git
makedepends = boost
makedepends = mesa
makedepends = llvm
+ makedepends = gcc10
+ makedepends = gcc10-libs
depends = alembic
depends = embree
depends = libgl
diff --git a/PKGBUILD b/PKGBUILD
index eec63c70203..cf6e7e9509a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,6 +6,8 @@
# shellcheck disable=SC2206
[[ -v CUDA_ARCH ]] && _cuda_capability=(${CUDA_ARCH})
+_CMAKE_FLAGS+=( -DCMAKE_C_COMPILER=gcc-10 -DCMAKE_CXX_COMPILER=g++-10 )
+
# opencolorio=2 fix (add LD_LIBRAY_PATH or rpath to blender-2.93)
_CMAKE_FLAGS+=( -DOSL_ROOT_DIR=/opt/osl
-DOPENIMAGEIO_ROOT_DIR=/opt/oiio
@@ -26,7 +28,7 @@ _CMAKE_FLAGS+=( -DOSL_ROOT_DIR=/opt/osl
((DISABLE_CUDA)) && optdepends+=("cuda: CUDA support in Cycles") || { makedepends+=("cuda") ; ((DISABLE_OPTIX)) || makedepends+=("optix>=7.0"); }
pkgname=upbge-git
-pkgver=110046.86bb8657741
+pkgver=110538.740c1695091
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=("i686" "x86_64")
@@ -34,7 +36,7 @@ url="https://upbge.org/"
depends=("alembic" "embree" "libgl" "python" "python-numpy" "openjpeg2" "libharu" "potrace" "openxr"
"ffmpeg" "fftw" "openal" "freetype2" "libxi" "openimageio-qfix" "opencolorio-qfix"
"openvdb" "opencollada" "opensubdiv" "openshadinglanguage-qfix" "libtiff" "libpng" "openimagedenoise")
-makedepends=("git" "cmake" "boost" "mesa" "llvm")
+makedepends=("git" "cmake" "boost" "mesa" "llvm" "gcc10" "gcc10-libs")
provides=("blender")
conflicts=("blender")
license=("GPL")