summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2020-05-05 14:37:14 -0500
committerZerophase2020-05-05 14:37:14 -0500
commit75b0b95f605c266c904ea10d49d6d5cf687697e2 (patch)
tree3c4c53bf7099ebf6f9b19cc2c97f5d5c6128004c
parentad7370305eb06f3f63ba2834a79235183d8bf473 (diff)
downloadaur-75b0b95f605c266c904ea10d49d6d5cf687697e2.tar.gz
update to 4.25
-rw-r--r--PKGBUILD4
-rw-r--r--use-arch-mono.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50401009d45..19e8684d787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# The source is about 200 MiB, with an extra ~11 GiB of dependencies downloaded in Setup.sh, and may take several hours to compile.
pkgname='unreal-engine'
-pkgver=4.24.3
+pkgver=4.25.0
pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
@@ -21,7 +21,7 @@ license=('custom:UnrealEngine')
source=('com.unrealengine.UE4Editor.desktop'
'use-arch-mono.patch')
sha256sums=('fa4bd19ab53e91cc8b4ae6208452a7fe986a08047617213d6250b43e7a140bf3'
- '90a112f72a498f50dafad4feeaf7c551fe4e19830610bcef634f8e23d3d283b3')
+ 'e891f07bf7294cd5fde8eb6de92e6d47ed004847ea8afd7c944e9b9b2bacaff4')
options=(strip staticlibs) # Package is 3 Gib smaller with "strip" but it takes a long time and generates many warnings
prepare() {
diff --git a/use-arch-mono.patch b/use-arch-mono.patch
index b1a256e1b11..a85cab55672 100644
--- a/use-arch-mono.patch
+++ b/use-arch-mono.patch
@@ -1,10 +1,10 @@
---- SetupMono-orig.sh 2019-09-05 18:59:40.953565669 -0500
-+++ SetupMono.sh 2019-09-05 19:05:21.203570187 -0500
+--- SetupMono.sh 2020-05-04 02:07:37.213825041 -0500
++++ SetupMono_new.sh 2020-05-05 12:31:03.403575161 -0500
@@ -11,6 +11,7 @@
bash FixDependencyFiles.sh
-
IS_MONO_INSTALLED=0
+ IS_MS_BUILD_AVAILABLE=0
+UE_USE_SYSTEM_MONO=1
MONO_VERSION_PATH=$(command -v mono) || true
+
if [ "$UE_USE_SYSTEM_MONO" == "1" ] && [ ! $MONO_VERSION_PATH == "" ] && [ -f $MONO_VERSION_PATH ]; then
- # If Mono is installed, check if it's 5.0 or higher