summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2017-10-29 22:42:59 +0100
committerGordian Edenhofer2017-10-29 22:42:59 +0100
commit0dd616f4fe36754f7eef42776e61ed8dc5979d98 (patch)
tree412f975d4f5c085186c8e07fba344141a9ab18b6
parent6cbe490eaf53e6fb153cd41fac8b91758ca42d01 (diff)
downloadaur-0dd616f4fe36754f7eef42776e61ed8dc5979d98.tar.gz
slurm-llnl: Add gtk2 to makedepends
Despite not being required at runtime, GTK2 is still necessary for compiling the source successfully. slurm-llnl-dev slurm-llnl-git
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2d8e047df8..b1a0c8d0f04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = slurm-llnl
arch = x86_64
license = GPL
makedepends = python
+ makedepends = gtk2
depends = munge
optdepends = hwloc: enables the task/cgroup plugin
optdepends = lua: the lua API will be available in various plugins
diff --git a/PKGBUILD b/PKGBUILD
index 1d4535ecc82..e48d57280ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ optdepends=("hwloc: enables the task/cgroup plugin"
"numactl: NUMA support in the task/affinity plugin"
"ncurses: adds the smap command "
"gtk2: enables the sview command, a simple graphical frontend")
-makedepends=('python')
+makedepends=('python' 'gtk2')
backup=('etc/default/slurm-llnl')
install="${pkgname}.install"
source=("slurm-tmpfiles.conf"