summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-07-09 18:28:06 +0200
committeranthraxx2015-07-09 18:28:06 +0200
commit63f103e330158a72843a5a74def6a95d193e6a1c (patch)
tree08a69287620717af739b7b29a3eed2433d5519e9
downloadaur-63f103e330158a72843a5a74def6a95d193e6a1c.tar.gz
addpkg: scanmem-git v0.15.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..0604d51a021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = scanmem-git
+ pkgdesc = A utility used to locate the address of a variable in an executing process.
+ pkgver = v0.15.2
+ pkgrel = 1
+ url = https://github.com/coolwan/scanmem
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ depends = python
+ depends = pygtk
+ depends = polkit
+ depends = python-gobject
+ provides = scanmem
+ conflicts = scanmem
+ source = git+https://github.com/scanmem/scanmem.git
+ md5sums = SKIP
+
+pkgname = scanmem-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..50e9407f7d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Allen Choong <allencch at hotmail dot com>
+
+pkgname=scanmem-git
+_gitname=scanmem
+pkgver=v0.15.2
+pkgrel=1
+pkgdesc="A utility used to locate the address of a variable in an executing process."
+arch=('i686' 'x86_64')
+url="https://github.com/coolwan/scanmem"
+provides=('scanmem')
+conflicts=('scanmem')
+license=('GPL3')
+depends=('python' 'pygtk' 'polkit' 'python-gobject')
+makedepends=('intltool')
+#optdepends=('gksu: needed for the GameConqueror GUI.')
+source=("git+https://github.com/scanmem/scanmem.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+
+ ./autogen.sh
+ ./configure --enable-gui --prefix=/usr
+ msg2 "Building..."
+ make -s
+}
+
+package() {
+ cd $_gitname
+ make -s DESTDIR="$pkgdir" install
+
+ # Replacing calls to the Python 3.x interpreter to the Python 2.x one:
+ #sed 's|python|python2|g' -i "$pkgdir/usr/bin/gameconqueror"
+ #sed 's|#!/usr/bin/env python|#!/usr/bin/env python2|g' -i \
+ # "$pkgdir/usr/share/gameconqueror/"{backend.py,GameConqueror.py,hexview.py}
+}
+