summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2021-01-28 19:37:48 +0100
committerStephan Springer2021-01-28 19:37:48 +0100
commit60e4eb5087494189ce0554ee626fc9793f3aff60 (patch)
treecab252e7532af7d0c2a1a95fb0541b1763d821cd
parent0d318f8b71243971919aec809046b1eee5153a7a (diff)
downloadaur-60e4eb5087494189ce0554ee626fc9793f3aff60.tar.gz
update to version 3.10.14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c757bd85bed..f441bf71954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis-ltr
pkgdesc = Geographic Information System (GIS); Long Term Release
- pkgver = 3.10.13
+ pkgver = 3.10.14
pkgrel = 1
url = https://qgis.org/
arch = x86_64
@@ -9,17 +9,17 @@ pkgbase = qgis-ltr
makedepends = ninja
makedepends = fcgi
makedepends = gsl
+ makedepends = python-setuptools
makedepends = python-six
makedepends = qt5-tools
makedepends = txt2tags
- makedepends = sip
- makedepends = python-setuptools
- depends = desktop-file-utils
+ makedepends = sip4
depends = exiv2
depends = gdal
depends = hicolor-icon-theme
depends = libzip
depends = python-qscintilla-qt5
+ depends = python-sip4
depends = qca
depends = qt5-3d
depends = qt5-serialport
@@ -27,7 +27,6 @@ pkgbase = qgis-ltr
depends = qtkeychain
depends = qwtpolar
depends = spatialindex
- depends = python-sip
optdepends = fcgi: Map server
optdepends = gpsbabel: GPS Tools plugin
optdepends = gsl: Georeferencer plugin
@@ -38,12 +37,12 @@ pkgbase = qgis-ltr
optdepends = python-pygments: MetaSearch plugin
optdepends = python-numpy: Processing plugin
optdepends = python-yaml: Processing plugin
- provides = qgis=3.10.13
+ provides = qgis=3.10.14
conflicts = qgis
- source = https://qgis.org/downloads/qgis-3.10.13.tar.bz2
+ source = https://qgis.org/downloads/qgis-3.10.14.tar.bz2
source = qgis-pyqt5-sip5.patch
source = t2t-toc-level.patch
- sha256sums = 1434f64906a53caf833919a21d8664fc6712de29e519d5f439a9b1ddc325431e
+ sha256sums = add0a24cb6ec0ed5120cdcfceb478d5941936c7187ed85f2f7e7d22628e36131
sha256sums = 47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981
sha256sums = f7e91914cfe366a63383b39c63d5731f6f20a1a0a0d7e9f3d16809a40bb5acff
diff --git a/PKGBUILD b/PKGBUILD
index 5d904a4b31b..17000b723d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,15 @@
_pkgname=qgis
pkgname="$_pkgname"-ltr
-pkgver=3.10.13
+pkgver=3.10.14
pkgrel=1
pkgdesc='Geographic Information System (GIS); Long Term Release'
url='https://qgis.org/'
license=(GPL)
arch=(x86_64)
-depends=(desktop-file-utils exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
- qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex python-sip)
-makedepends=(cmake ninja fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
+depends=(exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 python-sip4 qca qt5-3d
+ qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex)
+makedepends=(cmake ninja fcgi gsl python-setuptools python-six qt5-tools txt2tags sip4)
optdepends=('fcgi: Map server'
'gpsbabel: GPS Tools plugin'
'gsl: Georeferencer plugin'
@@ -35,7 +35,7 @@ source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2"
t2t-toc-level.patch
)
# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.sha256
-sha256sums=('1434f64906a53caf833919a21d8664fc6712de29e519d5f439a9b1ddc325431e'
+sha256sums=('add0a24cb6ec0ed5120cdcfceb478d5941936c7187ed85f2f7e7d22628e36131'
'47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981'
'f7e91914cfe366a63383b39c63d5731f6f20a1a0a0d7e9f3d16809a40bb5acff')
@@ -47,8 +47,7 @@ prepare() {
}
build() {
- cd build
- cmake -G Ninja ../"$_pkgname-$pkgver" \
+ cmake -B build "$_pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_3D=TRUE \
-DWITH_SERVER=TRUE \
@@ -57,9 +56,9 @@ build() {
-DQGIS_MANUAL_SUBDIR=share/man \
-DWITH_QWTPOLAR=TRUE \
-DWITH_INTERNAL_QWTPOLAR=FALSE
- cmake --build .
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}