summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2020-02-29 00:02:14 +0100
committerStephan Springer2020-02-29 00:02:14 +0100
commit1d9c71b6ccdb2fca29f9fcd09134ba7ae9efc333 (patch)
tree66f80d6b434c808bea7ede54375f6127f7f43ab7
parent629b25b8d3a726f4a56ffaeef3ba7b76d2c367f8 (diff)
downloadaur-1d9c71b6ccdb2fca29f9fcd09134ba7ae9efc333.tar.gz
update to version 3.10.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d33750ea92..e87c444b81e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis-ltr
pkgdesc = Geographic Information System (GIS); Long Term Release
- pkgver = 3.4.15
+ pkgver = 3.10.3
pkgrel = 1
url = https://qgis.org/
arch = x86_64
@@ -8,12 +8,13 @@ pkgbase = qgis-ltr
makedepends = cmake
makedepends = fcgi
makedepends = gsl
- makedepends = python-setuptools
makedepends = python-six
makedepends = qt5-tools
makedepends = txt2tags
makedepends = sip
+ makedepends = python-setuptools
depends = desktop-file-utils
+ depends = exiv2
depends = gdal
depends = hicolor-icon-theme
depends = libzip
@@ -22,7 +23,6 @@ pkgbase = qgis-ltr
depends = qt5-3d
depends = qt5-serialport
depends = qt5-webkit
- depends = qt5-xmlpatterns
depends = qtkeychain
depends = qwtpolar
depends = spatialindex
@@ -37,10 +37,10 @@ pkgbase = qgis-ltr
optdepends = python-pygments: MetaSearch plugin
optdepends = python-numpy: Processing plugin
optdepends = python-yaml: Processing plugin
- provides = qgis=3.4.15
+ provides = qgis=3.10.3
conflicts = qgis
- source = https://qgis.org/downloads/qgis-3.4.15.tar.bz2
- md5sums = fa934484202c0901ce839da43ae95b88
+ source = https://qgis.org/downloads/qgis-3.10.3.tar.bz2
+ sha256sums = 0869704df9120dd642996ff1ed50213ac8247650aa0640b62f8c9c581c05d7a7
pkgname = qgis-ltr
diff --git a/PKGBUILD b/PKGBUILD
index 0313a3d7c79..5e4b934e6ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,17 @@
# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
# Contributor: Eric Forgeot <http://esclinux.tk>
-# Globe Plugin and Map Server are disabled in cmake by default.
-# Uncomment them in the build() portion if you'd like them enabled.
-# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
-
_pkgname=qgis
pkgname="$_pkgname"-ltr
-pkgver=3.4.15
+pkgver=3.10.3
pkgrel=1
pkgdesc='Geographic Information System (GIS); Long Term Release'
url='https://qgis.org/'
license=(GPL)
arch=(x86_64)
-depends=(desktop-file-utils gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
- qt5-serialport qt5-webkit qt5-xmlpatterns qtkeychain qwtpolar spatialindex python-sip)
-makedepends=(cmake fcgi gsl python-setuptools python-six qt5-tools txt2tags sip)
+depends=(desktop-file-utils exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
+ qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex python-sip)
+makedepends=(cmake fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
optdepends=('fcgi: Map server'
'gpsbabel: GPS Tools plugin'
'gsl: Georeferencer plugin'
@@ -35,8 +31,8 @@ optdepends=('fcgi: Map server'
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2")
-# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.md5
-md5sums=('fa934484202c0901ce839da43ae95b88')
+# curl https://qgis.org/downloads/qgis-latest-ltr.tar.bz2.sha256
+sha256sums=('0869704df9120dd642996ff1ed50213ac8247650aa0640b62f8c9c581c05d7a7')
prepare() {
mkdir -p build