summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2019-10-12 18:32:15 -0400
committerRoss Whitfield2019-10-12 18:32:15 -0400
commit649b83ac7f945fef2b5760693becd7d71cf461fa (patch)
tree506483c1d942fa89296e9b05599359e6367c208d
parentf70e5aca83b501c4a200b3e5bce2260401b087bd (diff)
downloadaur-649b83ac7f945fef2b5760693becd7d71cf461fa.tar.gz
Bump to v0.11.0 and drop python 2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 12 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3153060e7f3..467091f5a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,12 @@
pkgbase = python-nexpy
pkgdesc = NeXpy: A Python GUI to analyze NeXus data
- pkgver = 0.10.10
- pkgrel = 2
+ pkgver = 0.11.0
+ pkgrel = 1
url = http://nexpy.github.io/nexpy
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
makedepends = python-six
- makedepends = python2-six
- source = https://github.com/nexpy/nexpy/archive/v0.10.10.tar.gz
- md5sums = 43bfc04c709eb5b8605215ed182af716
-
-pkgname = python-nexpy
depends = python-numpy
depends = python-h5py
depends = python-scipy
@@ -20,13 +14,8 @@ pkgname = python-nexpy
depends = jupyter
depends = python-matplotlib
depends = python-ansi2html
+ source = https://github.com/nexpy/nexpy/archive/v0.11.0.tar.gz
+ md5sums = 521fe3378577dbc0578d412aa71d3a3b
-pkgname = python2-nexpy
- depends = python2-numpy
- depends = python2-h5py
- depends = python2-scipy
- depends = python2-nexusformat
- depends = ipython2-notebook
- depends = python2-matplotlib
- depends = python2-subprocess32
+pkgname = python-nexpy
diff --git a/PKGBUILD b/PKGBUILD
index 8dca5c58604..2b12aed3d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,19 @@
# Maintainer: Ross Whitfield <whitfieldre@ornl.gov>
-pkgname=('python-nexpy' 'python2-nexpy')
+pkgname='python-nexpy'
_pkgname=nexpy
-pkgver=0.10.10
-pkgrel=2
+pkgver=0.11.0
+pkgrel=1
pkgdesc="NeXpy: A Python GUI to analyze NeXus data"
url="http://nexpy.github.io/nexpy"
arch=("any")
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-six' 'python2-six')
+makedepends=('python-setuptools' 'python-six')
+depends=('python-numpy' 'python-h5py' 'python-scipy' 'python-nexusformat' 'jupyter' 'python-matplotlib' 'python-ansi2html')
source=("https://github.com/nexpy/nexpy/archive/v${pkgver}.tar.gz")
-md5sums=('43bfc04c709eb5b8605215ed182af716')
+md5sums=('521fe3378577dbc0578d412aa71d3a3b')
-prepare() {
- cp -a "${srcdir}/$_pkgname-$pkgver"{,-py2}
-}
-
-package_python-nexpy() {
- depends=('python-numpy' 'python-h5py' 'python-scipy' 'python-nexusformat' 'jupyter' 'python-matplotlib' 'python-ansi2html')
+package() {
cd "$srcdir/$_pkgname-$pkgver"
sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
python setup.py install --root="$pkgdir/" --optimize=1
}
-
-package_python2-nexpy() {
- depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib' 'python2-subprocess32')
- cd "$srcdir/$_pkgname-$pkgver-py2"
- sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
- sed -i '/ansi2html/d' src/nexpy/requires.py # remove ansi2html from requires
- python2 setup.py install --root="$pkgdir/" --optimize=1
- # Conflict with python3 version
- mv $pkgdir/usr/bin/nexpy{,2}
-}