summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2017-01-17 11:38:56 -0500
committerRoss Whitfield2017-01-17 11:38:56 -0500
commit5819a6c7d549ba62af3f0a2581ea1db273707274 (patch)
treeeec5b6df8dd84bcb8b048fffeba5c6ff39529d0c
parentd4e894c260af9aeec70bddc813d83644d21837cb (diff)
downloadaur-5819a6c7d549ba62af3f0a2581ea1db273707274.tar.gz
Update to 0.9.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6b7773a79c..9537429c8cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-nexpy
pkgdesc = NeXpy: A Python GUI to analyze NeXus data
- pkgver = 0.9.0
+ pkgver = 0.9.2
pkgrel = 1
url = http://nexpy.github.io/nexpy
arch = any
@@ -9,8 +9,8 @@ pkgbase = python-nexpy
makedepends = python2-setuptools
makedepends = python-six
makedepends = python2-six
- source = https://github.com/nexpy/nexpy/archive/v0.9.0.tar.gz
- md5sums = 4d452f1fee93ca32a6e444fc685d9073
+ source = https://github.com/nexpy/nexpy/archive/v0.9.2.tar.gz
+ md5sums = 6b686a2810e488ad8a291aabd06eca9e
pkgname = python-nexpy
depends = python-numpy
@@ -27,4 +27,5 @@ pkgname = python2-nexpy
depends = python2-nexusformat
depends = ipython2-notebook
depends = python2-matplotlib
+ depends = python2-subprocess32
diff --git a/PKGBUILD b/PKGBUILD
index c7f5fd7a344..95844950f95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ross Whitfield <whitfieldre@ornl.gov>
pkgname=('python-nexpy' 'python2-nexpy')
_pkgname=nexpy
-pkgver=0.9.0
+pkgver=0.9.2
pkgrel=1
pkgdesc="NeXpy: A Python GUI to analyze NeXus data"
url="http://nexpy.github.io/nexpy"
@@ -9,7 +9,7 @@ arch=("any")
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python-six' 'python2-six')
source=("https://github.com/nexpy/nexpy/archive/v${pkgver}.tar.gz")
-md5sums=('4d452f1fee93ca32a6e444fc685d9073')
+md5sums=('6b686a2810e488ad8a291aabd06eca9e')
prepare() {
cp -a "${srcdir}/$_pkgname-$pkgver"{,-py2}
@@ -23,7 +23,7 @@ package_python-nexpy() {
}
package_python2-nexpy() {
- depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib')
+ depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib' 'python2-subprocess32')
cd "$srcdir/$_pkgname-$pkgver-py2"
sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
python2 setup.py install --root="$pkgdir/" --optimize=1