summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-08-03 10:05:02 +0200
committerPhilipp A2020-08-03 10:05:02 +0200
commitc468669b00bb342f3989760f97cbd6d99afff355 (patch)
tree1015d3ea9f6c2068417615e9fcc83f7083a80212
parentbc6c6672336eaa0e596e3cd949b77ff12a1cf699 (diff)
downloadaur-c468669b00bb342f3989760f97cbd6d99afff355.tar.gz
v0.7.3
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD60
3 files changed, 33 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8308ab56ecc..db46707f2c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,19 @@
pkgbase = python-adjusttext
- pkgdesc = A small library for automatically adjusting text position in matplotlib plots to minimize overlaps
- pkgver = 0.7
+ pkgdesc = Iteratively adjust text position in matplotlib plots to minimize overlaps
+ pkgver = 0.7.3
pkgrel = 1
- url = https://github.com/meowklaski/adjustText
+ url = https://github.com/Phlya/adjustText
arch = any
license = MIT
- makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
- options = !emptydirs
- source = python-adjusttext-0.7.tar.gz::https://pypi.io/packages/source/a/adjustText/adjustText-0.7.tar.gz
- source = https://raw.githubusercontent.com/Phlya/adjustText/0.7/LICENSE
- sha256sums = 9343d42777b43a0383327b3124172a83a0a66926a386b7a87413f8e719b4b6bf
- sha256sums = 443687f058d5f541952ab9bcd6f836d9843ac13b93b8a6b1097eb0832d2314fa
-
-pkgname = python-adjusttext
depends = python
depends = python-matplotlib
depends = python-numpy
+ options = !emptydirs
+ source = python-adjusttext-0.7.3.tar.gz::https://pypi.io/packages/source/a/adjustText/adjustText-0.7.3.tar.gz
+ source = https://raw.githubusercontent.com/Phlya/adjustText/0.7.3/LICENSE
+ sha256sums = b90e275a95b4d980cbbac7967914b8d66477c09bc346a0b3c9e2125bba664b06
+ sha256sums = 443687f058d5f541952ab9bcd6f836d9843ac13b93b8a6b1097eb0832d2314fa
-pkgname = python2-adjusttext
- depends = python2
- depends = python2-matplotlib
- depends = python2-numpy
+pkgname = python-adjusttext
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 00000000000..bbb5c46edd0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+/*.pkg.*
+/LICENSE
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index ab7cecaf25b..fb0b85b6241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,34 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
_name=adjustText
-pkgbase='python-adjusttext'
-pkgname=('python-adjusttext' 'python2-adjusttext')
-pkgver=0.7
+pkgname='python-adjusttext'
+pkgver=0.7.3
pkgrel=1
-pkgdesc=" A small library for automatically adjusting text position in matplotlib plots to minimize overlaps"
-arch=('any')
-url=https://github.com/meowklaski/"${_name}"
-license=('MIT')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
+pkgdesc='Iteratively adjust text position in matplotlib plots to minimize overlaps'
+arch=(any)
+url="https://github.com/Phlya/$_name"
+license=(MIT)
+depends=(python python-matplotlib python-numpy)
+makedepends=(python-setuptools)
options=(!emptydirs)
source=(
- "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
- https://raw.githubusercontent.com/Phlya/"${_name}"/"${pkgver}"/LICENSE
-)
-sha256sums=(
- '9343d42777b43a0383327b3124172a83a0a66926a386b7a87413f8e719b4b6bf'
- '443687f058d5f541952ab9bcd6f836d9843ac13b93b8a6b1097eb0832d2314fa'
+ "$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/Phlya/$_name/$pkgver/LICENSE"
)
+sha256sums=('b90e275a95b4d980cbbac7967914b8d66477c09bc346a0b3c9e2125bba664b06'
+ '443687f058d5f541952ab9bcd6f836d9843ac13b93b8a6b1097eb0832d2314fa')
prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
-}
-
-package() {
- cd "${srcdir}"/"${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
-}
-
-build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
- python setup.py build
-
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
+ cp -a "${_name}"-"${pkgver}"{,-py2}
}
-package_python2-adjusttext() {
- depends=('python2' 'python2-matplotlib' 'python2-numpy')
-
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+build() {
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
}
package_python-adjusttext() {
- depends=('python' 'python-matplotlib' 'python-numpy')
-
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}