summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-06-14 17:05:19 +0200
committersL1pKn072021-06-14 17:05:19 +0200
commite081c98840cdcdd539e875fd4eacd4ac01b4640b (patch)
treec4d2e15e48748224f3fe0a8ae8a9a69e97682229
parent4f4a24b65c68fbc1bf4e4a2538a1b03ce3a62fe7 (diff)
downloadaur-e081c98840cdcdd539e875fd4eacd4ac01b4640b.tar.gz
bump
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1ce100ebf4..37a6b0a55bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = pipewire-git
pkgrel = 1
url = https://pipewire.org
arch = x86_64
- license = LGPL
+ license = MIT
checkdepends = desktop-file-utils
makedepends = git
makedepends = meson
@@ -27,14 +27,14 @@ pkgbase = pipewire-git
makedepends = libfdk-aac
makedepends = libcamera-git
makedepends = vulkan-headers
- makedepends = webrtc-audio-processing
makedepends = avahi
+ makedepends = webrtc-audio-processing
source = git+https://gitlab.freedesktop.org/pipewire/pipewire.git
sha256sums = SKIP
pkgname = pipewire-git
install = pipewire-git.install
- depends = alsa-card-profiles-git
+ depends = alsa-card-profiles-git=0.3.30.82.gb6559289f
depends = rtkit
depends = libasound.so
depends = libbluetooth.so
@@ -78,9 +78,9 @@ pkgname = pipewire-docs-git
pkgname = pipewire-jack-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - JACK support (GIT version)
- license = LGPL
+ license = MIT
license = GPL2
- depends = pipewire-media-session
+ depends = pipewire-media-session-git=0.3.30.82.gb6559289f
depends = libpipewire-0.3.so
provides = pipewire-jack
provides = jack
@@ -93,7 +93,7 @@ pkgname = pipewire-jack-git
pkgname = pipewire-alsa-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - ALSA configuration (GIT version)
arch = any
- depends = pipewire-media-session
+ depends = pipewire-media-session-git=0.3.30.82.gb6559289f
provides = pipewire-alsa
provides = pulseaudio-alsa
conflicts = pipewire-alsa
@@ -102,7 +102,7 @@ pkgname = pipewire-pulse-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - PulseAudio replacement (GIT version)
install = pipewire-pulse.install
arch = any
- depends = pipewire-media-session
+ depends = pipewire-media-session-git=0.3.30.82.gb6559289f
depends = libpulse
provides = pipewire-pulse
provides = pulseaudio
@@ -113,16 +113,16 @@ pkgname = pipewire-pulse-git
pkgname = pipewire-ffmpeg-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - FFmpeg SPA plugin (GIT version)
- depends = pipewire
+ depends = pipewire-git=0.3.30.82.gb6559289f
depends = libpipewire-0.3.so
depends = ffmpeg
provides = pipewire-ffmpeg
conflicts = pipewire-ffmpeg
pkgname = pipewire-media-session-git
- pkgdesc = Low-latency audio/video router and processor (GIT version) - Session managerm (GIT version)
+ pkgdesc = Low-latency audio/video router and processor (GIT version) - Session manager (GIT version)
install = pipewire-media-session.install
- depends = pipewire
+ depends = pipewire-git=0.3.30.82.gb6559289f
depends = libpipewire-0.3.so
provides = pipewire-media-session
conflicts = pipewire-media-session
@@ -144,7 +144,7 @@ pkgname = alsa-card-profiles-git
pkgname = pipewire-zeroconf-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - Zeroconf support (GIT version)
- depends = pipewire
+ depends = pipewire-git=0.3.30.82.gb6559289f
depends = libpipewire-0.3.so
depends = libavahi-client.so
depends = libavahi-common.so
diff --git a/PKGBUILD b/PKGBUILD
index ee365718ba1..bff785f8c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgrel=1
pkgdesc='Low-latency audio/video router and processor (GIT version)'
arch=('x86_64')
url='https://pipewire.org'
-license=('LGPL')
+license=('MIT')
makedepends=('git'
'meson'
'doxygen'
@@ -36,8 +36,8 @@ makedepends=('git'
'libfdk-aac'
'libcamera-git'
'vulkan-headers'
- 'webrtc-audio-processing'
'avahi'
+ 'webrtc-audio-processing'
)
checkdepends=('desktop-file-utils')
source=('git+https://gitlab.freedesktop.org/pipewire/pipewire.git')
@@ -50,19 +50,11 @@ pkgver() {
prepare() {
mkdir -p build
-
- cd pipewire
-
- # Reduce docs size
- printf '%s\n' >> doc/Doxyfile.in \
- HAVE_DOT=yes DOT_IMAGE_FORMAT=svg INTERACTIVE_SVG=yes
}
build() {
cd "${srcdir}/build"
- CFLAGS+=" -Wformat"
-
arch-meson ../pipewire \
-D udevrulesdir=/usr/lib/udev/rules.d \
-D docs=enabled \
@@ -91,7 +83,7 @@ _pick() {
}
package_pipewire-git() {
- depends=('alsa-card-profiles-git'
+ depends=("alsa-card-profiles-git=${pkgver}"
'rtkit'
'libasound.so'
'libbluetooth.so'
@@ -169,7 +161,7 @@ package_pipewire-docs-git() {
package_pipewire-jack-git() {
pkgdesc+=" - JACK support (GIT version)"
license+=('GPL2') # libjackserver
- depends=('pipewire-media-session'
+ depends=("pipewire-media-session-git=${pkgver}"
"libpipewire-${pkgver:0:3}.so"
)
backup=('etc/pipewire/jack.conf')
@@ -189,7 +181,7 @@ package_pipewire-jack-git() {
package_pipewire-pulse-git() {
pkgdesc+=" - PulseAudio replacement (GIT version)"
- depends=('pipewire-media-session'
+ depends=("pipewire-media-session-git=${pkgver}"
'libpulse'
)
provides=('pipewire-pulse'
@@ -210,7 +202,7 @@ package_pipewire-pulse-git() {
package_pipewire-alsa-git() {
pkgdesc+=" - ALSA configuration (GIT version)"
- depends=('pipewire-media-session')
+ depends=("pipewire-media-session-git=${pkgver}")
provides=('pipewire-alsa'
'pulseaudio-alsa'
)
@@ -228,7 +220,7 @@ package_pipewire-alsa-git() {
package_pipewire-ffmpeg-git() {
pkgdesc+=" - FFmpeg SPA plugin (GIT version)"
- depends=('pipewire'
+ depends=("pipewire-git=${pkgver}"
"libpipewire-${pkgver:0:3}.so"
'ffmpeg'
)
@@ -241,8 +233,8 @@ package_pipewire-ffmpeg-git() {
}
package_pipewire-media-session-git() {
- pkgdesc+=" - Session managerm (GIT version)"
- depends=('pipewire'
+ pkgdesc+=" - Session manager (GIT version)"
+ depends=("pipewire-git=${pkgver}"
"libpipewire-${pkgver:0:3}.so"
)
provides=('pipewire-media-session')
@@ -273,7 +265,7 @@ package_alsa-card-profiles-git() {
package_pipewire-zeroconf-git() {
pkgdesc+=" - Zeroconf support (GIT version)"
- depends=('pipewire'
+ depends=("pipewire-git=${pkgver}"
"libpipewire-${pkgver:0:3}.so"
'libavahi-client.so'
'libavahi-common.so'