summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-12-02 22:42:10 +0100
committersL1pKn072020-12-02 22:43:42 +0100
commitd049f33fb4482d71281dcc036b28291bf1468d5e (patch)
tree2f93ccfe55f8b8fdde0eed7cebf709f109248a0f
parentecfd31e4c0151b8fe3811eee8aab507ca2d447b5 (diff)
downloadaur-d049f33fb4482d71281dcc036b28291bf1468d5e.tar.gz
bump
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
-rw-r--r--pipewire-pulse.install14
4 files changed, 43 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d13eff8a1b..42b315782b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-git
pkgdesc = Server and user space API to deal with multimedia pipelines. (GIT version)
- pkgver = 0.3.15.92.g573e2afd
+ pkgver = 0.3.17.35.g3c2ab98a
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -44,6 +44,7 @@ pkgname = pipewire-git
optdepends = pipewire-jack-git: JACK support
optdepends = pipewire-alsa-git: ALSA support
optdepends = pipewire-pulse-git: PulseAudio support
+ optdepends = pipewire-ffmpeg-git: ffmpeg support
provides = pipewire
provides = libpipewire-0.3.so
conflicts = pipewire
@@ -57,6 +58,7 @@ pkgname = pipewire-docs-git
pkgname = pipewire-jack-git
pkgdesc = Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)
+ depends = pipewire
depends = libpipewire-0.3.so
depends = libjack.so
provides = pipewire-jack
@@ -65,17 +67,23 @@ pkgname = pipewire-jack-git
pkgname = pipewire-alsa-git
pkgdesc = ALSA Configuration for PipeWire (ALSA support)(GIT version)
arch = any
+ depends = pipewire
depends = libpipewire-0.3.so
provides = pipewire-alsa
conflicts = pipewire-alsa
pkgname = pipewire-pulse-git
pkgdesc = Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)
+ install = pipewire-pulse.install
+ depends = pipewire
depends = libpipewire-0.3.so
- depends = libglib-2.0.so
+ depends = libpulse
provides = pipewire-pulse
provides = pulseaudio
+ provides = pulseaudio-bluetooth
conflicts = pipewire-pulse
+ conflicts = pulseaudio
+ conflicts = pulseaudio-bluetooth
pkgname = pipewire-ffmpeg-git
pkgdesc = Server and user space API to deal with multimedia pipelines. (FFmpeg SPA plugin)(GIT version)
diff --git a/.gitignore b/.gitignore
index a8c0ac10dde..b4b2790238c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!.SRCINFO
!PKGBUILD
!pipewire-git.install
+!pipewire-pulse.install
diff --git a/PKGBUILD b/PKGBUILD
index 9fd3c3f9472..d341401cc1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=('pipewire-git'
'pipewire-pulse-git'
'pipewire-ffmpeg-git'
)
-pkgver=0.3.15.92.g573e2afd
+pkgver=0.3.17.35.g3c2ab98a
pkgrel=1
pkgdesc='Server and user space API to deal with multimedia pipelines. (GIT version)'
arch=('x86_64')
@@ -95,6 +95,7 @@ package_pipewire-git() {
'pipewire-jack-git: JACK support'
'pipewire-alsa-git: ALSA support'
'pipewire-pulse-git: PulseAudio support'
+ 'pipewire-ffmpeg-git: ffmpeg support'
)
provides=('pipewire'
"libpipewire-${pkgver:0:3}.so"
@@ -112,6 +113,7 @@ package_pipewire-git() {
_pick docs usr/share/doc
+ _pick jack etc/pipewire/media-session.d/with-jack
_pick jack usr/bin/pw-jack usr/lib/pipewire-${pkgver:0:3}/jack
_pick jack usr/lib/spa-0.2/jack
_pick jack usr/share/man/man1/pw-jack.1
@@ -120,6 +122,7 @@ package_pipewire-git() {
rm -rv "$pkgdir"/usr/share/alsa-card-profile
_pick pulse usr/bin/pipewire-pulse usr/lib/systemd/user/pipewire-pulse*
+ _pick pulse etc/pipewire/media-session.d/with-pulseaudio
_pick ffmpeg usr/lib/spa-0.2/ffmpeg/libspa-ffmpeg.so
@@ -136,7 +139,8 @@ package_pipewire-docs-git() {
package_pipewire-jack-git() {
pkgdesc='Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)'
- depends=("libpipewire-${pkgver:0:3}.so"
+ depends=('pipewire'
+ "libpipewire-${pkgver:0:3}.so"
'libjack.so'
)
provides=('pipewire-jack')
@@ -147,7 +151,9 @@ package_pipewire-jack-git() {
package_pipewire-alsa-git() {
pkgdesc="ALSA Configuration for PipeWire (ALSA support)(GIT version)"
- depends=("libpipewire-${pkgver:0:3}.so")
+ depends=('pipewire'
+ "libpipewire-${pkgver:0:3}.so"
+ )
provides=('pipewire-alsa')
conflicts=('pipewire-alsa')
arch=('any')
@@ -158,13 +164,19 @@ package_pipewire-alsa-git() {
package_pipewire-pulse-git() {
pkgdesc='Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)'
- depends=("libpipewire-${pkgver:0:3}.so"
- 'libglib-2.0.so'
+ depends=('pipewire'
+ "libpipewire-${pkgver:0:3}.so"
+ 'libpulse'
)
provides=('pipewire-pulse'
'pulseaudio'
+ 'pulseaudio-bluetooth'
)
- conflicts=('pipewire-pulse')
+ conflicts=('pipewire-pulse'
+ 'pulseaudio'
+ 'pulseaudio-bluetooth'
+ )
+ install=pipewire-pulse.install
mv pulse/* "${pkgdir}"
}
diff --git a/pipewire-pulse.install b/pipewire-pulse.install
new file mode 100644
index 00000000000..051abb3a0c7
--- /dev/null
+++ b/pipewire-pulse.install
@@ -0,0 +1,14 @@
+post_install() {
+ # Enable socket by default
+ systemctl --global enable pipewire-pulse.socket
+}
+
+post_upgrade() {
+ if (( $(vercmp $2 0.3.16-1) < 0)); then
+ systemctl --global enable pipewire-pulse.socket
+ fi
+}
+
+pre_remove() {
+ systemctl --global disable pipewire-pulse.socket
+}