summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-06-14 16:15:04 +0200
committersL1pKn072021-06-14 16:15:04 +0200
commitbf78fdb9d3dee89af2caa8428eff973f60e1e2b4 (patch)
tree5020ef924f07955e70fdcd3f5cdbba6347eca556
parente646d6320464f8f933a79f6a59ed0dfe7ed4199c (diff)
downloadaur-bf78fdb9d3dee89af2caa8428eff973f60e1e2b4.tar.gz
bump
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 48 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9bb8dffaf7..3403b03bc6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-git
pkgdesc = Low-latency audio/video router and processor (GIT version)
- pkgver = 0.3.27.132.gcdfd50e1
+ pkgver = 0.3.30.82.gb6559289f
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -27,6 +27,7 @@ pkgbase = pipewire-git
makedepends = libfdk-aac
makedepends = libcamera-git
makedepends = vulkan-headers
+ makedepends = webrtc-audio-processing
source = git+https://gitlab.freedesktop.org/pipewire/pipewire.git
sha256sums = SKIP
@@ -47,6 +48,7 @@ pkgname = pipewire-git
depends = libudev.so
depends = libvulkan.so
depends = libcamera-git
+ depends = libwebrtc_audio_processing.so
optdepends = pipewire-docs-git: Documentation
optdepends = pipewire-jack-git: JACK support
optdepends = pipewire-alsa-git: ALSA support
@@ -54,6 +56,7 @@ pkgname = pipewire-git
optdepends = pipewire-ffmpeg-git: ffmpeg support
optdepends = pipewire-media-session-git: Default session manager
optdepends = gst-plugin-pipewire-git: gstreamer support
+ optdepends = pipewire-zeroconf-git: Zeroconf support
provides = pipewire
provides = libpipewire-0.3.so
conflicts = pipewire
@@ -74,6 +77,8 @@ pkgname = pipewire-docs-git
pkgname = pipewire-jack-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - JACK support (GIT version)
+ license = LGPL
+ license = GPL2
depends = pipewire-media-session
depends = libpipewire-0.3.so
provides = pipewire-jack
@@ -132,6 +137,13 @@ pkgname = pipewire-media-session-git
pkgname = alsa-card-profiles-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - ALSA card profiles (GIT version)
arch = any
+ license = LGPL
provides = alsa-card-profiles
conflicts = alsa-card-profiles
+pkgname = pipewire-zeroconf-git
+ pkgdesc = Low-latency audio/video router and processor (GIT version) - Zeroconf support (GIT version)
+ depends = pipewire
+ depends = libpipewire-0.3.so
+ depends = libavahi-client.so
+ depends = libavahi-common.so
diff --git a/PKGBUILD b/PKGBUILD
index 0982bb90e44..2003a87cbe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,9 @@ pkgname=('pipewire-git'
'pipewire-ffmpeg-git'
'pipewire-media-session-git'
'alsa-card-profiles-git'
+ 'pipewire-zeroconf-git'
)
-pkgver=0.3.27.132.gcdfd50e1
+pkgver=0.3.30.82.gb6559289f
pkgrel=1
pkgdesc='Low-latency audio/video router and processor (GIT version)'
arch=('x86_64')
@@ -35,6 +36,7 @@ makedepends=('git'
'libfdk-aac'
'libcamera-git'
'vulkan-headers'
+ 'webrtc-audio-processing'
)
checkdepends=('desktop-file-utils')
source=('git+https://gitlab.freedesktop.org/pipewire/pipewire.git')
@@ -103,6 +105,7 @@ package_pipewire-git() {
'libudev.so'
'libvulkan.so'
'libcamera-git'
+ 'libwebrtc_audio_processing.so'
)
optdepends=('pipewire-docs-git: Documentation'
'pipewire-jack-git: JACK support'
@@ -111,6 +114,7 @@ package_pipewire-git() {
'pipewire-ffmpeg-git: ffmpeg support'
'pipewire-media-session-git: Default session manager'
'gst-plugin-pipewire-git: gstreamer support'
+ 'pipewire-zeroconf-git: Zeroconf support'
)
provides=('pipewire'
"libpipewire-${pkgver:0:3}.so"
@@ -143,6 +147,8 @@ package_pipewire-git() {
_pick ffmpeg usr/lib/spa-0.2/ffmpeg/libspa-ffmpeg.so
+ _pick zeroconf "usr/lib/pipewire-${pkgver:0:3}/libpipewire-module-zeroconf-discover.so"
+
}
package_pipewire-docs-git() {
@@ -152,10 +158,13 @@ package_pipewire-docs-git() {
arch=('any')
mv docs/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}
package_pipewire-jack-git() {
pkgdesc+=" - JACK support (GIT version)"
+ license+=('GPL2') # libjackserver
depends=('pipewire-media-session'
"libpipewire-${pkgver:0:3}.so"
)
@@ -170,6 +179,8 @@ package_pipewire-jack-git() {
)
mv jack/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}
package_pipewire-pulse-git() {
@@ -189,6 +200,8 @@ package_pipewire-pulse-git() {
install=pipewire-pulse.install
mv pulse/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}
package_pipewire-alsa-git() {
@@ -205,6 +218,8 @@ package_pipewire-alsa-git() {
/usr/share/alsa/alsa.conf.d/{50-pipewire,99-pipewire-default}.conf
install -Dm644 /dev/null "${pkgdir}/usr/share/pipewire/media-session.d/with-alsa"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}
package_pipewire-ffmpeg-git() {
@@ -217,6 +232,8 @@ package_pipewire-ffmpeg-git() {
conflicts=('pipewire-ffmpeg')
mv ffmpeg/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}
package_pipewire-media-session-git() {
@@ -234,14 +251,30 @@ package_pipewire-media-session-git() {
install=pipewire-media-session.install
mv pms/* "${pkgdir}"
-}
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
+}
package_alsa-card-profiles-git() {
pkgdesc+=" - ALSA card profiles (GIT version)"
provides=('alsa-card-profiles')
conflicts=('alsa-card-profiles')
+ license=('LGPL')
arch=('any')
mv acp/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
+}
+
+package_pipewire-zeroconf-git() {
+ pkgdesc+=" - Zeroconf support (GIT version)"
+ depends=('pipewire'
+ "libpipewire-${pkgver:0:3}.so"
+ libavahi-{client,common}.so
+ )
+
+ mv zeroconf/* "${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 pipewire/COPYING
}