summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-07-21 15:06:14 +0200
committersL1pKn072021-07-21 15:06:14 +0200
commit5223f0f58dbf27a71b6f1f8b042b692cb1534ebd (patch)
tree7fec20b40356f1acc14066af64b265bf90cefe13
parente081c98840cdcdd539e875fd4eacd4ac01b4640b (diff)
downloadaur-5223f0f58dbf27a71b6f1f8b042b692cb1534ebd.tar.gz
bump
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD17
2 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37a6b0a55bb..e3eb73b1d4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-git
pkgdesc = Low-latency audio/video router and processor (GIT version)
- pkgver = 0.3.30.82.gb6559289f
+ pkgver = 0.3.32.8.ga33df863b
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -34,7 +34,7 @@ pkgbase = pipewire-git
pkgname = pipewire-git
install = pipewire-git.install
- depends = alsa-card-profiles-git=0.3.30.82.gb6559289f
+ depends = alsa-card-profiles-git=0.3.32.8.ga33df863b
depends = rtkit
depends = libasound.so
depends = libbluetooth.so
@@ -50,6 +50,7 @@ pkgname = pipewire-git
depends = libvulkan.so
depends = libcamera-git
depends = libwebrtc_audio_processing.so
+ depends = libusb-1.0.so
optdepends = pipewire-docs-git: Documentation
optdepends = pipewire-jack-git: JACK support
optdepends = pipewire-alsa-git: ALSA support
@@ -80,7 +81,7 @@ pkgname = pipewire-jack-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - JACK support (GIT version)
license = MIT
license = GPL2
- depends = pipewire-media-session-git=0.3.30.82.gb6559289f
+ depends = pipewire-media-session-git=0.3.32.8.ga33df863b
depends = libpipewire-0.3.so
provides = pipewire-jack
provides = jack
@@ -93,7 +94,7 @@ pkgname = pipewire-jack-git
pkgname = pipewire-alsa-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - ALSA configuration (GIT version)
arch = any
- depends = pipewire-media-session-git=0.3.30.82.gb6559289f
+ depends = pipewire-media-session-git=0.3.32.8.ga33df863b
provides = pipewire-alsa
provides = pulseaudio-alsa
conflicts = pipewire-alsa
@@ -101,9 +102,12 @@ pkgname = pipewire-alsa-git
pkgname = pipewire-pulse-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - PulseAudio replacement (GIT version)
install = pipewire-pulse.install
- arch = any
- depends = pipewire-media-session-git=0.3.30.82.gb6559289f
- depends = libpulse
+ arch = x86_64
+ depends = pipewire-media-session-git=0.3.32.8.ga33df863b
+ depends = libpipewire-0.3.so
+ depends = libpulse.so
+ depends = libavahi-client.so
+ depends = libavahi-common.so
provides = pipewire-pulse
provides = pulseaudio
provides = pulseaudio-bluetooth
@@ -113,7 +117,7 @@ pkgname = pipewire-pulse-git
pkgname = pipewire-ffmpeg-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - FFmpeg SPA plugin (GIT version)
- depends = pipewire-git=0.3.30.82.gb6559289f
+ depends = pipewire-git=0.3.32.8.ga33df863b
depends = libpipewire-0.3.so
depends = ffmpeg
provides = pipewire-ffmpeg
@@ -122,7 +126,7 @@ pkgname = pipewire-ffmpeg-git
pkgname = pipewire-media-session-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - Session manager (GIT version)
install = pipewire-media-session.install
- depends = pipewire-git=0.3.30.82.gb6559289f
+ depends = pipewire-git=0.3.32.8.ga33df863b
depends = libpipewire-0.3.so
provides = pipewire-media-session
conflicts = pipewire-media-session
@@ -144,7 +148,7 @@ pkgname = alsa-card-profiles-git
pkgname = pipewire-zeroconf-git
pkgdesc = Low-latency audio/video router and processor (GIT version) - Zeroconf support (GIT version)
- depends = pipewire-git=0.3.30.82.gb6559289f
+ depends = pipewire-git=0.3.32.8.ga33df863b
depends = libpipewire-0.3.so
depends = libavahi-client.so
depends = libavahi-common.so
diff --git a/PKGBUILD b/PKGBUILD
index bff785f8c37..659262aa24b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,5 @@
+#Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
pkgbase=pipewire-git
pkgname=('pipewire-git'
'pipewire-docs-git'
@@ -9,7 +11,7 @@ pkgname=('pipewire-git'
'alsa-card-profiles-git'
'pipewire-zeroconf-git'
)
-pkgver=0.3.30.82.gb6559289f
+pkgver=0.3.32.8.ga33df863b
pkgrel=1
pkgdesc='Low-latency audio/video router and processor (GIT version)'
arch=('x86_64')
@@ -38,6 +40,7 @@ makedepends=('git'
'vulkan-headers'
'avahi'
'webrtc-audio-processing'
+# 'roc-git'
)
checkdepends=('desktop-file-utils')
source=('git+https://gitlab.freedesktop.org/pipewire/pipewire.git')
@@ -61,6 +64,7 @@ build() {
-D jack=disabled \
-D gstreamer=disabled \
-D gstreamer-device-provider=disabled \
+ -D roc=disabled \
-D ffmpeg=enabled \
-D jack-devel=enabled \
-D libjack-path=/usr/lib
@@ -99,6 +103,7 @@ package_pipewire-git() {
'libvulkan.so'
'libcamera-git'
'libwebrtc_audio_processing.so'
+ 'libusb-1.0.so'
)
optdepends=('pipewire-docs-git: Documentation'
'pipewire-jack-git: JACK support'
@@ -136,7 +141,10 @@ package_pipewire-git() {
_pick jack usr/share/pipewire/{jack.conf,media-session.d/with-jack}
_pick jack usr/share/man/man1/pw-jack.1
+ _pick pulse usr/bin/pipewire-pulse
+ _pick pulse "usr/lib/pipewire-${pkgver:0:3}/libpipewire-module-protocol-pulse.so"
_pick pulse "usr/lib/pipewire-${pkgver:0:3}/libpipewire-module-pulse-tunnel.so"
+ _pick pulse usr/lib/systemd/user/pipewire-pulse.*
_pick pulse usr/share/pipewire/media-session.d/with-pulseaudio
_pick ffmpeg usr/lib/spa-0.2/ffmpeg/libspa-ffmpeg.so
@@ -182,7 +190,10 @@ package_pipewire-jack-git() {
package_pipewire-pulse-git() {
pkgdesc+=" - PulseAudio replacement (GIT version)"
depends=("pipewire-media-session-git=${pkgver}"
- 'libpulse'
+ "libpipewire-${pkgver:0:3}.so"
+ 'libpulse.so'
+ 'libavahi-client.so'
+ 'libavahi-common.so'
)
provides=('pipewire-pulse'
'pulseaudio'
@@ -192,7 +203,7 @@ package_pipewire-pulse-git() {
'pulseaudio'
'pulseaudio-bluetooth'
)
- arch=('any')
+ arch=('x86_64')
install=pipewire-pulse.install
mv pulse/* "${pkgdir}"