summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-02-11 17:07:08 +0100
committersL1pKn072021-02-11 17:07:08 +0100
commit31de2734ce9d76bba8e2bb83fc4b0398a97dbbd1 (patch)
tree03cbc10d700ae9fcddcf5399ab4cf5bf1a8c138e
parent541a8a3f828ac4d032ea4c762e048015b5bb7a97 (diff)
downloadaur-31de2734ce9d76bba8e2bb83fc4b0398a97dbbd1.tar.gz
bump
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 128694c77f7..af9fab38682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-git
pkgdesc = Server and user space API to deal with multimedia pipelines. (GIT version)
- pkgver = 0.3.20.9.g73896bfa
+ pkgver = 0.3.21.78.g6b11bf71
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -17,13 +17,11 @@ pkgbase = pipewire-git
makedepends = jack2
makedepends = sbc
makedepends = rtkit
- makedepends = vulkan-icd-loader
makedepends = dbus
makedepends = sdl2
makedepends = ncurses
makedepends = libsndfile
makedepends = bluez-libs
- makedepends = vulkan-headers
makedepends = ffmpeg
makedepends = libldac
makedepends = libopenaptx
@@ -37,7 +35,6 @@ pkgname = pipewire-git
depends = bluez-libs
depends = rtkit
depends = sbc
- depends = vulkan-icd-loader
depends = libasound.so
depends = libdbus-1.so
depends = libfdk-aac.so
@@ -63,13 +60,13 @@ pkgname = pipewire-git
backup = etc/pipewire/media-session.d/v4l2-monitor.conf
pkgname = pipewire-docs-git
- pkgdesc = Server and user space API to deal with multimedia pipelines. (documentation)(GIT Version)
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (documentation) (GIT Version)
arch = any
provides = pipewire-docs
conflicts = pipewire-docs
pkgname = pipewire-jack-git
- pkgdesc = Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (JACK support) (GIT Version)
depends = pipewire
depends = libpipewire-0.3.so
depends = libjack.so
@@ -77,7 +74,7 @@ pkgname = pipewire-jack-git
conflicts = pipewire-jack
pkgname = pipewire-alsa-git
- pkgdesc = ALSA Configuration for PipeWire (ALSA support)(GIT version)
+ pkgdesc = ALSA Configuration for PipeWire (ALSA support) (GIT version)
arch = any
depends = pipewire
depends = libpipewire-0.3.so
@@ -85,7 +82,7 @@ pkgname = pipewire-alsa-git
conflicts = pipewire-alsa
pkgname = pipewire-pulse-git
- pkgdesc = Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (Pulse support) (GIT version)
install = pipewire-pulse.install
arch = any
depends = pipewire
@@ -98,7 +95,7 @@ pkgname = pipewire-pulse-git
conflicts = pulseaudio-bluetooth
pkgname = pipewire-ffmpeg-git
- pkgdesc = Server and user space API to deal with multimedia pipelines. (FFmpeg SPA plugin)(GIT version)
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (FFmpeg SPA plugin) (GIT version)
depends = pipewire
depends = libpipewire-0.3.so
depends = ffmpeg
@@ -107,6 +104,7 @@ pkgname = pipewire-ffmpeg-git
pkgname = alsa-card-profiles-git
pkgdesc = ALSA card profiles shared by PipeWire (GIT version)
+ arch = any
provides = alsa-card-profiles
conflicts = alsa-card-profiles
diff --git a/PKGBUILD b/PKGBUILD
index ef8dcc464be..b7a9ba0b596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=('pipewire-git'
'pipewire-ffmpeg-git'
'alsa-card-profiles-git'
)
-pkgver=0.3.20.9.g73896bfa
+pkgver=0.3.21.78.g6b11bf71
pkgrel=1
pkgdesc='Server and user space API to deal with multimedia pipelines. (GIT version)'
arch=('x86_64')
@@ -24,13 +24,11 @@ makedepends=('git'
'jack2'
'sbc'
'rtkit'
- 'vulkan-icd-loader'
'dbus'
'sdl2'
'ncurses'
'libsndfile'
'bluez-libs'
- 'vulkan-headers'
'ffmpeg'
'libldac'
'libopenaptx'
@@ -88,7 +86,6 @@ package_pipewire-git() {
'bluez-libs'
'rtkit'
'sbc'
- 'vulkan-icd-loader'
'libasound.so'
'libdbus-1.so'
'libfdk-aac.so'
@@ -122,9 +119,6 @@ package_pipewire-git() {
cd "${pkgdir}"
- mkdir -p etc/alsa/conf.d
- ln -st etc/alsa/conf.d /usr/share/alsa/alsa.conf.d/50-pipewire.conf
-
_pick docs usr/share/doc
_pick jack etc/pipewire/media-session.d/with-jack
@@ -142,7 +136,7 @@ package_pipewire-git() {
}
package_pipewire-docs-git() {
- pkgdesc='Server and user space API to deal with multimedia pipelines. (documentation)(GIT Version)'
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (documentation) (GIT Version)'
provides=('pipewire-docs')
conflicts=('pipewire-docs')
arch=('any')
@@ -151,7 +145,7 @@ package_pipewire-docs-git() {
}
package_pipewire-jack-git() {
- pkgdesc='Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)'
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (JACK support) (GIT Version)'
depends=('pipewire'
"libpipewire-${pkgver:0:3}.so"
'libjack.so'
@@ -163,7 +157,7 @@ package_pipewire-jack-git() {
}
package_pipewire-pulse-git() {
- pkgdesc='Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)'
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (Pulse support) (GIT version)'
depends=('pipewire'
'libpulse'
)
@@ -182,7 +176,7 @@ package_pipewire-pulse-git() {
}
package_pipewire-alsa-git() {
- pkgdesc="ALSA Configuration for PipeWire (ALSA support)(GIT version)"
+ pkgdesc="ALSA Configuration for PipeWire (ALSA support) (GIT version)"
depends=('pipewire'
"libpipewire-${pkgver:0:3}.so"
)
@@ -190,21 +184,22 @@ package_pipewire-alsa-git() {
conflicts=('pipewire-alsa')
arch=('any')
- mkdir -p "$pkgdir"/etc/{alsa/conf.d,pipewire/media-session.d}
- ln -st "${pkgdir}/etc/alsa/conf.d" /usr/share/alsa/alsa.conf.d/99-pipewire-default.conf
- touch "$pkgdir/etc/pipewire/media-session.d/with-alsa"
+ mkdir -p "${pkgdir}"/etc/{alsa/conf.d,pipewire/media-session.d}
+ ln -st "${pkgdir}/etc/alsa/conf.d" /usr/share/alsa/alsa.conf.d/{50-pipewire,99-pipewire-default}.conf
+ touch "${pkgdir}/etc/pipewire/media-session.d/with-alsa"
}
package_alsa-card-profiles-git() {
pkgdesc="ALSA card profiles shared by PipeWire (GIT version)"
provides=('alsa-card-profiles')
conflicts=('alsa-card-profiles')
+ arch=('any')
- mv acp/* "$pkgdir"
+ mv acp/* "${pkgdir}"
}
package_pipewire-ffmpeg-git() {
- pkgdesc='Server and user space API to deal with multimedia pipelines. (FFmpeg SPA plugin)(GIT version)'
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (FFmpeg SPA plugin) (GIT version)'
depends=('pipewire'
"libpipewire-${pkgver:0:3}.so"
'ffmpeg'