summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickaël Thomas2016-01-04 17:57:51 +0100
committerMickaël Thomas2016-01-04 17:57:51 +0100
commitb38e6b71bbeb7b01206eacdfc1195939b1ee29bd (patch)
tree44f78d78fda1f8286f336e30eaed87f208631bc6
parentdc59ffcdf118e4884ef70599d3937839e5e5749e (diff)
downloadaur-b38e6b71bbeb7b01206eacdfc1195939b1ee29bd.tar.gz
Remove www. from source URLs and add stricter conflicts with php 7
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD54
2 files changed, 77 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32152e0271c..f75b6443d18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 3 21:23:01 UTC 2016
+# Mon Jan 4 16:50:23 UTC 2016
pkgbase = php56
pkgver = 5.6.16
- pkgrel = 1
- url = http://www.php.net
+ pkgrel = 2
+ url = http://php.net
arch = i686
arch = x86_64
license = PHP
@@ -31,8 +31,8 @@ pkgbase = php56
makedepends = db
makedepends = gmp
makedepends = systemd
- source = http://www.php.net/distributions/php-5.6.16.tar.xz
- source = http://www.php.net/distributions/php-5.6.16.tar.xz.asc
+ source = http://php.net/distributions/php-5.6.16.tar.xz
+ source = http://php.net/distributions/php-5.6.16.tar.xz.asc
source = php.ini.patch
source = apache.conf
source = php-fpm.conf.in.patch
@@ -54,12 +54,35 @@ pkgname = php56
depends = libxml2
depends = curl
depends = libzip
+ provides = php
+ conflicts = php>=7
+ conflicts = php-cgi>=7
+ conflicts = php-apache>=7
+ conflicts = php-fpm>=7
+ conflicts = php-embed>=7
+ conflicts = php-phpdbg>=7
+ conflicts = php-pear>=7
+ conflicts = php-enchant>=7
+ conflicts = php-gd>=7
+ conflicts = php-imap>=7
+ conflicts = php-intl>=7
+ conflicts = php-ldap>=7
+ conflicts = php-mcrypt>=7
+ conflicts = php-mssql>=7
+ conflicts = php-odbc>=7
+ conflicts = php-pgsql>=7
+ conflicts = php-pspell>=7
+ conflicts = php-snmp>=7
+ conflicts = php-sqlite>=7
+ conflicts = php-tidy>=7
+ conflicts = php-xsl>=7
backup = etc/php/php.ini
pkgname = php56-cgi
pkgdesc = CGI and FCGI SAPI for PHP
depends = php56
provides = php-cgi
+ conflicts = php>=7
conflicts = php-cgi
pkgname = php56-apache
@@ -67,6 +90,7 @@ pkgname = php56-apache
depends = php56
depends = apache
provides = php-apache
+ conflicts = php>=7
conflicts = php-apache
backup = etc/httpd/conf/extra/php5_module.conf
@@ -76,6 +100,7 @@ pkgname = php56-fpm
depends = php56
depends = systemd
provides = php-fpm
+ conflicts = php>=7
conflicts = php-fpm
backup = etc/php/php-fpm.conf
@@ -83,18 +108,21 @@ pkgname = php56-embed
pkgdesc = Embedded PHP SAPI library
depends = php56
provides = php-embed
+ conflicts = php>=7
conflicts = php-embed
pkgname = php56-phpdbg
pkgdesc = Interactive PHP debugger
depends = php56
provides = php-phpdbg
+ conflicts = php>=7
conflicts = php-phpdbg
pkgname = php56-pear
pkgdesc = PHP Extension and Application Repository
depends = php56
provides = php-pear
+ conflicts = php>=7
conflicts = php-pear
backup = etc/php/pear.conf
@@ -103,6 +131,7 @@ pkgname = php56-enchant
depends = php56
depends = enchant
provides = php-enchant
+ conflicts = php>=7
conflicts = php-enchant
pkgname = php56-gd
@@ -110,6 +139,7 @@ pkgname = php56-gd
depends = php56
depends = gd
provides = php-gd
+ conflicts = php>=7
conflicts = php-gd
pkgname = php56-imap
@@ -117,6 +147,7 @@ pkgname = php56-imap
depends = php56
depends = c-client
provides = php-imap
+ conflicts = php>=7
conflicts = php-imap
pkgname = php56-intl
@@ -124,6 +155,7 @@ pkgname = php56-intl
depends = php56
depends = icu
provides = php-intl
+ conflicts = php>=7
conflicts = php-intl
pkgname = php56-ldap
@@ -131,6 +163,7 @@ pkgname = php56-ldap
depends = php56
depends = libldap
provides = php-ldap
+ conflicts = php>=7
conflicts = php-ldap
pkgname = php56-mcrypt
@@ -139,6 +172,7 @@ pkgname = php56-mcrypt
depends = libmcrypt
depends = libltdl
provides = php-mcrypt
+ conflicts = php>=7
conflicts = php-mcrypt
pkgname = php56-mssql
@@ -146,6 +180,7 @@ pkgname = php56-mssql
depends = php56
depends = freetds
provides = php-mssql
+ conflicts = php>=7
conflicts = php-mssql
pkgname = php56-odbc
@@ -153,6 +188,7 @@ pkgname = php56-odbc
depends = php56
depends = unixodbc
provides = php-odbc
+ conflicts = php>=7
conflicts = php-odbc
pkgname = php56-pgsql
@@ -160,6 +196,7 @@ pkgname = php56-pgsql
depends = php56
depends = postgresql-libs
provides = php-pgsql
+ conflicts = php>=7
conflicts = php-pgsql
pkgname = php56-pspell
@@ -167,6 +204,7 @@ pkgname = php56-pspell
depends = php56
depends = aspell
provides = php-pspell
+ conflicts = php>=7
conflicts = php-pspell
pkgname = php56-snmp
@@ -174,6 +212,7 @@ pkgname = php56-snmp
depends = php56
depends = net-snmp
provides = php-snmp
+ conflicts = php>=7
conflicts = php-snmp
pkgname = php56-sqlite
@@ -181,6 +220,7 @@ pkgname = php56-sqlite
depends = php56
depends = sqlite
provides = php-sqlite
+ conflicts = php>=7
conflicts = php-sqlite
pkgname = php56-tidy
@@ -188,6 +228,7 @@ pkgname = php56-tidy
depends = php56
depends = tidyhtml
provides = php-tidy
+ conflicts = php>=7
conflicts = php-tidy
pkgname = php56-xsl
@@ -195,5 +236,6 @@ pkgname = php56-xsl
depends = php56
depends = libxslt
provides = php-xsl
+ conflicts = php>=7
conflicts = php-xsl
diff --git a/PKGBUILD b/PKGBUILD
index 10e4ffd277e..9049e1360a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,17 +25,21 @@ pkgname=("${pkgbase}"
"${pkgbase}-tidy"
"${pkgbase}-xsl")
pkgver=5.6.16
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
license=('PHP')
-url='http://www.php.net'
+url='http://php.net'
makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'postfix'
'sqlite' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file' 'freetds'
'libmcrypt' 'tidyhtml' 'aspell' 'libltdl' 'gd' 'icu'
'curl' 'libxslt' 'openssl' 'db' 'gmp' 'systemd')
+
+_conflicts=("${pkgname[@]/$pkgbase/$_pkgbase}")
+_conflicts=("${_conflicts[@]/%/>=7}")
+
#checkdepends=('procps-ng')
-source=("http://www.php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"
- "http://www.php.net/distributions/${_pkgbase}-${pkgver}.tar.xz.asc"
+source=("http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"
+ "http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz.asc"
'php.ini.patch' 'apache.conf' 'php-fpm.conf.in.patch'
'logrotate.d.php-fpm' 'php-fpm.service' 'php-fpm.tmpfiles')
md5sums=('3f1d999ed1f9cb5713c9a0161c557f2f'
@@ -239,6 +243,8 @@ package_php56() {
pkgdesc='An HTML-embedded scripting language'
depends=('pcre' 'libxml2' 'curl' 'libzip')
backup=('etc/php/php.ini')
+ conflicts=("${_conflicts[@]}")
+ provides=('php')
cd ${srcdir}/build-php
make -j1 INSTALL_ROOT=${pkgdir} install
@@ -261,7 +267,7 @@ package_php56-cgi() {
pkgdesc='CGI and FCGI SAPI for PHP'
depends=("${pkgbase}")
provides=('php-cgi')
- conflicts=('php-cgi')
+ conflicts=('php>=7' 'php-cgi')
install -D -m755 ${srcdir}/build-cgi/sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi
}
@@ -270,7 +276,7 @@ package_php56-apache() {
pkgdesc='Apache SAPI for PHP'
depends=("${pkgbase}" 'apache')
provides=('php-apache')
- conflicts=('php-apache')
+ conflicts=('php>=7' 'php-apache')
backup=('etc/httpd/conf/extra/php5_module.conf')
install -D -m755 ${srcdir}/build-apache/libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so
@@ -281,7 +287,7 @@ package_php56-fpm() {
pkgdesc='FastCGI Process Manager for PHP'
depends=("${pkgbase}" 'systemd')
provides=('php-fpm')
- conflicts=('php-fpm')
+ conflicts=('php>=7' 'php-fpm')
backup=('etc/php/php-fpm.conf')
install='php-fpm.install'
@@ -298,7 +304,7 @@ package_php56-embed() {
pkgdesc='Embedded PHP SAPI library'
depends=("${pkgbase}")
provides=('php-embed')
- conflicts=('php-embed')
+ conflicts=('php>=7' 'php-embed')
install -D -m755 ${srcdir}/build-embed/libs/libphp5.so ${pkgdir}/usr/lib/libphp5.so
install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/sapi/embed/php_embed.h ${pkgdir}/usr/include/php/sapi/embed/php_embed.h
@@ -308,7 +314,7 @@ package_php56-phpdbg() {
pkgdesc='Interactive PHP debugger'
depends=("${pkgbase}")
provides=('php-phpdbg')
- conflicts=('php-phpdbg')
+ conflicts=('php>=7' 'php-phpdbg')
install -D -m755 ${srcdir}/build-phpdbg/sapi/phpdbg/phpdbg ${pkgdir}/usr/bin/phpdbg
}
@@ -317,7 +323,7 @@ package_php56-pear() {
pkgdesc='PHP Extension and Application Repository'
depends=("${pkgbase}")
provides=('php-pear')
- conflicts=('php-pear')
+ conflicts=('php>=7' 'php-pear')
backup=('etc/php/pear.conf')
cd ${srcdir}/build-pear
@@ -329,7 +335,7 @@ package_php56-enchant() {
pkgdesc='enchant module for PHP'
depends=("${pkgbase}" 'enchant')
provides=('php-enchant')
- conflicts=('php-enchant')
+ conflicts=('php>=7' 'php-enchant')
install -D -m755 ${srcdir}/build-php/modules/enchant.so ${pkgdir}/usr/lib/php/modules/enchant.so
}
@@ -338,7 +344,7 @@ package_php56-gd() {
pkgdesc='gd module for PHP'
depends=("${pkgbase}" 'gd')
provides=('php-gd')
- conflicts=('php-gd')
+ conflicts=('php>=7' 'php-gd')
install -D -m755 ${srcdir}/build-php/modules/gd.so ${pkgdir}/usr/lib/php/modules/gd.so
}
@@ -347,7 +353,7 @@ package_php56-imap() {
pkgdesc='imap module for PHP'
depends=("${pkgbase}" 'c-client')
provides=('php-imap')
- conflicts=('php-imap')
+ conflicts=('php>=7' 'php-imap')
install -D -m755 ${srcdir}/build-php/modules/imap.so ${pkgdir}/usr/lib/php/modules/imap.so
}
@@ -356,7 +362,7 @@ package_php56-intl() {
pkgdesc='intl module for PHP'
depends=("${pkgbase}" 'icu')
provides=('php-intl')
- conflicts=('php-intl')
+ conflicts=('php>=7' 'php-intl')
install -D -m755 ${srcdir}/build-php/modules/intl.so ${pkgdir}/usr/lib/php/modules/intl.so
}
@@ -365,7 +371,7 @@ package_php56-ldap() {
pkgdesc='ldap module for PHP'
depends=("${pkgbase}" 'libldap')
provides=('php-ldap')
- conflicts=('php-ldap')
+ conflicts=('php>=7' 'php-ldap')
install -D -m755 ${srcdir}/build-php/modules/ldap.so ${pkgdir}/usr/lib/php/modules/ldap.so
}
@@ -374,7 +380,7 @@ package_php56-mcrypt() {
pkgdesc='mcrypt module for PHP'
depends=("${pkgbase}" 'libmcrypt' 'libltdl')
provides=('php-mcrypt')
- conflicts=('php-mcrypt')
+ conflicts=('php>=7' 'php-mcrypt')
install -D -m755 ${srcdir}/build-php/modules/mcrypt.so ${pkgdir}/usr/lib/php/modules/mcrypt.so
}
@@ -383,7 +389,7 @@ package_php56-mssql() {
pkgdesc='mssql module for PHP'
depends=("${pkgbase}" 'freetds')
provides=('php-mssql')
- conflicts=('php-mssql')
+ conflicts=('php>=7' 'php-mssql')
install -D -m755 ${srcdir}/build-php/modules/mssql.so ${pkgdir}/usr/lib/php/modules/mssql.so
}
@@ -392,7 +398,7 @@ package_php56-odbc() {
pkgdesc='ODBC modules for PHP'
depends=("${pkgbase}" 'unixodbc')
provides=('php-odbc')
- conflicts=('php-odbc')
+ conflicts=('php>=7' 'php-odbc')
install -D -m755 ${srcdir}/build-php/modules/odbc.so ${pkgdir}/usr/lib/php/modules/odbc.so
install -D -m755 ${srcdir}/build-php/modules/pdo_odbc.so ${pkgdir}/usr/lib/php/modules/pdo_odbc.so
@@ -402,7 +408,7 @@ package_php56-pgsql() {
pkgdesc='PostgreSQL modules for PHP'
depends=("${pkgbase}" 'postgresql-libs')
provides=('php-pgsql')
- conflicts=('php-pgsql')
+ conflicts=('php>=7' 'php-pgsql')
install -D -m755 ${srcdir}/build-php/modules/pgsql.so ${pkgdir}/usr/lib/php/modules/pgsql.so
install -D -m755 ${srcdir}/build-php/modules/pdo_pgsql.so ${pkgdir}/usr/lib/php/modules/pdo_pgsql.so
@@ -412,7 +418,7 @@ package_php56-pspell() {
pkgdesc='pspell module for PHP'
depends=("${pkgbase}" 'aspell')
provides=('php-pspell')
- conflicts=('php-pspell')
+ conflicts=('php>=7' 'php-pspell')
install -D -m755 ${srcdir}/build-php/modules/pspell.so ${pkgdir}/usr/lib/php/modules/pspell.so
}
@@ -421,7 +427,7 @@ package_php56-snmp() {
pkgdesc='snmp module for PHP'
depends=("${pkgbase}" 'net-snmp')
provides=('php-snmp')
- conflicts=('php-snmp')
+ conflicts=('php>=7' 'php-snmp')
install -D -m755 ${srcdir}/build-php/modules/snmp.so ${pkgdir}/usr/lib/php/modules/snmp.so
}
@@ -430,7 +436,7 @@ package_php56-sqlite() {
pkgdesc='sqlite module for PHP'
depends=("${pkgbase}" 'sqlite')
provides=('php-sqlite')
- conflicts=('php-sqlite')
+ conflicts=('php>=7' 'php-sqlite')
install -D -m755 ${srcdir}/build-php/modules/sqlite3.so ${pkgdir}/usr/lib/php/modules/sqlite3.so
install -D -m755 ${srcdir}/build-php/modules/pdo_sqlite.so ${pkgdir}/usr/lib/php/modules/pdo_sqlite.so
@@ -440,7 +446,7 @@ package_php56-tidy() {
pkgdesc='tidy module for PHP'
depends=("${pkgbase}" 'tidyhtml')
provides=('php-tidy')
- conflicts=('php-tidy')
+ conflicts=('php>=7' 'php-tidy')
install -D -m755 ${srcdir}/build-php/modules/tidy.so ${pkgdir}/usr/lib/php/modules/tidy.so
}
@@ -449,7 +455,7 @@ package_php56-xsl() {
pkgdesc='xsl module for PHP'
depends=("${pkgbase}" 'libxslt')
provides=('php-xsl')
- conflicts=('php-xsl')
+ conflicts=('php>=7' 'php-xsl')
install -D -m755 ${srcdir}/build-php/modules/xsl.so ${pkgdir}/usr/lib/php/modules/xsl.so
}