summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThore Boedecker2016-01-12 23:33:18 +0100
committerMickaël Thomas2016-01-13 00:43:50 +0100
commit36642b5b381a14197edeaac7388c91a9b5419122 (patch)
tree71023c543a7be0b7d6d5255e3315bdf99be19e0b
parentd3dd3d3f2647c5fc48384221792d993941a46978 (diff)
downloadaur-36642b5b381a14197edeaac7388c91a9b5419122.tar.gz
rework package to a separate install location
Signed-off-by: Thore Boedecker <me@foxxx0.de>
-rw-r--r--.SRCINFO86
-rw-r--r--PKGBUILD224
-rw-r--r--php-fpm.conf.in.patch8
-rw-r--r--php-fpm.install4
-rw-r--r--php-fpm.service6
-rw-r--r--php-fpm.tmpfiles2
-rw-r--r--php.ini.patch6
7 files changed, 147 insertions, 189 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab0bcc22f5b..e44f7d1c110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 8 17:05:49 UTC 2016
+# Tue Jan 12 22:32:46 UTC 2016
pkgbase = php56
+ pkgdesc = A general-purpose scripting language that is especially suited to web development
pkgver = 5.6.17
- pkgrel = 1
+ pkgrel = 2
url = http://php.net
arch = i686
arch = x86_64
@@ -11,7 +12,7 @@ pkgbase = php56
makedepends = c-client
makedepends = postgresql-libs
makedepends = libldap
- makedepends = postfix
+ makedepends = msmtp-mta
makedepends = sqlite
makedepends = unixodbc
makedepends = net-snmp
@@ -41,12 +42,12 @@ pkgbase = php56
source = php-fpm.tmpfiles
md5sums = 5e080e4b7df5db24f1b64313f8114bd8
md5sums = SKIP
- md5sums = 39eff6cc99dae4ec3b52125e6229de7e
+ md5sums = f66d04cc5a54241747ae2ca5f15e1bad
md5sums = dec2cbaad64e3abf4f0ec70e1de4e8e9
- md5sums = 16b5e2e4da59f15bea4c2db78a7bc8dc
+ md5sums = 2d0e98c423a9dc57e923f31d63117106
md5sums = 25bc67ad828e8147a817410b68d8016c
- md5sums = cc2940f5312ba42e7aa1ddfab74b84c4
- md5sums = c60343df74f8e1afb13b084d5c0e47ed
+ md5sums = c1cc15d2123931f883f75f231ae44f60
+ md5sums = 12392414f768281ae96f292d0aa9669c
pkgname = php56
pkgdesc = An HTML-embedded scripting language
@@ -55,44 +56,19 @@ pkgname = php56
depends = curl
depends = libzip
provides = php=5.6.17
- conflicts = php>=7
- conflicts = php-cgi>=7
- conflicts = php-apache>=7
- conflicts = php-fpm>=7
- conflicts = php-embed>=7
- conflicts = php-phpdbg>=7
- conflicts = php-pear>=7
- conflicts = php-enchant>=7
- conflicts = php-gd>=7
- conflicts = php-imap>=7
- conflicts = php-intl>=7
- conflicts = php-ldap>=7
- conflicts = php-mcrypt>=7
- conflicts = php-mssql>=7
- conflicts = php-odbc>=7
- conflicts = php-pgsql>=7
- conflicts = php-pspell>=7
- conflicts = php-snmp>=7
- conflicts = php-sqlite>=7
- conflicts = php-tidy>=7
- conflicts = php-xsl>=7
- backup = etc/php/php.ini
+ backup = opt/php56/etc/php/php.ini
pkgname = php56-cgi
pkgdesc = CGI and FCGI SAPI for PHP
depends = php56
provides = php-cgi=5.6.17
- conflicts = php>=7
- conflicts = php-cgi
pkgname = php56-apache
pkgdesc = Apache SAPI for PHP
depends = php56
depends = apache
provides = php-apache=5.6.17
- conflicts = php>=7
- conflicts = php-apache
- backup = etc/httpd/conf/extra/php5_module.conf
+ backup = etc/httpd/conf/extra/php56_module.conf
pkgname = php56-fpm
pkgdesc = FastCGI Process Manager for PHP
@@ -100,71 +76,53 @@ pkgname = php56-fpm
depends = php56
depends = systemd
provides = php-fpm=5.6.17
- conflicts = php>=7
- conflicts = php-fpm
- backup = etc/php/php-fpm.conf
+ backup = opt/php56/etc/php/php-fpm.conf
pkgname = php56-embed
pkgdesc = Embedded PHP SAPI library
depends = php56
provides = php-embed=5.6.17
- conflicts = php>=7
- conflicts = php-embed
pkgname = php56-phpdbg
pkgdesc = Interactive PHP debugger
depends = php56
provides = php-phpdbg=5.6.17
- conflicts = php>=7
- conflicts = php-phpdbg
pkgname = php56-pear
pkgdesc = PHP Extension and Application Repository
depends = php56
provides = php-pear=5.6.17
- conflicts = php>=7
- conflicts = php-pear
- backup = etc/php/pear.conf
+ backup = opt/php56/etc/php/pear.conf
pkgname = php56-enchant
pkgdesc = enchant module for PHP
depends = php56
depends = enchant
provides = php-enchant=5.6.17
- conflicts = php>=7
- conflicts = php-enchant
pkgname = php56-gd
pkgdesc = gd module for PHP
depends = php56
depends = gd
provides = php-gd=5.6.17
- conflicts = php>=7
- conflicts = php-gd
pkgname = php56-imap
pkgdesc = imap module for PHP
depends = php56
depends = c-client
provides = php-imap=5.6.17
- conflicts = php>=7
- conflicts = php-imap
pkgname = php56-intl
pkgdesc = intl module for PHP
depends = php56
depends = icu
provides = php-intl=5.6.17
- conflicts = php>=7
- conflicts = php-intl
pkgname = php56-ldap
pkgdesc = ldap module for PHP
depends = php56
depends = libldap
- provides = php-ldap=5.6.17
- conflicts = php>=7
- conflicts = php-ldap
+ provides = php56-ldap=5.6.17
pkgname = php56-mcrypt
pkgdesc = mcrypt module for PHP
@@ -172,70 +130,52 @@ pkgname = php56-mcrypt
depends = libmcrypt
depends = libltdl
provides = php-mcrypt=5.6.17
- conflicts = php>=7
- conflicts = php-mcrypt
pkgname = php56-mssql
pkgdesc = mssql module for PHP
depends = php56
depends = freetds
provides = php-mssql=5.6.17
- conflicts = php>=7
- conflicts = php-mssql
pkgname = php56-odbc
pkgdesc = ODBC modules for PHP
depends = php56
depends = unixodbc
provides = php-odbc=5.6.17
- conflicts = php>=7
- conflicts = php-odbc
pkgname = php56-pgsql
pkgdesc = PostgreSQL modules for PHP
depends = php56
depends = postgresql-libs
provides = php-pgsql=5.6.17
- conflicts = php>=7
- conflicts = php-pgsql
pkgname = php56-pspell
pkgdesc = pspell module for PHP
depends = php56
depends = aspell
provides = php-pspell=5.6.17
- conflicts = php>=7
- conflicts = php-pspell
pkgname = php56-snmp
pkgdesc = snmp module for PHP
depends = php56
depends = net-snmp
provides = php-snmp=5.6.17
- conflicts = php>=7
- conflicts = php-snmp
pkgname = php56-sqlite
pkgdesc = sqlite module for PHP
depends = php56
depends = sqlite
provides = php-sqlite=5.6.17
- conflicts = php>=7
- conflicts = php-sqlite
pkgname = php56-tidy
pkgdesc = tidy module for PHP
depends = php56
depends = tidyhtml
provides = php-tidy=5.6.17
- conflicts = php>=7
- conflicts = php-tidy
pkgname = php56-xsl
pkgdesc = xsl module for PHP
depends = php56
depends = libxslt
provides = php-xsl=5.6.17
- conflicts = php>=7
- conflicts = php-xsl
diff --git a/PKGBUILD b/PKGBUILD
index e06ce994335..62fa194b8cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,14 @@
# Maintainer: mickael9 <mickael9 at gmail.com>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Thore Bödecker <me@foxxx0.de>
+#
+# Changes from 2016-01-10, by Thore Bödecker:
+# reworked everything to allow php56 to co-exist with upstream php packages
+
pkgbase=php56
_pkgbase=${pkgbase%56}
+_buildprefix="/opt/${pkgbase}"
pkgname=("${pkgbase}"
"${pkgbase}-cgi"
"${pkgbase}-apache"
@@ -25,31 +31,28 @@ pkgname=("${pkgbase}"
"${pkgbase}-tidy"
"${pkgbase}-xsl")
pkgver=5.6.17
-pkgrel=1
+pkgrel=2
+pkgdesc="A general-purpose scripting language that is especially suited to web development"
arch=('i686' 'x86_64')
license=('PHP')
url='http://php.net'
-makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'postfix'
+makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'msmtp-mta'
'sqlite' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file' 'freetds'
'libmcrypt' 'tidyhtml' 'aspell' 'libltdl' 'gd' 'icu'
'curl' 'libxslt' 'openssl' 'db' 'gmp' 'systemd')
-_conflicts=("${pkgname[@]/$pkgbase/$_pkgbase}")
-_conflicts=("${_conflicts[@]/%/>=7}")
-
-#checkdepends=('procps-ng')
source=("http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"
"http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz.asc"
'php.ini.patch' 'apache.conf' 'php-fpm.conf.in.patch'
'logrotate.d.php-fpm' 'php-fpm.service' 'php-fpm.tmpfiles')
md5sums=('5e080e4b7df5db24f1b64313f8114bd8'
'SKIP'
- '39eff6cc99dae4ec3b52125e6229de7e'
+ 'f66d04cc5a54241747ae2ca5f15e1bad'
'dec2cbaad64e3abf4f0ec70e1de4e8e9'
- '16b5e2e4da59f15bea4c2db78a7bc8dc'
+ '2d0e98c423a9dc57e923f31d63117106'
'25bc67ad828e8147a817410b68d8016c'
- 'cc2940f5312ba42e7aa1ddfab74b84c4'
- 'c60343df74f8e1afb13b084d5c0e47ed')
+ 'c1cc15d2123931f883f75f231ae44f60'
+ '12392414f768281ae96f292d0aa9669c')
validpgpkeys=('6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3'
'0BD78B5F97500D450838F95DFE857D9A90D90EC1')
@@ -66,15 +69,15 @@ prepare() {
build() {
local _phpconfig="--srcdir=../${_pkgbase}-${pkgver} \
--config-cache \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/php \
+ --prefix=${_buildprefix} \
+ --sbindir=${_buildprefix}/bin \
+ --sysconfdir=${_buildprefix}/etc/php \
--localstatedir=/var \
--with-layout=GNU \
- --with-config-file-path=/etc/php \
- --with-config-file-scan-dir=/etc/php/conf.d \
+ --with-config-file-path=${_buildprefix}/etc/php \
+ --with-config-file-scan-dir=${_buildprefix}/etc/php/conf.d \
--disable-rpath \
- --mandir=/usr/share/man \
+ --mandir=${_buildprefix}/share/man \
--without-pear \
"
@@ -141,9 +144,9 @@ build() {
--with-zlib \
"
- EXTENSION_DIR=/usr/lib/php/modules
+ EXTENSION_DIR=${_buildprefix}/lib/php/modules
export EXTENSION_DIR
- PEAR_INSTALLDIR=/usr/share/pear
+ PEAR_INSTALLDIR=${_buildprefix}/share/pear
export PEAR_INSTALLDIR
cd ${srcdir}/${_pkgbase}-${pkgver}
@@ -242,220 +245,235 @@ build() {
package_php56() {
pkgdesc='An HTML-embedded scripting language'
depends=('pcre' 'libxml2' 'curl' 'libzip')
- backup=('etc/php/php.ini')
- conflicts=("${_conflicts[@]}")
- provides=("php=$pkgver")
+ backup=("${_buildprefix#/}/etc/php/php.ini")
+ provides=("${_pkgbase}=$pkgver")
cd ${srcdir}/build-php
make -j1 INSTALL_ROOT=${pkgdir} install
- install -d -m755 ${pkgdir}/usr/share/pear
+
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/share/pear
# install php.ini
- install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/php.ini-production ${pkgdir}/etc/php/php.ini
- install -d -m755 ${pkgdir}/etc/php/conf.d/
+ install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/php.ini-production ${pkgdir}/${_buildprefix#/}/etc/php/php.ini
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/etc/php/conf.d/
# remove static modules
- rm -f ${pkgdir}/usr/lib/php/modules/*.a
+ rm -f ${pkgdir}/${_buildprefix#/}/lib/php/modules/*.a
# remove modules provided by sub packages
- rm -f ${pkgdir}/usr/lib/php/modules/{enchant,gd,imap,intl,ldap,mcrypt,mssql,odbc,pdo_odbc,pgsql,pdo_pgsql,pspell,snmp,sqlite3,pdo_sqlite,tidy,xsl}.so
+ rm -f ${pkgdir}/${_buildprefix#/}/lib/php/modules/{enchant,gd,imap,intl,ldap,mcrypt,mssql,odbc,pdo_odbc,pgsql,pdo_pgsql,pspell,snmp,sqlite3,pdo_sqlite,tidy,xsl}.so
# remove empty directory
- rmdir ${pkgdir}/usr/include/php/include
- # fix broken link
- ln -sf phar.phar ${pkgdir}/usr/bin/phar
+ rmdir ${pkgdir}/${_buildprefix#/}/include/php/include
+
+ # set symlinks
+ mkdir -p ${pkgdir}/etc;
+ ln -sf ${_buildprefix}/etc/php ${pkgdir}/etc/${pkgbase}
+
+ mkdir -p ${pkgdir}/usr/bin;
+ ln -sf ${_buildprefix}/bin/phar.phar ${pkgdir}/usr/bin/phar56
+ ln -sf ${_buildprefix}/bin/php ${pkgdir}/usr/bin/${pkgbase}
+ ln -sf ${_buildprefix}/bin/php-config ${pkgdir}/usr/bin/${pkgbase}-config
+ ln -sf ${_buildprefix}/bin/phpize ${pkgdir}/usr/bin/${pkgbase}ize
+
+ mkdir -p ${pkgdir}/usr/share/man/man1;
+ ln -sf ${_buildprefix}/share/man/man1/phar.1 ${pkgdir}/usr/share/man/man1/phar56.1
+ ln -sf ${_buildprefix}/share/man/man1/php-config.1 ${pkgdir}/usr/share/man/man1/${pkgbase}-config.1
+ ln -sf ${_buildprefix}/share/man/man1/php.1 ${pkgdir}/usr/share/man/man1/${pkgbase}.1
+ ln -sf ${_buildprefix}/share/man/man1/phar.phar.1 ${pkgdir}/usr/share/man/man1/phar56.phar.1
+ ln -sf ${_buildprefix}/share/man/man1/phpize.1 ${pkgdir}/usr/share/man/man1/${pkgbase}ize.1
}
package_php56-cgi() {
pkgdesc='CGI and FCGI SAPI for PHP'
depends=("${pkgbase}")
- provides=("php-cgi=$pkgver")
- conflicts=('php>=7' 'php-cgi')
+ provides=("${_pkgbase}-cgi=$pkgver")
+
+ install -D -m755 ${srcdir}/build-cgi/sapi/cgi/php-cgi ${pkgdir}/${_buildprefix#/}/bin/php-cgi
- install -D -m755 ${srcdir}/build-cgi/sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi
+ mkdir -p ${pkgdir}/usr/bin;
+ ln -sf ${_buildprefix}/bin/php-cgi ${pkgdir}/usr/bin/${pkgbase}-cgi
}
package_php56-apache() {
pkgdesc='Apache SAPI for PHP'
depends=("${pkgbase}" 'apache')
- provides=("php-apache=$pkgver")
- conflicts=('php>=7' 'php-apache')
- backup=('etc/httpd/conf/extra/php5_module.conf')
+ provides=("${_pkgbase}-apache=$pkgver")
+ backup=("etc/httpd/conf/extra/${pkgbase}_module.conf")
- install -D -m755 ${srcdir}/build-apache/libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so
- install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf
+ install -D -m755 ${srcdir}/build-apache/libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/lib${pkgbase}.so
+ install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/${pkgbase}_module.conf
}
package_php56-fpm() {
pkgdesc='FastCGI Process Manager for PHP'
depends=("${pkgbase}" 'systemd')
- provides=("php-fpm=$pkgver")
- conflicts=('php>=7' 'php-fpm')
- backup=('etc/php/php-fpm.conf')
+ provides=("${_pkgbase}-fpm=$pkgver")
+ backup=("${_buildprefix#/}/etc/php/php-fpm.conf")
install='php-fpm.install'
- install -D -m755 ${srcdir}/build-fpm/sapi/fpm/php-fpm ${pkgdir}/usr/bin/php-fpm
- install -D -m644 ${srcdir}/build-fpm/sapi/fpm/php-fpm.8 ${pkgdir}/usr/share/man/man8/php-fpm.8
- install -D -m644 ${srcdir}/build-fpm/sapi/fpm/php-fpm.conf ${pkgdir}/etc/php/php-fpm.conf
- install -D -m644 ${srcdir}/logrotate.d.php-fpm ${pkgdir}/etc/logrotate.d/php-fpm
- install -d -m755 ${pkgdir}/etc/php/fpm.d
- install -D -m644 ${srcdir}/php-fpm.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/php-fpm.conf
- install -D -m644 ${srcdir}/php-fpm.service ${pkgdir}/usr/lib/systemd/system/php-fpm.service
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/bin
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/etc
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/etc/logrotate.d
+
+ install -D -m755 ${srcdir}/build-fpm/sapi/fpm/php-fpm ${pkgdir}/${_buildprefix#/}/bin/php-fpm
+ install -D -m644 ${srcdir}/build-fpm/sapi/fpm/php-fpm.8 ${pkgdir}/usr/share/man/man8/${pkgbase}-fpm.8
+ install -D -m644 ${srcdir}/build-fpm/sapi/fpm/php-fpm.conf ${pkgdir}/${_buildprefix#/}/etc/php/php-fpm.conf
+ install -d -m755 ${pkgdir}/${_buildprefix#/}/etc/php/fpm.d
+ install -D -m644 ${srcdir}/php-fpm.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/${pkgbase}-fpm.conf
+ install -D -m644 ${srcdir}/php-fpm.service ${pkgdir}/usr/lib/systemd/system/${pkgbase}-fpm.service
+
+ mkdir -p ${pkgdir}/etc/logrotate.d
+ install -D -m644 ${srcdir}/logrotate.d.php-fpm ${pkgdir}/etc/logrotate.d/${pkgbase}-fpm
+
+ mkdir -p ${pkgdir}/usr/bin
+ ln -sf ${_buildprefix}/bin/php-fpm ${pkgdir}/usr/bin/${pkgbase}-fpm
}
package_php56-embed() {
pkgdesc='Embedded PHP SAPI library'
depends=("${pkgbase}")
- provides=("php-embed=$pkgver")
- conflicts=('php>=7' 'php-embed')
+ provides=("${_pkgbase}-embed=$pkgver")
- install -D -m755 ${srcdir}/build-embed/libs/libphp5.so ${pkgdir}/usr/lib/libphp5.so
- install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/sapi/embed/php_embed.h ${pkgdir}/usr/include/php/sapi/embed/php_embed.h
+ install -D -m755 ${srcdir}/build-embed/libs/libphp5.so ${pkgdir}/${_buildprefix#/}/lib/libphp5.so
+ install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/sapi/embed/php_embed.h ${pkgdir}/${_buildprefix#/}/include/php/sapi/embed/php_embed.h
}
package_php56-phpdbg() {
pkgdesc='Interactive PHP debugger'
depends=("${pkgbase}")
- provides=("php-phpdbg=$pkgver")
- conflicts=('php>=7' 'php-phpdbg')
+ provides=("${_pkgbase}-phpdbg=$pkgver")
- install -D -m755 ${srcdir}/build-phpdbg/sapi/phpdbg/phpdbg ${pkgdir}/usr/bin/phpdbg
+ install -D -m755 ${srcdir}/build-phpdbg/sapi/phpdbg/phpdbg ${pkgdir}/${_buildprefix#/}/bin/phpdbg
+
+ mkdir -p ${pkgdir}/usr/bin;
+ ln -sf ${_buildprefix}/bin/phpdbg ${pkgdir}/usr/bin/${pkgbase}dbg
}
package_php56-pear() {
pkgdesc='PHP Extension and Application Repository'
depends=("${pkgbase}")
- provides=("php-pear=$pkgver")
- conflicts=('php>=7' 'php-pear')
- backup=('etc/php/pear.conf')
+ provides=("${_pkgbase}-pear=$pkgver")
+ backup=("${_buildprefix#/}/etc/php/pear.conf")
cd ${srcdir}/build-pear
make install-pear INSTALL_ROOT=${pkgdir}
- rm -rf ${pkgdir}/usr/share/pear/.{channels,depdb,depdblock,filemap,lock,registry}
+ rm -rf ${pkgdir}/${_buildprefix#/}/share/pear/.{channels,depdb,depdblock,filemap,lock,registry}
+
+ mkdir -p ${pkgdir}/usr/bin;
+ ln -sf ${_buildprefix}/bin/pear ${pkgdir}/usr/bin/pear56
+ ln -sf ${_buildprefix}/bin/peardev ${pkgdir}/usr/bin/pear56dev
+ ln -sf ${_buildprefix}/bin/pecl ${pkgdir}/usr/bin/pecl56
}
package_php56-enchant() {
pkgdesc='enchant module for PHP'
depends=("${pkgbase}" 'enchant')
- provides=("php-enchant=$pkgver")
- conflicts=('php>=7' 'php-enchant')
+ provides=("${_pkgbase}-enchant=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/enchant.so ${pkgdir}/usr/lib/php/modules/enchant.so
+ install -D -m755 ${srcdir}/build-php/modules/enchant.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/enchant.so
}
package_php56-gd() {
pkgdesc='gd module for PHP'
depends=("${pkgbase}" 'gd')
- provides=("php-gd=$pkgver")
- conflicts=('php>=7' 'php-gd')
+ provides=("${_pkgbase}-gd=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/gd.so ${pkgdir}/usr/lib/php/modules/gd.so
+ install -D -m755 ${srcdir}/build-php/modules/gd.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/gd.so
}
package_php56-imap() {
pkgdesc='imap module for PHP'
depends=("${pkgbase}" 'c-client')
- provides=("php-imap=$pkgver")
- conflicts=('php>=7' 'php-imap')
+ provides=("${_pkgbase}-imap=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/imap.so ${pkgdir}/usr/lib/php/modules/imap.so
+ install -D -m755 ${srcdir}/build-php/modules/imap.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/imap.so
}
package_php56-intl() {
pkgdesc='intl module for PHP'
depends=("${pkgbase}" 'icu')
- provides=("php-intl=$pkgver")
- conflicts=('php>=7' 'php-intl')
+ provides=("${_pkgbase}-intl=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/intl.so ${pkgdir}/usr/lib/php/modules/intl.so
+ install -D -m755 ${srcdir}/build-php/modules/intl.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/intl.so
}
package_php56-ldap() {
pkgdesc='ldap module for PHP'
depends=("${pkgbase}" 'libldap')
- provides=("php-ldap=$pkgver")
- conflicts=('php>=7' 'php-ldap')
+ provides=("${pkgbase}-ldap=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/ldap.so ${pkgdir}/usr/lib/php/modules/ldap.so
+ install -D -m755 ${srcdir}/build-php/modules/ldap.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/ldap.so
}
package_php56-mcrypt() {
pkgdesc='mcrypt module for PHP'
depends=("${pkgbase}" 'libmcrypt' 'libltdl')
- provides=("php-mcrypt=$pkgver")
- conflicts=('php>=7' 'php-mcrypt')
+ provides=("${_pkgbase}-mcrypt=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/mcrypt.so ${pkgdir}/usr/lib/php/modules/mcrypt.so
+ install -D -m755 ${srcdir}/build-php/modules/mcrypt.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/mcrypt.so
}
package_php56-mssql() {
pkgdesc='mssql module for PHP'
depends=("${pkgbase}" 'freetds')
- provides=("php-mssql=$pkgver")
- conflicts=('php>=7' 'php-mssql')
+ provides=("${_pkgbase}-mssql=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/mssql.so ${pkgdir}/usr/lib/php/modules/mssql.so
+ install -D -m755 ${srcdir}/build-php/modules/mssql.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/mssql.so
}
package_php56-odbc() {
pkgdesc='ODBC modules for PHP'
depends=("${pkgbase}" 'unixodbc')
- provides=("php-odbc=$pkgver")
- conflicts=('php>=7' 'php-odbc')
+ provides=("${_pkgbase}-odbc=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/odbc.so ${pkgdir}/usr/lib/php/modules/odbc.so
- install -D -m755 ${srcdir}/build-php/modules/pdo_odbc.so ${pkgdir}/usr/lib/php/modules/pdo_odbc.so
+ install -D -m755 ${srcdir}/build-php/modules/odbc.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/odbc.so
+ install -D -m755 ${srcdir}/build-php/modules/pdo_odbc.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/pdo_odbc.so
}
package_php56-pgsql() {
pkgdesc='PostgreSQL modules for PHP'
depends=("${pkgbase}" 'postgresql-libs')
- provides=("php-pgsql=$pkgver")
- conflicts=('php>=7' 'php-pgsql')
+ provides=("${_pkgbase}-pgsql=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/pgsql.so ${pkgdir}/usr/lib/php/modules/pgsql.so
- install -D -m755 ${srcdir}/build-php/modules/pdo_pgsql.so ${pkgdir}/usr/lib/php/modules/pdo_pgsql.so
+ install -D -m755 ${srcdir}/build-php/modules/pgsql.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/pgsql.so
+ install -D -m755 ${srcdir}/build-php/modules/pdo_pgsql.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/pdo_pgsql.so
}
package_php56-pspell() {
pkgdesc='pspell module for PHP'
depends=("${pkgbase}" 'aspell')
- provides=("php-pspell=$pkgver")
- conflicts=('php>=7' 'php-pspell')
+ provides=("${_pkgbase}-pspell=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/pspell.so ${pkgdir}/usr/lib/php/modules/pspell.so
+ install -D -m755 ${srcdir}/build-php/modules/pspell.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/pspell.so
}
package_php56-snmp() {
pkgdesc='snmp module for PHP'
depends=("${pkgbase}" 'net-snmp')
- provides=("php-snmp=$pkgver")
- conflicts=('php>=7' 'php-snmp')
+ provides=("${_pkgbase}-snmp=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/snmp.so ${pkgdir}/usr/lib/php/modules/snmp.so
+ install -D -m755 ${srcdir}/build-php/modules/snmp.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/snmp.so
}
package_php56-sqlite() {
pkgdesc='sqlite module for PHP'
depends=("${pkgbase}" 'sqlite')
- provides=("php-sqlite=$pkgver")
- conflicts=('php>=7' 'php-sqlite')
+ provides=("${_pkgbase}-sqlite=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/sqlite3.so ${pkgdir}/usr/lib/php/modules/sqlite3.so
- install -D -m755 ${srcdir}/build-php/modules/pdo_sqlite.so ${pkgdir}/usr/lib/php/modules/pdo_sqlite.so
+ install -D -m755 ${srcdir}/build-php/modules/sqlite3.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/sqlite3.so
+ install -D -m755 ${srcdir}/build-php/modules/pdo_sqlite.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/pdo_sqlite.so
}
package_php56-tidy() {
pkgdesc='tidy module for PHP'
depends=("${pkgbase}" 'tidyhtml')
- provides=("php-tidy=$pkgver")
- conflicts=('php>=7' 'php-tidy')
+ provides=("${_pkgbase}-tidy=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/tidy.so ${pkgdir}/usr/lib/php/modules/tidy.so
+ install -D -m755 ${srcdir}/build-php/modules/tidy.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/tidy.so
}
package_php56-xsl() {
pkgdesc='xsl module for PHP'
depends=("${pkgbase}" 'libxslt')
- provides=("php-xsl=$pkgver")
- conflicts=('php>=7' 'php-xsl')
+ provides=("${_pkgbase}-xsl=$pkgver")
- install -D -m755 ${srcdir}/build-php/modules/xsl.so ${pkgdir}/usr/lib/php/modules/xsl.so
+ install -D -m755 ${srcdir}/build-php/modules/xsl.so ${pkgdir}/${_buildprefix#/}/lib/php/modules/xsl.so
}
diff --git a/php-fpm.conf.in.patch b/php-fpm.conf.in.patch
index f9721a1ac00..9b383cbf0c9 100644
--- a/php-fpm.conf.in.patch
+++ b/php-fpm.conf.in.patch
@@ -5,7 +5,7 @@
; - the global prefix if it's been set (-p argument)
; - @prefix@ otherwise
-;include=etc/fpm.d/*.conf
-+;include=/etc/php/fpm.d/*.conf
++;include=/etc/php56/fpm.d/*.conf
;;;;;;;;;;;;;;;;;;
; Global Options ;
@@ -14,7 +14,7 @@
; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
; Default Value: none
-;pid = run/php-fpm.pid
-+pid = /run/php-fpm/php-fpm.pid
++pid = /run/php56-fpm/php-fpm.pid
; Error log file
; If it's set to "syslog", log is sent to syslogd instead of being written
@@ -23,8 +23,8 @@
; '/path/to/unix/socket' - to listen on a unix socket.
; Note: This value is mandatory.
-listen = 127.0.0.1:9000
-+;listen = 127.0.0.1:9000
-+listen = /run/php-fpm/php-fpm.sock
++;listen = 127.0.0.1:9001
++listen = /run/php56-fpm/php-fpm.sock
; Set listen(2) backlog.
; Default Value: 65535 (-1 on FreeBSD and OpenBSD)
diff --git a/php-fpm.install b/php-fpm.install
index 3572a765315..1e2c2d9fe0f 100644
--- a/php-fpm.install
+++ b/php-fpm.install
@@ -1,6 +1,6 @@
post_install() {
- if [[ ! -d run/php-fpm ]]; then
- usr/bin/systemd-tmpfiles --create php-fpm.conf
+ if [[ ! -d run/php56-fpm ]]; then
+ usr/bin/systemd-tmpfiles --create php56-fpm.conf
fi
}
diff --git a/php-fpm.service b/php-fpm.service
index 6e2faafd865..8afb974627a 100644
--- a/php-fpm.service
+++ b/php-fpm.service
@@ -1,12 +1,12 @@
[Unit]
-Description=The PHP FastCGI Process Manager
+Description=The PHP 5.6 FastCGI Process Manager
After=syslog.target network.target
[Service]
Type=notify
-PIDFile=/run/php-fpm/php-fpm.pid
+PIDFile=/run/php56-fpm/php-fpm.pid
PrivateTmp=true
-ExecStart=/usr/bin/php-fpm --nodaemonize --pid /run/php-fpm/php-fpm.pid
+ExecStart=/usr/bin/php56-fpm --nodaemonize --pid /run/php56-fpm/php-fpm.pid
ExecReload=/bin/kill -USR2 $MAINPID
[Install]
diff --git a/php-fpm.tmpfiles b/php-fpm.tmpfiles
index 801e74f1e62..0498d884426 100644
--- a/php-fpm.tmpfiles
+++ b/php-fpm.tmpfiles
@@ -1 +1 @@
-d /run/php-fpm 755 root root
+d /run/php56-fpm 755 root root
diff --git a/php.ini.patch b/php.ini.patch
index 93a2e757122..c3e18f88e99 100644
--- a/php.ini.patch
+++ b/php.ini.patch
@@ -5,7 +5,7 @@
; or per-virtualhost web server configuration file.
; http://php.net/open-basedir
-;open_basedir =
-+open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/
++open_basedir = /srv/http/:/home/:/tmp/:/opt/php56/share/pear/:/usr/share/webapps/
; This directive allows you to disable certain functions for security reasons.
; It receives a comma-delimited list of function names.
@@ -14,7 +14,7 @@
; UNIX: "/path1:/path2"
-;include_path = ".:/php/includes"
-+include_path = ".:/usr/share/pear"
++include_path = ".:/opt/php56/share/pear"
;
; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes"
@@ -23,7 +23,7 @@
; Directory in which the loadable extensions (modules) reside.
; http://php.net/extension-dir
-; extension_dir = "./"
-+extension_dir = "/usr/lib/php/modules/"
++extension_dir = "/opt/php56/lib/php/modules/"
; On windows:
; extension_dir = "ext"