summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Algar2021-07-04 14:12:42 -0700
committerRyan Algar2021-07-04 14:12:42 -0700
commit0162d01c4aa1042472f41b58aef516af26ea5f47 (patch)
tree344abd01e1a7cc5c59889dcae3d1df474cd57d68
parent179359c322a6932b1cb1d9e2cf3d2901f137aec0 (diff)
downloadaur-0162d01c4aa1042472f41b58aef516af26ea5f47.tar.gz
Fix VST path, add conflict with -bin package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 157e8b474ac..3ce3c4320b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = odin2-synthesizer
pkgdesc = 24 voice polyphonic synthesizer, with modulation and FX. (Standalone, VST3, LV2)
pkgver = 2.2.4
- pkgrel = 4
+ pkgrel = 5
url = https://www.thewavewarden.com/odin2
arch = x86_64
license = GPL3
@@ -28,6 +28,8 @@ pkgbase = odin2-synthesizer
depends = ttf-font
optdepends = ttf-dejavu: One of these may be needed for fonts to render correctly
optdepends = ttf-liberation: One of these may be needed for fonts to render correctly
+ provides = odin2
+ conflicts = odin2-synthesizer-bin
backup = opt/odin2/odin2.conf
backup = opt/odin2/Soundbanks/User Patches
source = /odin2::git+https://github.com/TheWaveWarden/odin2.git
@@ -40,4 +42,3 @@ pkgbase = odin2-synthesizer
sha256sums = SKIP
pkgname = odin2-synthesizer
-
diff --git a/PKGBUILD b/PKGBUILD
index c0d053c2e3f..d22162ec2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=odin2-synthesizer
pkgver=2.2.4
-pkgrel=4
+pkgrel=5
pkgdesc='24 voice polyphonic synthesizer, with modulation and FX. (Standalone, VST3, LV2)'
license=('GPL3')
arch=('x86_64')
url='https://www.thewavewarden.com/odin2'
-#conflicts=('odin2-synthesizer-bin')
+provides=('odin2')
+conflicts=('odin2-synthesizer-bin')
depends=(ttf-font)
makedepends=('atk'
@@ -39,10 +40,8 @@ source=("${srcdir}/${pkgname%-synthesizer}::git+https://github.com/TheWaveWarden
'AppConfig.patch'
'Makefile.patch')
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
-
backup=('opt/odin2/odin2.conf' 'opt/odin2/Soundbanks/User Patches')
-
prepare() {
# Checkout the 6.0.1 branch of JUCE, and build Projucer
cd "${srcdir}/JUCE"
@@ -78,7 +77,7 @@ check() {
}
package() {
- install -Dm 755 "${srcdir}/odin2/Builds/LinuxMakefile/build/Odin2.vst3/Contents/x86_64-linux/Odin2.so" "${pkgdir}/usr/lib/vst3/Odin2.vst3/Odin2.so"
+ install -Dm 755 "${srcdir}/odin2/Builds/LinuxMakefile/build/Odin2.vst3/Contents/x86_64-linux/Odin2.so" "${pkgdir}/usr/lib/vst3/Odin2.vst3/Contents/x86_64-linux/Odin2.so"
install -Dm 755 "${srcdir}/odin2/Builds/LinuxMakefile/build/Odin2_.lv2/Odin2_.so" "${pkgdir}/usr/lib/lv2/Odin2.lv2/Odin2_.so"
install -Dm 644 "${srcdir}/odin2/Builds/LinuxMakefile/build/Odin2_.lv2/Odin2_.ttl" "${pkgdir}/usr/lib/lv2/Odin2.lv2/Odin2_.ttl"