summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2016-11-28 22:00:10 -0800
committerEric Anderson2016-11-28 22:00:10 -0800
commit4b13d3e3cd2b2ed519e3f2cd3a9d76c672517801 (patch)
tree8db0dde0adba11021a627f8632d40ce0287d5760
parentcd2c6d3a48e219c3e94a126019143b80c9a7dfcb (diff)
downloadaur-4b13d3e3cd2b2ed519e3f2cd3a9d76c672517801.tar.gz
Update to 1.20.2
This is a mostly useless update. The only change to upstream in 1.20.1 and 1.20.2 is a new explicit dependency on gnupg in Debian since it was no longer implicitly included via build-essential. That seems a bit strange since that should imply gnupg is only a build dependency, but it is used at runtime as well. It's also unclear why the dependency is a 'Depends' instead of a 'Suggests', since it is only necessary when using encryption. Maybe I don't understand the semantics of Suggests. This has little impact for Arch because pacman transitively depends on gnupg. Obnam could have an optional dependency on gnupg, but gnupg is already installed on virtually all Arch machines and upstream chose a strong dependency.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f64e01644d..9ab47636823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 29 17:02:54 UTC 2016
+# Tue Nov 29 06:00:03 UTC 2016
pkgbase = obnam
pkgdesc = Easy, secure backup program
- pkgver = 1.20
+ pkgver = 1.20.2
pkgrel = 1
url = http://obnam.org/
arch = i686
@@ -13,9 +13,10 @@ pkgbase = obnam
depends = python2-larch
depends = python2-ttystatus
depends = python2-cliapp
+ depends = gnupg
optdepends = python2-fuse: support for mounting backups
- source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.20.orig.tar.xz
- sha256sums = 08b674f400f7c132a560af5b23bc080bd96f95c4738d41713cff90d41f3a30f1
+ source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.20.2.orig.tar.xz
+ sha256sums = b84a39d976acb007414c1ed972c0869693f38c185889bb8bb4f1a61ce5b30f65
pkgname = obnam
diff --git a/PKGBUILD b/PKGBUILD
index 230ba3f7baa..d419835dab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=obnam
-pkgver=1.20
+pkgver=1.20.2
pkgrel=1
pkgdesc="Easy, secure backup program"
arch=('i686' 'x86_64')
url="http://obnam.org/"
license=('GPL3')
depends=('python2-paramiko' 'python2-tracing' 'python2-larch'
- 'python2-ttystatus' 'python2-cliapp')
+ 'python2-ttystatus' 'python2-cliapp' 'gnupg')
optdepends=('python2-fuse: support for mounting backups')
source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz")
-sha256sums=('08b674f400f7c132a560af5b23bc080bd96f95c4738d41713cff90d41f3a30f1')
+sha256sums=('b84a39d976acb007414c1ed972c0869693f38c185889bb8bb4f1a61ce5b30f65')
build() {
cd "$srcdir/$pkgname-$pkgver"