summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schrempf2019-04-30 20:35:39 +0200
committerDominik Schrempf2019-04-30 20:35:39 +0200
commit13c2a7c9a249023c59fba7493e5f2f53cb8aa232 (patch)
tree8787f38e495d0d77ebf8df2a45308b4b771b6cb1
parentd0012e1d4d4f622ec6e9a0f0e59aa041a8bfb1c1 (diff)
downloadaur-13c2a7c9a249023c59fba7493e5f2f53cb8aa232.tar.gz
inform about dir change
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD2
-rw-r--r--nextcloud-systemd-timers.install15
4 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 131e1b037b0..046808251c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = nextcloud-systemd-timers
install = nextcloud-systemd-timers.install
arch = any
license = GPL
- conflicts = nextcloud-systemd-cron
source = nextcloud-cron.service
source = nextcloud-cron.timer
source = nextcloud-preview-pre-generate.service
diff --git a/.gitignore b/.gitignore
index 3491100687a..8e5af080034 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,4 @@
/update
+/pkg/
+/src/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index e5ba83b9af2..bf61b902225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ makedepends=()
checkdepends=()
optdepends=()
provides=()
-conflicts=(nextcloud-systemd-cron)
+conflicts=()
replaces=()
backup=()
options=()
diff --git a/nextcloud-systemd-timers.install b/nextcloud-systemd-timers.install
index 9c4d44ad0ee..cdf3a5b9f90 100644
--- a/nextcloud-systemd-timers.install
+++ b/nextcloud-systemd-timers.install
@@ -34,11 +34,16 @@ post_install() {
echo '$ systemctl list-timers'
}
-## arg 1: the new package version
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ if [[ $1 == 0.6 ]]
+ then
+ echo "The systemd unit directory has changed from"
+ echo "/etc/systemd/system to /usr/lib/systemd/system."
+ echo "Please deactivate the old units, and activate the new ones after the upgrade."
+ fi
+}
## arg 1: the new package version
## arg 2: the old package version