summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-16 10:00:29 +0200
committerMartchus2016-06-16 10:00:29 +0200
commite7da1b8812868eb45afda60b2c231f0eb3c45f08 (patch)
treeeab745c07b6588a4947e07414070ddb3f34625db
parentd1ddc625518996e24d767d093443a4b70cff7361 (diff)
downloadaur-e7da1b8812868eb45afda60b2c231f0eb3c45f08.tar.gz
Update to 5.6.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--qt5-use-system-zlib-in-host-libs.patch16
-rw-r--r--qt5-use-win32-g++-mkspecs-profile.patch11
-rw-r--r--use-external-angle-library.patch4
5 files changed, 31 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 779d3519c21..a18e8d33a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 13 13:09:20 UTC 2016
+# Thu Jun 16 08:00:16 UTC 2016
pkgbase = mingw-w64-qt5-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
- pkgver = 5.6.0
- pkgrel = 3
+ pkgver = 5.6.1
+ pkgrel = 1
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -31,7 +31,7 @@ pkgbase = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qtbase-opensource-src-5.6.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.1/submodules/qtbase-opensource-src-5.6.1.tar.xz
source = add-angle-support.patch
source = use-external-angle-library.patch
source = qt5-workaround-pkgconfig-install-issue.patch
@@ -46,12 +46,11 @@ pkgbase = mingw-w64-qt5-base
source = qt5-use-system-zlib-in-host-libs.patch
source = fix-opengl-to-many-sections.patch
source = fix-static-psql-mysql.patch
- source = qt5-fix-QSemaphore-problem.patch
source = qtbase-1-fixes.patch
source = qt5-fix-implib-ext.patch
- md5sums = d6b6cfd333c22829c6c85fc52ceed019
+ md5sums = b23232190a3df61fe1ba81636987b036
md5sums = bab00ccc19d888997f323c80354a7c3f
- md5sums = 9916ded318f21afbe8388f0b9822062b
+ md5sums = f7e1487de6e85116d9c6bde2eac4fb73
md5sums = bc99c4cc6998295d76f37ed681c20d47
md5sums = 4fe6523dd1c34398df3aa5a8763530cc
md5sums = f32a768e1acb9785c79c8e93aa266db2
@@ -60,11 +59,10 @@ pkgbase = mingw-w64-qt5-base
md5sums = 99bb9f51ec684803768f36e407baf486
md5sums = 6a6bc88f35ac8080869de39bc128ce5b
md5sums = 40de3aaf7d713034e06f4eece665b1ba
- md5sums = d0c7198115ff028188ed1759b70fd981
- md5sums = a265dea62755caf38187114143999224
+ md5sums = 0186761e13206a32b689f10898e0d536
+ md5sums = c15d9f480d0248648fa52aeacb46e3c7
md5sums = 612a4dfb9f1a3898a1920c28bb999159
md5sums = d0eb81aef1a21c65813fe4ddabbc4206
- md5sums = 87cbd116c75ced1b075bf266f2455d50
md5sums = 62d2977e57fccf1f16d7ea6bf06d3279
md5sums = 83139869355c2d46921adb25e47cf0fa
diff --git a/PKGBUILD b/PKGBUILD
index e208e71cc69..71f7c445d43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ isOpenGL() {
}
pkgname=mingw-w64-qt5-base
-pkgver=5.6.0
-pkgrel=3
+pkgver=5.6.1
+pkgrel=1
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
! isStatic && arch=('i686' 'x86_64')
isStatic && arch=('any') # the static variant doesn't contain any executables which need to be executed on the host
@@ -62,12 +62,11 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
"qt5-use-system-zlib-in-host-libs.patch"
"fix-opengl-to-many-sections.patch"
"fix-static-psql-mysql.patch"
- "qt5-fix-QSemaphore-problem.patch"
"qtbase-1-fixes.patch"
"qt5-fix-implib-ext.patch")
-md5sums=('d6b6cfd333c22829c6c85fc52ceed019'
+md5sums=('b23232190a3df61fe1ba81636987b036'
'bab00ccc19d888997f323c80354a7c3f'
- '9916ded318f21afbe8388f0b9822062b'
+ 'f7e1487de6e85116d9c6bde2eac4fb73'
'bc99c4cc6998295d76f37ed681c20d47'
'4fe6523dd1c34398df3aa5a8763530cc'
'f32a768e1acb9785c79c8e93aa266db2'
@@ -76,14 +75,13 @@ md5sums=('d6b6cfd333c22829c6c85fc52ceed019'
'99bb9f51ec684803768f36e407baf486'
'6a6bc88f35ac8080869de39bc128ce5b'
'40de3aaf7d713034e06f4eece665b1ba'
- 'd0c7198115ff028188ed1759b70fd981'
- 'a265dea62755caf38187114143999224'
+ '0186761e13206a32b689f10898e0d536'
+ 'c15d9f480d0248648fa52aeacb46e3c7'
'612a4dfb9f1a3898a1920c28bb999159'
'd0eb81aef1a21c65813fe4ddabbc4206'
- '87cbd116c75ced1b075bf266f2455d50'
'62d2977e57fccf1f16d7ea6bf06d3279'
'83139869355c2d46921adb25e47cf0fa')
-_architectures="x86_64-w64-mingw32 i686-w64-mingw32"
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
isStatic && depends+=("mingw-w64-qt5-base")
! isOpenGL && depends+=("mingw-w64-angleproject")
@@ -128,7 +126,7 @@ prepare() {
patch -p1 -i ../qt5-fix-static-dbus-detection.patch
# Patch the win32-g++ mkspecs profile to match our environment
- patch -p1 -i ../qt5-use-win32-g++-mkspecs-profile.patch
+ patch -p0 -i ../qt5-use-win32-g++-mkspecs-profile.patch
# The bundled pcre is built as static library by default
# As we're not using the bundled copy but our own copy
@@ -157,13 +155,11 @@ prepare() {
# Build host libs with system zlib. This patch cannot be upstreamed as-is
# due to the other host-libs patches.
- patch -p1 -i ../qt5-use-system-zlib-in-host-libs.patch
+ patch -p0 -i ../qt5-use-system-zlib-in-host-libs.patch
# Fix qmake to append .dll.a extension to import libs
patch -p1 -i ../qt5-fix-implib-ext.patch
- patch configure ../qt5-fix-QSemaphore-problem.patch
-
isStatic && patch -p0 -i ../fix-static-psql-mysql.patch
# Make sure the Qt5 build system uses our external ANGLE library
diff --git a/qt5-use-system-zlib-in-host-libs.patch b/qt5-use-system-zlib-in-host-libs.patch
index a5046514062..311e5a981d4 100644
--- a/qt5-use-system-zlib-in-host-libs.patch
+++ b/qt5-use-system-zlib-in-host-libs.patch
@@ -1,11 +1,11 @@
---- a/src/tools/bootstrap/bootstrap.pro 2014-01-01 13:22:42.367935800 -0600
-+++ b/src/tools/bootstrap/bootstrap.pro 2014-01-02 23:38:20.707687700 -0600
-@@ -145,7 +145,7 @@
+--- src/tools/bootstrap/bootstrap.pro.orig 2016-06-14 17:01:24.972134372 +0200
++++ src/tools/bootstrap/bootstrap.pro 2016-05-25 17:46:17.000000000 +0200
+@@ -132,7 +132,7 @@
../../corelib/io/qstandardpaths_win.cpp
}
--if(contains(QT_CONFIG, zlib)|cross_compile):include(../../3rdparty/zlib.pri)
-+if(contains(QT_CONFIG, zlib)):include(../../3rdparty/zlib.pri)
- else:include(../../3rdparty/zlib_dependency.pri)
-
- win32:LIBS += -luser32 -lole32 -ladvapi32 -lshell32
+-contains(QT_CONFIG, zlib)|cross_compile {
++contains(QT_CONFIG, zlib) {
+ include(../../3rdparty/zlib.pri)
+ } else {
+ CONFIG += no_core_dep
diff --git a/qt5-use-win32-g++-mkspecs-profile.patch b/qt5-use-win32-g++-mkspecs-profile.patch
index 23ca26609d8..29302dac820 100644
--- a/qt5-use-win32-g++-mkspecs-profile.patch
+++ b/qt5-use-win32-g++-mkspecs-profile.patch
@@ -1,5 +1,5 @@
---- qtbase-opensource-src-5.5.0/mkspecs/win32-g++/qmake.conf.orig 2015-06-29 22:05:10.000000000 +0200
-+++ qtbase-opensource-src-5.5.0/mkspecs/win32-g++/qmake.conf 2015-08-05 19:53:33.349194327 +0200
+--- mkspecs/win32-g++/qmake.conf.orig 2016-06-14 16:22:02.779947341 +0200
++++ mkspecs/win32-g++/qmake.conf 2016-06-14 16:38:56.298752668 +0200
@@ -25,7 +25,7 @@
QMAKE_LEXFLAGS =
QMAKE_YACC = byacc
@@ -22,14 +22,14 @@
QMAKE_LFLAGS_DEBUG =
QMAKE_LFLAGS_CONSOLE = -Wl,-subsystem,console
QMAKE_LFLAGS_WINDOWS = -Wl,-subsystem,windows
-@@ -94,21 +94,26 @@
+@@ -95,21 +95,26 @@
QMAKE_LIB_EXTENSIONS = a dll.a
QMAKE_LIBS =
-QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32
-QMAKE_LIBS_GUI = -lgdi32 -lcomdlg32 -loleaut32 -limm32 -lwinmm -lws2_32 -lole32 -luuid -luser32 -ladvapi32
-QMAKE_LIBS_NETWORK = -lws2_32
-+QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32 -lz -lpcre16
++QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32 -lz -lpcre16
+QMAKE_LIBS_GUI = -lgdi32 -lcomdlg32 -loleaut32 -limm32 -lwinmm -lws2_32 -lole32 -luuid -luser32 -ladvapi32 -ljpeg -lpng -lharfbuzz -lglib-2.0 -lintl -lwinmm
+QMAKE_LIBS_NETWORK = -lws2_32 -lcrypt32 -ldnsapi
QMAKE_LIBS_OPENGL = -lglu32 -lopengl32 -lgdi32 -luser32
@@ -42,9 +42,8 @@
+QMAKE_LIBS_QT_ENTRY = -lmingw32 -lqt5main
-QMAKE_IDL = midl
--QMAKE_LIB = $${CROSS_COMPILE}ar -ru
+QMAKE_IDL = $${CROSS_COMPILE}widl
-+QMAKE_LIB = $${CROSS_COMPILE}ar -rc
+ QMAKE_LIB = $${CROSS_COMPILE}ar -rc
QMAKE_RC = $${CROSS_COMPILE}windres
+QMAKE_DLLTOOL = $${CROSS_COMPILE}dlltool
+QMAKE_LRELEASE = $${CROSS_COMPILE}lrelease-qt5
diff --git a/use-external-angle-library.patch b/use-external-angle-library.patch
index 214c8b8b0ad..bbdda14974b 100644
--- a/use-external-angle-library.patch
+++ b/use-external-angle-library.patch
@@ -1,7 +1,7 @@
diff -U 3 -r a/src/gui/gui.pro b/src/gui/gui.pro
--- a/src/gui/gui.pro 2015-06-29 14:04:55.000000000 -0600
+++ b/src/gui/gui.pro 2015-07-18 10:50:02.228227482 -0600
-@@ -17,12 +17,6 @@
+@@ -17,10 +17,5 @@
imageformats \
egldeviceintegrations
@@ -10,8 +10,6 @@ diff -U 3 -r a/src/gui/gui.pro b/src/gui/gui.pro
- MODULE_AUX_INCLUDES = \
- \$\$QT_MODULE_INCLUDE_BASE/QtANGLE
-}
--
- load(qt_module)
# Code coverage with TestCocoon
@@ -35,6 +29,10 @@