summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2021-06-07 09:29:23 +0200
committerReza Jahanbakhshi2021-06-07 09:29:23 +0200
commit36b32b8673f83e0ae752221eb18a56f63bf2db97 (patch)
treef95be0fcf357dc1b253383bff1c14fdb6d6dbb43
parent13f96e6e0d69c50c8ae960ec99568edba52ea480 (diff)
downloadaur-36b32b8673f83e0ae752221eb18a56f63bf2db97.tar.gz
Changed llvm and libraries to the latest official version.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b96c235b3db..894a1d635b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.2.0_devel.139447.c0068ef4953
+ pkgver = 21.2.0_devel.140585.017a1509842
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -19,8 +19,8 @@ pkgbase = mesa-git
makedepends = meson
makedepends = ninja
makedepends = glslang
- makedepends = llvm=11.1.0
- makedepends = clang=11.1.0
+ makedepends = llvm=12.0.0
+ makedepends = clang=12.0.0
depends = libdrm
depends = libxxf86vm
depends = libxdamage
@@ -35,7 +35,7 @@ pkgbase = mesa-git
depends = vulkan-icd-loader
depends = zstd
depends = expat
- depends = llvm-libs=11.1.0
+ depends = llvm-libs=12.0.0
optdepends = opengl-man-pages: for the OpenGL API man pages
optdepends = clang: opencl
optdepends = compiler-rt: opencl
@@ -66,4 +66,3 @@ pkgbase = mesa-git
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
pkgname = mesa-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4bd14d1eb9b..06fada7008d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.2.0_devel.139447.c0068ef4953
+pkgver=21.2.0_devel.140585.017a1509842
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -72,8 +72,8 @@ case $MESA_WHICH_LLVM in
;;
4)
# extra/llvm
- makedepends+=(llvm=11.1.0 clang=11.1.0)
- depends+=(llvm-libs=11.1.0)
+ makedepends+=(llvm=12.0.0 clang=12.0.0)
+ depends+=(llvm-libs=12.0.0)
optdepends+=('clang: opencl' 'compiler-rt: opencl')
;;
*)