summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2020-07-15 11:34:39 -0400
committerAlexandre Demers2020-07-15 11:34:39 -0400
commitd4eaf492099306ebe74c5955b600f711b88b4396 (patch)
tree77ddacaca1e75106588ea07b9717ba3e729a2bcf
parente22cead08c28e7bfc666414ed4e363b597f21f38 (diff)
downloadaur-d4eaf492099306ebe74c5955b600f711b88b4396.tar.gz
Update to 4.3.1 and fix makepkg's sub-dependencies
Since makepkg doesn't install dependencies if they are listed under a specific package, put them as global dependencies. Update to 4.3.1. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO75
-rw-r--r--PKGBUILD173
2 files changed, 75 insertions, 173 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c69cf3651d..81439563301 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
- pkgver = 4.2.3
- pkgrel = 3
- epoch = 1
+ pkgver = 4.3.1
+ pkgrel = 1
+ epoch = 2
url = http://ffmpeg.org/
arch = x86_64
license = GPL3
@@ -10,16 +10,6 @@ pkgbase = lib32-ffmpeg
makedepends = git
makedepends = lib32-ladspa
makedepends = yasm
- optdepends = lib32-ladspa: LADSPA filters
- optdepends = lib32-nvidia-utils: Nvidia NVDEC/NVENC support
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.2.3
- source = vmaf-model-path.patch
- validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
- sha256sums = SKIP
- sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
-
-pkgname = lib32-ffmpeg
- pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
depends = ffmpeg
depends = lib32-alsa-lib
depends = lib32-aom
@@ -37,7 +27,6 @@ pkgname = lib32-ffmpeg
depends = lib32-libbluray
depends = lib32-libdav1d
depends = lib32-libdrm
- depends = lib32-libffmpeg
depends = lib32-freetype2
depends = lib32-libiec61883
depends = lib32-libmodplug
@@ -68,56 +57,20 @@ pkgname = lib32-ffmpeg
depends = lib32-vmaf
depends = lib32-xz
depends = lib32-zlib
+ optdepends = lib32-ladspa: LADSPA filters
+ optdepends = lib32-nvidia-utils: Nvidia NVDEC/NVENC support
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.3.1
+ source = vmaf-model-path.patch
+ validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
+ sha256sums = SKIP
+ sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
+
+pkgname = lib32-ffmpeg
+ pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
+ depends = lib32-libffmpeg
pkgname = lib32-libffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video - library (32 bit)
- depends = ffmpeg
- depends = lib32-alsa-lib
- depends = lib32-aom
- depends = lib32-bzip2
- depends = lib32-fontconfig
- depends = lib32-fribidi
- depends = lib32-glibc
- depends = lib32-gmp
- depends = lib32-gnutls
- depends = lib32-gsm
- depends = lib32-jack
- depends = lib32-lame
- depends = lib32-libass
- depends = lib32-libavc1394
- depends = lib32-libbluray
- depends = lib32-libdav1d
- depends = lib32-libdrm
- depends = lib32-freetype2
- depends = lib32-libiec61883
- depends = lib32-libmodplug
- depends = lib32-libomxil-bellagio
- depends = lib32-libpulse
- depends = lib32-libraw1394
- depends = lib32-libtheora
- depends = lib32-libva
- depends = lib32-libvdpau
- depends = lib32-libvorbis
- depends = lib32-libvpx
- depends = lib32-libwebp
- depends = lib32-libx11
- depends = lib32-x264>=0.159
- depends = lib32-x265>=3.3
- depends = lib32-libxcb
- depends = lib32-libxext
- depends = lib32-libxml2
- depends = lib32-libxv
- depends = lib32-xvidcore
- depends = lib32-opencore-amr
- depends = lib32-openjpeg2
- depends = lib32-opus
- depends = lib32-sdl2
- depends = lib32-speex
- depends = lib32-srt
- depends = lib32-v4l-utils
- depends = lib32-vmaf
- depends = lib32-xz
- depends = lib32-zlib
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index f6464e04424..63016b37bb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,76 @@
_pkgbasename=ffmpeg
pkgname=("lib32-$_pkgbasename" "lib32-lib$_pkgbasename")
-pkgver=4.2.3
-pkgrel=3
-epoch=1
+pkgver=4.3.1
+pkgrel=1
+epoch=2
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
url="http://ffmpeg.org/"
license=('GPL3')
+ depends=(
+ "$_pkgbasename"
+ 'lib32-alsa-lib'
+ 'lib32-aom'
+ 'lib32-bzip2'
+ 'lib32-fontconfig'
+ 'lib32-fribidi'
+ 'lib32-glibc'
+ 'lib32-gmp'
+ 'lib32-gnutls'
+ 'lib32-gsm'
+ 'lib32-jack'
+ 'lib32-lame'
+ 'lib32-libass'
+ 'lib32-libavc1394'
+ 'lib32-libbluray'
+ 'lib32-libdav1d'
+ 'lib32-libdrm'
+ 'lib32-freetype2'
+ 'lib32-libiec61883'
+# 'lib32-libmfx'
+ 'lib32-libmodplug'
+ 'lib32-libomxil-bellagio'
+ 'lib32-libpulse'
+# 'lib32-rav1e'
+ 'lib32-libraw1394'
+# 'lib32-libsoxr'
+# 'lib32-libssh'
+ 'lib32-libtheora'
+ 'lib32-libva'
+ 'lib32-libvdpau'
+# 'lib32-vid.stab'
+ 'lib32-libvorbis'
+ 'lib32-libvpx'
+ 'lib32-libwebp'
+ 'lib32-libx11'
+ 'lib32-x264>=0.159'
+ 'lib32-x265>=3.3'
+ 'lib32-libxcb'
+ 'lib32-libxext'
+ 'lib32-libxml2'
+ 'lib32-libxv'
+ 'lib32-xvidcore'
+ 'lib32-opencore-amr'
+ 'lib32-openjpeg2'
+ 'lib32-opus'
+ 'lib32-sdl2'
+ 'lib32-speex'
+ 'lib32-srt'
+ 'lib32-v4l-utils'
+ 'lib32-vmaf'
+ 'lib32-xz'
+ 'lib32-zlib'
+ )
makedepends=(
+# 'avisynthplus'
'ffnvcodec-headers'
'git'
'lib32-ladspa'
'yasm'
)
optdepends=(
+# 'avisynthplus: AviSynthPlus support'
# 'intel-media-sdk: Intel QuickSync support'
'lib32-ladspa: LADSPA filters'
'lib32-nvidia-utils: Nvidia NVDEC/NVENC support'
@@ -39,10 +95,6 @@ prepare() {
# Patching if needed
- # lavf/mp3dec: don't adjust start time; packets are not adjusted
- # https://crbug.com/1062037
- git cherry-pick -n 460132c9980f8a1f501a1f69477bca49e1641233
-
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
}
@@ -59,7 +111,6 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
- --enable-avisynth \
--enable-fontconfig \
--enable-gmp \
--enable-gnutls \
@@ -101,6 +152,8 @@ build() {
--enable-shared \
--enable-version3
+# --enable-avisynth \ ## not available under 32 bit
+# --enable-librav1e \ ## not available under 32 bit
# --enable-libsoxr \ ## not available under 32 bit
# --enable-libssh \ ## not available under 32 bit
# --enable-libvidstab \ ## not available under 32 bit
@@ -122,59 +175,6 @@ package_lib32-libffmpeg() {
'libswscale.so'
'lib32-ffmpeg'
)
- depends=(
- "$_pkgbasename"
- 'lib32-alsa-lib'
- 'lib32-aom'
- 'lib32-bzip2'
- 'lib32-fontconfig'
- 'lib32-fribidi'
- 'lib32-glibc'
- 'lib32-gmp'
- 'lib32-gnutls'
- 'lib32-gsm'
- 'lib32-jack'
- 'lib32-lame'
- 'lib32-libass'
- 'lib32-libavc1394'
- 'lib32-libbluray'
- 'lib32-libdav1d'
- 'lib32-libdrm'
- 'lib32-freetype2'
- 'lib32-libiec61883'
-# 'lib32-libmfx'
- 'lib32-libmodplug'
- 'lib32-libomxil-bellagio'
- 'lib32-libpulse'
- 'lib32-libraw1394'
-# 'lib32-libsoxr'
-# 'lib32-libssh'
- 'lib32-libtheora'
- 'lib32-libva'
- 'lib32-libvdpau'
-# 'lib32-vid.stab'
- 'lib32-libvorbis'
- 'lib32-libvpx'
- 'lib32-libwebp'
- 'lib32-libx11'
- 'lib32-x264>=0.159'
- 'lib32-x265>=3.3'
- 'lib32-libxcb'
- 'lib32-libxext'
- 'lib32-libxml2'
- 'lib32-libxv'
- 'lib32-xvidcore'
- 'lib32-opencore-amr'
- 'lib32-openjpeg2'
- 'lib32-opus'
- 'lib32-sdl2'
- 'lib32-speex'
- 'lib32-srt'
- 'lib32-v4l-utils'
- 'lib32-vmaf'
- 'lib32-xz'
- 'lib32-zlib'
- )
cd ${_pkgbasename}
@@ -186,58 +186,7 @@ package_lib32-libffmpeg() {
package_lib32-ffmpeg() {
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
depends=(
- "$_pkgbasename"
- 'lib32-alsa-lib'
- 'lib32-aom'
- 'lib32-bzip2'
- 'lib32-fontconfig'
- 'lib32-fribidi'
- 'lib32-glibc'
- 'lib32-gmp'
- 'lib32-gnutls'
- 'lib32-gsm'
- 'lib32-jack'
- 'lib32-lame'
- 'lib32-libass'
- 'lib32-libavc1394'
- 'lib32-libbluray'
- 'lib32-libdav1d'
- 'lib32-libdrm'
'lib32-libffmpeg'
- 'lib32-freetype2'
- 'lib32-libiec61883'
-# 'lib32-libmfx'
- 'lib32-libmodplug'
- 'lib32-libomxil-bellagio'
- 'lib32-libpulse'
- 'lib32-libraw1394'
-# 'lib32-libsoxr'
-# 'lib32-libssh'
- 'lib32-libtheora'
- 'lib32-libva'
- 'lib32-libvdpau'
-# 'lib32-vid.stab'
- 'lib32-libvorbis'
- 'lib32-libvpx'
- 'lib32-libwebp'
- 'lib32-libx11'
- 'lib32-x264>=0.159'
- 'lib32-x265>=3.3'
- 'lib32-libxcb'
- 'lib32-libxext'
- 'lib32-libxml2'
- 'lib32-libxv'
- 'lib32-xvidcore'
- 'lib32-opencore-amr'
- 'lib32-openjpeg2'
- 'lib32-opus'
- 'lib32-sdl2'
- 'lib32-speex'
- 'lib32-srt'
- 'lib32-v4l-utils'
- 'lib32-vmaf'
- 'lib32-xz'
- 'lib32-zlib'
)
cd ${_pkgbasename}