summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2021-04-02 15:54:34 -0400
committerAlexandre Demers2021-04-02 15:54:34 -0400
commit60a246f25aea67953de1d0e426a7ac0d94c8d6f1 (patch)
treee3f8075e537f0715d53e2954329e32c4a508784e
parent3e12414be37216b5d00857001d10ea13bb96db16 (diff)
downloadaur-60a246f25aea67953de1d0e426a7ac0d94c8d6f1.tar.gz
FS#70010 remove obsolete libsrt fix and update version restriction on x264
Update version restriction on lib32-x264. The epoch was missing. The restrictions should come from the packages themselves to be on par with their native counterparts... While I'm lib-x264's maintainer, I'm not for x265. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a72b377950d..d99e49c85be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
pkgver = 4.3.2
- pkgrel = 2
+ pkgrel = 3
epoch = 2
url = http://ffmpeg.org/
arch = x86_64
@@ -41,7 +41,7 @@ pkgbase = lib32-ffmpeg
depends = lib32-libvpx
depends = lib32-libwebp
depends = lib32-libx11
- depends = lib32-x264>=0.161
+ depends = lib32-x264>=3:0.161
depends = lib32-x265>=3.5
depends = lib32-libxcb
depends = lib32-libxext
diff --git a/PKGBUILD b/PKGBUILD
index 294d97c4771..b3cea81a9b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbasename=ffmpeg
pkgname=("lib32-$_pkgbasename" "lib32-lib$_pkgbasename")
pkgver=4.3.2
-pkgrel=2
+pkgrel=3
epoch=2
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
@@ -48,7 +48,7 @@ license=('GPL3')
'lib32-libvpx'
'lib32-libwebp'
'lib32-libx11'
- 'lib32-x264>=0.161'
+ 'lib32-x264>=3:0.161'
'lib32-x265>=3.5'
'lib32-libxcb'
'lib32-libxext'
@@ -97,7 +97,6 @@ prepare() {
cd ${_pkgbasename}
# Patching if needed
- git cherry-pick -n 7c59e1b0f285cd7c7b35fcd71f49c5fd52cf9315 # fix build against libsrt 1.4.2
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
}