summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonuk Raval2019-05-05 18:12:38 -0400
committerRonuk Raval2019-05-05 18:12:38 -0400
commit18a2b784888e08370c0b518be9ed3b73a237563c (patch)
tree6113842e4a4431bd84d8e24fafea8b046dea8a0c
parent34eab9d1900cc5340f2e903c3bd73e18091acfc0 (diff)
downloadaur-18a2b784888e08370c0b518be9ed3b73a237563c.tar.gz
v5.9
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD47
-rw-r--r--leo-dist.patch37
4 files changed, 29 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34b0705d5b..c49e03c9311 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,28 @@
pkgbase = leo
pkgdesc = Literate programmer's editor, outliner, and project manager
- pkgver = 5.8
+ pkgver = 5.9
pkgrel = 1
url = http://leoeditor.com/
arch = any
license = custom
+ depends = python
+ depends = python-setuptools
depends = desktop-file-utils
- depends = jupyter-nbformat
+ depends = shared-mime-info
+ depends = python-pyqt5
depends = python-docutils
- depends = python-keyring
- depends = python-pyflakes
+ depends = python-flexx
+ depends = jupyter-nbformat
depends = python-pylint
- depends = python-pypandoc
- depends = python-pyqt5
- depends = python-semantic-version
- depends = python-setuptools
+ depends = python-pyflakes
depends = python-sphinx
- depends = python-wheel
- depends = shared-mime-info
- depends = twine
+ depends = python-future
+ depends = python-six
optdepends = python-pyenchant: spellchecking support
- source = leo-5.8.tar.gz::https://github.com/leo-editor/leo-editor/archive/5.8.tar.gz
- source = leo-dist.patch
+ source = leo-5.9.tar.gz::https://github.com/leo-editor/leo-editor/archive/v5.9.tar.gz
source = leo.desktop
source = leo.xml
- sha256sums = ef8413acebb1a032ef8ba6972eb96179a3cd893eb0dd33bf0b84ca78e3c34e31
- sha256sums = 552321ab4df5c1b9ecc26aca925bacdc0ef0aca18f04e65b7fa856ff6b8bee87
+ sha256sums = 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
sha256sums = 7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
sha256sums = 630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
diff --git a/.gitignore b/.gitignore
index 135bf34e046..bf132e6d13e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/pkg
/src
+/*.pkg.tar
/*.pkg.tar.xz
/leo-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index dd8e03bbee0..5e89b260158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,64 +3,49 @@
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=5.8
+pkgver=5.9
pkgrel=1
pkgdesc="Literate programmer's editor, outliner, and project manager"
arch=('any')
url="http://leoeditor.com/"
license=('custom')
-# Many of these are actually developer-only dependencies, but the launch
-# scripts will throw `DistributionNotFound` without them.
-#
-# Upstream is working on fixing their dependency specifications:
-# https://github.com/leo-editor/leo-editor/issues/968#issuecomment-435644438
depends=(
+ python
+ python-setuptools
desktop-file-utils
- jupyter-nbformat
+ shared-mime-info
+
+ python-pyqt5
python-docutils
- python-keyring
- python-pyflakes
+ python-flexx
+ jupyter-nbformat
python-pylint
- python-pypandoc
- python-pyqt5
- python-semantic-version
- python-setuptools
+ python-pyflakes
python-sphinx
- python-wheel
- shared-mime-info
- twine
+ python-future
+ python-six
)
optdepends=('python-pyenchant: spellchecking support')
source=(
- ${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/${pkgver}.tar.gz
- leo-dist.patch
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz
leo.desktop
leo.xml
)
sha256sums=(
- ef8413acebb1a032ef8ba6972eb96179a3cd893eb0dd33bf0b84ca78e3c34e31
- 5140c9daf92eb0b3bacea022bb6a7e46911cb727d8372fdb756a31f8bcd6c8f0
+ 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
)
-prepare() {
+build() {
cd "leo-editor-${pkgver}"
-
- # leo's packaging workflow currently requires several workarounds to
- # function:
- #
- # https://github.com/leo-editor/leo-editor/issues/968#issuecomment-451763826
- patch -p1 < ../leo-dist.patch
+ python setup.py build
}
package() {
cd "leo-editor-${pkgver}"
- # leo's setup.py has a hardcoded clean step that always removes the `build`
- # directory. So providing separate `build()` and `package()` steps is futile.
- python setup.py install --root="$pkgdir/" --optimize=1
-
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 "$srcdir/leo.desktop" "$pkgdir/usr/share/applications/leo.desktop"
install -D -m644 "$srcdir/leo.xml" "$pkgdir/usr/share/mime/packages/leo.xml"
diff --git a/leo-dist.patch b/leo-dist.patch
deleted file mode 100644
index a83d82fda27..00000000000
--- a/leo-dist.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -Naur leo-editor-5.8/MANIFEST.in leo-editor-5.8-patch/MANIFEST.in
---- leo-editor-5.8/MANIFEST.in 1969-12-31 19:00:00.000000000 -0500
-+++ leo-editor-5.8-patch/MANIFEST.in 2019-01-06 12:29:19.567721953 -0500
-@@ -0,0 +1,22 @@
-+# Processed in order listed
-+# Global
-+#recursive-include leo *.* # not needed when using `graft`
-+graft leo
-+global-exclude *.py[cod] __pycache__ *.so
-+
-+# Root folder
-+include *.TXT
-+include launchLeo.py
-+include profileLeo.py
-+include pylint-leo.bat
-+include pylint-leo.py
-+include *.nsi
-+
-+# Exclusions
-+# same as scrub_datafiles in setup.py, prior to Github commit 9982d17e2470ac8313050b8a0288cd39d7ad4f5b
-+prune leo/test
-+prune leo/doc/html
-+
-+# Issue #603, https://github.com/leo-editor/leo-editor/issues/603
-+include leo/doc/html/conf.py
-+include leo/doc/html/index.html
-diff -Naur leo-editor-5.8/setup.py leo-editor-5.8-patch/setup.py
---- leo-editor-5.8/setup.py 2018-10-01 12:15:11.000000000 -0400
-+++ leo-editor-5.8-patch/setup.py 2019-01-06 12:30:37.254242095 -0500
-@@ -156,6 +156,7 @@
- include_package_data=True, # also include MANIFEST files in wheels
- setup_requires=setup_requires,
- install_requires=user_requires,
-+ scripts=['leo/dist/leo-install.py'],
- entry_points={
- 'console_scripts': ['leo-c = leo.core.runLeo:run_console',
- 'leo-console = leo.core.runLeo:run_console',