summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-03-25 11:08:53 +0200
committerEmiel Wiedijk2018-03-25 11:08:53 +0200
commite10c6ef3d0d1856333b8b30aa8c90ef19596a38b (patch)
tree7c46f29904d1a15357abe9a202f4c2ca44c5a093
parentd82dc9368a245b03659119f3a05d5e4290b7277b (diff)
downloadaur-e10c6ef3d0d1856333b8b30aa8c90ef19596a38b.tar.gz
Remove indicator-kdeconnect-git from conflicts
According to the ArchWiki (https://wiki.archlinux.org/index.php/PKGBUILD#conflicts), all packages providing a feature (i.e. indicator-kdeconnect) should conflict with and provide the vanilla package (in this case indicator-kdeconnect, this package). Other packages (i.e. indicator-kdeconnect-git or indicator-kdeconnect-patch) will add inidicator-kdeconnect to the conflicts and provides arrays. Pacman is able to figure out the conflicts itself.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD1
2 files changed, 0 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcd8873eddb..95c79d28ca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,6 @@ pkgbase = indicator-kdeconnect
depends = kdeconnect
depends = python-requests-oauthlib
depends = python-gobject
- conflicts = indicator-kdeconnect-git
source = indicator-kdeconnect-0.9.3.tar.gz::https://github.com/Bajoja/indicator-kdeconnect/archive/0.9.3.tar.gz
sha256sums = 6a75da2b87c8c23808376683db5a2563dc31fd9a38548ac1480682e53245bed0
diff --git a/PKGBUILD b/PKGBUILD
index 2dd878ca4e7..d49fe8664d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,6 @@ pkgdesc="Integrate KDEConnect on desktop environments that use AppIndicators (e.
arch=('x86_64')
url="https://github.com/bajoja/indicator-kdeconnect"
license=('LGPL')
-conflicts=("${pkgname}-git")
depends=('libappindicator-gtk3' 'kdeconnect' 'python-requests-oauthlib' 'python-gobject')
makedepends=('cmake' 'vala')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Bajoja/indicator-kdeconnect/archive/${pkgver}.tar.gz")