summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-03-23 13:25:56 +0100
committerGordian Edenhofer2016-03-23 13:25:56 +0100
commit68cdfa5d1d57cb6450f64d448f8c80938db552dc (patch)
tree3b7b4ab7b0c5a94a4480a8162816fc428e5b5431
parentc7711b431753826e6d9f0812f4a6f7b730017999 (diff)
downloadaur-68cdfa5d1d57cb6450f64d448f8c80938db552dc.tar.gz
Upgpkg: 106.5bc5245-1
Make depends optdepends since it might be desirable to only support one gtk version and not both.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c349814156e..5c45b9d372e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gtk-theme-iris-dark-git
- pkgdesc = A flat theme that uses varying shades and tones to create distinction and a modern experience. It supports Gtk 3.10, Gtk 3.12 and Gtk 2 (using the Murrine engine).
+ pkgdesc = A flat theme that uses varying shades and tones to create distinction and a modern experience.
pkgver = 106.5bc5245
pkgrel = 1
url = http://thevirtualdragon.deviantart.com/art/Iris-Dark-Gtk-Theme-v1-9-429628194
@@ -7,8 +7,8 @@ pkgbase = gtk-theme-iris-dark-git
arch = any
license = GPL3
makedepends = git
- depends = gtk3
- depends = gtk-engine-murrine
+ optdepends = gtk-engine-murrine: gtk2 bindings
+ optdepends = gtk3: gtk3 bindings
provides = gtk-theme-iris-dark
conflicts = gtk-theme-iris-dark
source = iris-dark::git+https://github.com/xyl0n/iris.git
diff --git a/PKGBUILD b/PKGBUILD
index b6c4cb93979..6da4a80dcc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,12 @@ pkgname=gtk-theme-iris-dark-git
_pkgname=iris-dark
pkgver=106.5bc5245
pkgrel=1
-pkgdesc="A flat theme that uses varying shades and tones to create distinction and a modern experience. It supports Gtk 3.10, Gtk 3.12 and Gtk 2 (using the Murrine engine)."
+pkgdesc="A flat theme that uses varying shades and tones to create distinction and a modern experience."
arch=('any')
url="http://thevirtualdragon.deviantart.com/art/Iris-Dark-Gtk-Theme-v1-9-429628194"
license=('GPL3')
-depends=('gtk3' 'gtk-engine-murrine')
+optdepends=("gtk-engine-murrine: gtk2 bindings"
+ "gtk3: gtk3 bindings")
makedepends=('git')
provides=('gtk-theme-iris-dark')
conflicts=('gtk-theme-iris-dark')