summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartoszek2019-10-03 15:28:50 +0200
committerbartus2019-10-23 10:56:15 +0200
commita794ea20590772d993e248f565b57a486899090a (patch)
tree596bb4f25536a75552999aaf8591014450a2678f
parentda25ae747d6bddaac4a99741beef96c6d753ce97 (diff)
downloadaur-a794ea20590772d993e248f565b57a486899090a.tar.gz
Update deps (nsgif,luajit,vala,exiv,mrg) and provide.
-rw-r--r--.SRCINFO18
-rw-r--r--.travis.yml1
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.in16
4 files changed, 38 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53338351fd8..0b4e8a54142 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gegl-git
pkgdesc = Graph based image processing framework
- pkgver = 0.4.17.r9794.ae8b3e7ca
+ pkgver = 0.4.17.r9806.592a7db44
pkgrel = 1
url = https://www.gegl.org
arch = i686
@@ -12,18 +12,25 @@ pkgbase = gegl-git
makedepends = intltool
makedepends = python
makedepends = ruby
- makedepends = lua
+ makedepends = luajit
makedepends = libraw
makedepends = openexr
makedepends = ffmpeg
makedepends = librsvg
makedepends = jasper
makedepends = libtiff
+ makedepends = libnsgif
+ makedepends = exiv2
+ makedepends = libgexiv2
+ makedepends = lensfun
+ makedepends = vala
+ makedepends = python-gobject
makedepends = suitesparse
makedepends = gobject-introspection
depends = babl>=0.1.72
depends = libspiro
depends = json-glib
+ depends = sdl2
optdepends = openexr: for using the openexr plugin
optdepends = ffmpeg: for using the ffmpeg plugin
optdepends = librsvg: for using the svg plugin
@@ -31,8 +38,11 @@ pkgbase = gegl-git
optdepends = jasper: for using the jasper plugin
optdepends = libraw: raw plugin
optdepends = suitesparse: matting-levin plugin
- optdepends = lua: lua plugin
- provides = gegl=0.4.17.r9794.ae8b3e7ca
+ optdepends = luajit: lua plugin
+ optdepends = libgexiv2: for image metadata
+ optdepends = lensfun: for lens distortion
+ optdepends = libnsgif: gif plugin
+ provides = gegl=0.4.17
conflicts = gegl
options = !libtool
source = git+https://gitlab.gnome.org/GNOME/gegl.git
diff --git a/.travis.yml b/.travis.yml
index d9c08ec6aa0..18bd967f032 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -24,6 +24,7 @@ archlinux:
- ccache
- moreutils
- babl-git
+# - mrg-git
before_install:
# 1.Override `package-cleanup.hook` to preserve cache for travis.
# 2.Enable ccache
diff --git a/PKGBUILD b/PKGBUILD
index 7ee5a98ad85..37f594d789d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,18 @@
_pkgname=gegl
pkgname="${_pkgname}-git"
-pkgver=0.4.17.r9794.ae8b3e7ca
+pkgver=0.4.17.r9806.592a7db44
pkgrel=1
pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
url="https://www.gegl.org"
license=('GPL3' 'LGPL3')
-depends=('babl>=0.1.72' 'libspiro' 'json-glib')
-makedepends=('git' 'meson' 'intltool' 'python' 'ruby' 'lua'
+depends=('babl>=0.1.72' 'libspiro' 'json-glib' 'sdl2') #'mrg'
+makedepends=('git' 'meson' 'intltool' 'python' 'ruby' 'luajit'
'libraw' 'openexr' 'ffmpeg' 'librsvg' 'jasper'
- 'libtiff' 'suitesparse' 'gobject-introspection')
+ 'libtiff' 'libnsgif' 'exiv2' 'libgexiv2' 'lensfun'
+ 'vala' 'python-gobject'
+ 'suitesparse' 'gobject-introspection')
optdepends=('openexr: for using the openexr plugin'
'ffmpeg: for using the ffmpeg plugin'
'librsvg: for using the svg plugin'
@@ -26,8 +28,11 @@ optdepends=('openexr: for using the openexr plugin'
'jasper: for using the jasper plugin'
'libraw: raw plugin'
'suitesparse: matting-levin plugin'
- 'lua: lua plugin')
-provides=("gegl=$pkgver")
+ 'luajit: lua plugin'
+ 'libgexiv2: for image metadata'
+ 'lensfun: for lens distortion'
+ 'libnsgif: gif plugin')
+provides=("gegl=${pkgver%%.r*}")
conflicts=('gegl')
options=(!libtool)
source=('git+https://gitlab.gnome.org/GNOME/gegl.git')
@@ -54,6 +59,7 @@ pkgver() {
}
build() {
+ export NINJA_STATUS="[%p | %f<%r<%u | %cbps ] "
ninja -C "${srcdir}/build"
}
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 32ef7a64465..665b4662439 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -15,10 +15,12 @@ pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
url="https://www.gegl.org"
license=('GPL3' 'LGPL3')
-depends=('babl>=@_babl_version@' 'libspiro' 'json-glib')
-makedepends=('git' 'meson' 'intltool' 'python' 'ruby' 'lua'
+depends=('babl>=@_babl_version@' 'libspiro' 'json-glib' 'sdl2') #'mrg'
+makedepends=('git' 'meson' 'intltool' 'python' 'ruby' 'luajit'
'libraw' 'openexr' 'ffmpeg' 'librsvg' 'jasper'
- 'libtiff' 'suitesparse' 'gobject-introspection')
+ 'libtiff' 'libnsgif' 'exiv2' 'libgexiv2' 'lensfun'
+ 'vala' 'python-gobject'
+ 'suitesparse' 'gobject-introspection')
optdepends=('openexr: for using the openexr plugin'
'ffmpeg: for using the ffmpeg plugin'
'librsvg: for using the svg plugin'
@@ -26,8 +28,11 @@ optdepends=('openexr: for using the openexr plugin'
'jasper: for using the jasper plugin'
'libraw: raw plugin'
'suitesparse: matting-levin plugin'
- 'lua: lua plugin')
-provides=("gegl=$pkgver")
+ 'luajit: lua plugin'
+ 'libgexiv2: for image metadata'
+ 'lensfun: for lens distortion'
+ 'libnsgif: gif plugin')
+provides=("gegl=${pkgver%%.r*}")
conflicts=('gegl')
options=(!libtool)
source=('git+https://gitlab.gnome.org/GNOME/gegl.git')
@@ -54,6 +59,7 @@ pkgver() {
}
build() {
+ export NINJA_STATUS="[%p | %f<%r<%u | %cbps ] "
ninja -C "${srcdir}/build"
}