summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-02-22 01:47:02 +0000
committerDaniel Bermond2019-02-22 01:47:02 +0000
commiteff2f3a3ae508729a08597c5a15ce2d17fb5823a (patch)
treeee20b8a20b765d80ca819b2e95a9d6e58cd99b52
parent648f82331b8ce8bb36dccccc9744ee88d70993da (diff)
downloadaur-eff2f3a3ae508729a08597c5a15ce2d17fb5823a.tar.gz
Temporarily disable cuda-sdk due to upstream build error
References ---------- https://trac.ffmpeg.org/ticket/7742
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 687002e243b..7e63f33c464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)
- pkgver = 4.2.r92924.g5faa1b8b5a
+ pkgver = 4.2.r93217.ga899b3b3c5
pkgrel = 1
url = https://www.ffmpeg.org/
arch = i686
@@ -28,6 +28,7 @@ pkgbase = ffmpeg-full-git
depends = libcaca
depends = celt
depends = libcdio-paranoia
+ depends = dav1d
depends = libdc1394
depends = libavc1394
depends = libfdk-aac
@@ -89,7 +90,6 @@ pkgbase = ffmpeg-full-git
depends = libvdpau
depends = chromaprint-fftw
depends = codec2
- depends = dav1d
depends = davs2
depends = flite1-patched
depends = libilbc
diff --git a/PKGBUILD b/PKGBUILD
index 15428668942..bed61ed153f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ffmpeg-full-git
_srcname=ffmpeg
-pkgver=4.2.r92924.g5faa1b8b5a
+pkgver=4.2.r93217.ga899b3b3c5
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ depends=(
# official repositories:
'glibc' 'alsa-lib' 'jack' 'libpng'
'bzip2' 'frei0r-plugins' 'libgcrypt' 'gmp' 'gnutls' 'ladspa' 'libass' 'aom'
- 'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'libdc1394'
+ 'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'dav1d' 'libdc1394'
'libavc1394' 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm'
'libiec61883' 'lensfun' 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus'
'pulseaudio' 'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr'
@@ -22,9 +22,9 @@ depends=(
'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth' 'libxv' 'libx11'
'libxext' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
# AUR:
- 'chromaprint-fftw' 'codec2' 'dav1d' 'davs2' 'flite1-patched' 'libilbc'
- 'libklvanc-git' 'kvazaar' 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc'
- 'xavs' 'xavs2' 'ndi-sdk' 'libmysofa-git' 'rockchip-mpp'
+ 'chromaprint-fftw' 'codec2' 'davs2' 'flite1-patched' 'libilbc' 'libklvanc-git'
+ 'kvazaar' 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc' 'xavs' 'xavs2'
+ 'ndi-sdk' 'libmysofa-git' 'rockchip-mpp'
)
depends_x86_64=(
# official repositories:
@@ -72,7 +72,7 @@ build() {
if [ "$CARCH" = 'x86_64' ]
then
local _libvmaf='--enable-libvmaf'
- local _cudasdk='--enable-cuda-sdk'
+ local _cudasdk='--disable-cuda-sdk'
local _libmfx='--enable-libmfx'
local _libnpp='--enable-libnpp'