summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-08-12 21:47:56 +0000
committerDaniel Bermond2020-08-12 21:51:16 +0000
commitb38e834c47562855016e855af82456e3f752eccd (patch)
treefd50c129fb39c5a0a8372b72f30ede20539d34dd
parentb1cef38294c451baf2e1ee12bc0cfc58a7f05259 (diff)
downloadaur-b38e834c47562855016e855af82456e3f752eccd.tar.gz
Temporarily disable tensorflow
A recent commit[1] at upstream ffmpeg broke tensorflow support. Temporarily disabling it until it's fixed upstream. References ---------- [1] http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=0a51abe8ab71c03eff66200265142fc910bcbfe2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 214552ffc1d..467b79d771e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 4.4.r98638.g9c0beaf0d3
+ pkgver = 4.4.r98723.gbb59bdbcd1
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -64,7 +64,6 @@ pkgbase = ffmpeg-full-git
depends = svt-hevc
depends = svt-av1
depends = svt-vp9
- depends = tensorflow
depends = tesseract
depends = libtheora
depends = twolame
diff --git a/PKGBUILD b/PKGBUILD
index 1a619e58436..5a8c6ffc54d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _svt_hevc_ver='1.5.0'
_svt_vp9_ver='0.2.2'
pkgname=ffmpeg-full-git
-pkgver=4.4.r98638.g9c0beaf0d3
+pkgver=4.4.r98723.gbb59bdbcd1
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -19,7 +19,7 @@ depends=(
'libilbc' 'jack' 'kvazaar' 'lensfun' 'libmodplug' 'lame' 'opencore-amr'
'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c' 'rav1e' 'librsvg' 'rubberband'
'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh' 'svt-hevc' 'svt-av1'
- 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame' 'v4l-utils'
+ 'svt-vp9' 'tesseract' 'libtheora' 'twolame' 'v4l-utils'
'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264' 'x265'
'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
@@ -80,7 +80,7 @@ build() {
./configure \
--prefix='/usr' \
- --extra-cflags='-I/opt/cuda/include -I/usr/include/tensorflow' \
+ --extra-cflags='-I/opt/cuda/include' \
--extra-ldflags='-L/opt/cuda/lib64' \
\
--disable-rpath \
@@ -154,7 +154,7 @@ build() {
--enable-libssh \
--enable-libsvthevc \
--enable-libsvtav1 \
- --enable-libtensorflow \
+ --disable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \
--disable-libtls \