summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-08-27 17:39:23 +0000
committerDaniel Bermond2019-08-27 18:02:17 +0000
commitac942cbfe8f3244f6e1358ff465525cfecef2488 (patch)
tree14b3afbe7f50e056b43142257584a8993126dcb4
parent39351983f025d378e02e6967ec156aad021396d0 (diff)
downloadaur-ac942cbfe8f3244f6e1358ff465525cfecef2488.tar.gz
Remove --enable-omx-rpi
Although this option is specific to the Raspberry Pi, it was compiling fine so it was ok to leave it there. But a recent upstream ffmpeg commit[1] broke build with this option, making it to fail with the following error: ‘OMX_IndexConfigBrcmVideoRequestIFrame’ undeclared. Now it needs headers[1] that are specific to the Raspeberry Pi firmware, so it will be removed. References ---------- [1] https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/76c82843ccad11666603e3f1f6d9d9a36c780a32 [2] https://github.com/raspberrypi/firmware/blob/1.20190819/hardfp/opt/vc/include/IL/OMX_Index.h#L381
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 2 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3d72ad6af4..39e485159bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)
- pkgver = 4.3.r94501.g33186028fc
+ pkgver = 4.3.r94667.gdead949a1f
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 52a216ef5b4..b8849f78f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _svt_av1_ver='0.6.0'
_svt_vp9_ver='ce245894c6fc1c5d1439c41a7dda8d6dc61784c4'
pkgname=ffmpeg-full-git
-pkgver=4.3.r94501.g33186028fc
+pkgver=4.3.r94667.gdead949a1f
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('x86_64')
@@ -218,7 +218,6 @@ build() {
--enable-nvdec \
--enable-nvenc \
--enable-omx \
- --enable-omx-rpi \
--enable-rkmpp \
--enable-v4l2-m2m \
--enable-vaapi \