summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-21 18:21:14 +0000
committerDaniel Bermond2018-11-21 18:22:16 +0000
commitf12ec9acea516c773870506abae2b0e7fd2a1067 (patch)
tree2122a06d559da07d8f31e322b94c63fb7d15ff00
parent928fae4a6544f341d2ae69d8c2cde129d7a6a85a (diff)
downloadaur-f12ec9acea516c773870506abae2b0e7fd2a1067.tar.gz
Temporarily disable libsmbclient due to upstream bug
ffmpeg fails to compile with the newly released smbclient 4.9[1]. Currently, there is a pull request[2] at upstream samba that aparently fixes this, but it still was not accepted at the time of writing. It is being discussed on the samba mailing list[3]. Disabling libsmbclient until there is a consistent upstream solution. References ---------- [1] https://bugs.gentoo.org/666548 [2] https://github.com/samba-team/samba/pull/212/ [3] https://lists.samba.org/archive/samba-technical/2018-October/130668.html
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac21286b1c7..f6f9d4c2d60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)
pkgver = 4.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.ffmpeg.org/
arch = i686
arch = x86_64
@@ -46,7 +46,6 @@ pkgbase = ffmpeg-full
depends = librsvg
depends = rubberband
depends = rtmpdump
- depends = smbclient
depends = snappy
depends = libsoxr
depends = speex
diff --git a/PKGBUILD b/PKGBUILD
index 36bc8036113..1f8061acf14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ffmpeg-full
_srcname=ffmpeg
pkgver=4.1
-pkgrel=2
+pkgrel=3
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)'
arch=('i686' 'x86_64')
url='https://www.ffmpeg.org/'
@@ -16,7 +16,7 @@ depends=(
'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'libdc1394'
'libavc1394' 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm'
'libiec61883' 'lensfun' 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus'
- 'pulseaudio' 'librsvg' 'rubberband' 'rtmpdump' 'smbclient' 'snappy' 'libsoxr'
+ 'pulseaudio' 'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr'
'speex' 'srt' 'libssh' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
'v4l-utils' 'vid.stab' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'libx264.so'
'x265' 'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
@@ -142,7 +142,7 @@ build() {
--enable-librubberband \
--enable-librtmp \
--enable-libshine \
- --enable-libsmbclient \
+ --disable-libsmbclient \
--enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \