summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealitygaps2015-07-06 16:51:00 +0200
committerrealitygaps2015-07-06 16:51:00 +0200
commita7b89745c0c3072b7b1900b92d29644c21bd9d8a (patch)
tree8967e7f9ed1e0f33841ba075525e695c90159472
downloadaur-a7b89745c0c3072b7b1900b92d29644c21bd9d8a.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--fengoffice.install51
4 files changed, 99 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 00000000000..f9b04d8201e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = fengoffice
+ pkgdesc = OpenGoo is an easy to use Open Source Web Office
+ pkgver = 2.6.3
+ pkgrel = 1
+ url = http://www.fengoffice.com/
+ install = fengoffice.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = php
+ source = http://downloads.sourceforge.net/opengoo/fengoffice/fengoffice_2.6.3/fengoffice_2.6.3.zip
+
+pkgname = fengoffice
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..b074f3310b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fengoffice
+ pkgdesc = OpenGoo is an easy to use Open Source Web Office
+ pkgver = 2.6.3
+ pkgrel = 1
+ url = http://www.fengoffice.com/
+ install = fengoffice.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = php
+ source = http://downloads.sourceforge.net/opengoo/fengoffice/fengoffice_2.6.3/fengoffice_2.6.3.zip
+ md5sums = bb849c2d79a94c5abae259eb5b30bf55
+
+pkgname = fengoffice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..a76466df555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: realitygaps <realitygaps AT yahoo DOT com>
+
+pkgname=fengoffice
+pkgver=2.6.3
+pkgrel=1
+pkgdesc="OpenGoo is an easy to use Open Source Web Office"
+arch=('i686' 'x86_64')
+url="http://www.fengoffice.com/"
+license=('GPL')
+depends=('php')
+install=${pkgname}.install
+source=(http://downloads.sourceforge.net/opengoo/$pkgname/${pkgname}_${pkgver}/${pkgname}_$pkgver.zip)
+md5sums=('bb849c2d79a94c5abae259eb5b30bf55')
+
+
+build() {
+ mkdir -p $startdir/pkg/${pkgname}/usr/share/webapps/fengoffice
+ cp -r $startdir/src/* $startdir/pkg/${pkgname}/usr/share/webapps/$pkgname
+}
diff --git a/fengoffice.install b/fengoffice.install
new file mode 100644
index 00000000000..b1b5d67db13
--- /dev/null
+++ b/fengoffice.install
@@ -0,0 +1,51 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "Remember that you need to install either mysql or postgresql for this package"
+ echo "to work. Also make sure to read either INSTALL.mysql.txt (for MySQL) or"
+ echo "INSTALL.pgsql.txt (for PostgreSQL) in /srv/www/atrium/."
+ if [[ ! `grep "^extension=mysql.so" /etc/php/php.ini` ]]
+ then echo "If you use mysql you should enable its module by adding the line:"
+ echo " extension=mysql.so"
+ echo "to your /etc/php/php.ini, otherwise fengoffice won't work."
+ fi
+ if [[ ! `grep "^extension=openssl.so" /etc/php/php.ini` ]]
+ then echo "Fengoffice requires openssl, you should enable its module by adding the line:"
+ echo " extension=openssl.so"
+ echo "to your /etc/php/php.ini, otherwise fengoffice won't work."
+ fi
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*