summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2020-05-07 17:04:35 +0200
committerJelle van der Waa2020-05-07 17:04:35 +0200
commit1c813f3ffa984d538f6a7d1f263000c588bf7931 (patch)
tree413e22cc9d0f62ebe6da7abed5fc1234edb33d53
downloadaur-empathy.tar.gz
import from community
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD58
-rw-r--r--enchant-2.patch39
3 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..5e5b401505a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = empathy
+ pkgdesc = A GNOME instant messaging client using the Telepathy framework
+ pkgver = 3.25.90+34+g78f4d4fda
+ pkgrel = 3
+ url = https://wiki.gnome.org/Apps/Empathy
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = docbook-xsl
+ makedepends = python
+ makedepends = gnome-common
+ makedepends = git
+ depends = clutter-gst
+ depends = clutter-gtk
+ depends = folks
+ depends = gcr
+ depends = iso-codes
+ depends = libcanberra
+ depends = libpulse
+ depends = webkit2gtk
+ depends = telepathy-farstream
+ depends = telepathy-glib
+ depends = telepathy-logger
+ depends = telepathy-mission-control
+ depends = geoclue2
+ depends = geocode-glib
+ depends = cheese
+ depends = libchamplain
+ depends = libgudev
+ optdepends = telepathy-gabble: XMPP/Jabber support
+ optdepends = telepathy-idle: IRC support
+ optdepends = telepathy-salut: Link-local XMPP support
+ optdepends = telepathy-haze: libpurple support
+ source = git+https://git.gnome.org/browse/empathy#commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9
+ source = git+https://git.gnome.org/browse/telepathy-account-widgets
+ source = enchant-2.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e
+
+pkgname = empathy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..f72f1048822
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=empathy
+pkgver=3.25.90+34+g78f4d4fda
+pkgrel=3
+pkgdesc="A GNOME instant messaging client using the Telepathy framework"
+url="https://wiki.gnome.org/Apps/Empathy"
+arch=(x86_64)
+license=(GPL2)
+depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
+ telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control geoclue2
+ geocode-glib cheese libchamplain libgudev)
+makedepends=(intltool itstool docbook-xsl python gnome-common git)
+optdepends=('telepathy-gabble: XMPP/Jabber support'
+ 'telepathy-idle: IRC support'
+ 'telepathy-salut: Link-local XMPP support'
+ 'telepathy-haze: libpurple support')
+_commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9 # master
+source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
+ "git+https://git.gnome.org/browse/telepathy-account-widgets"
+ enchant-2.patch)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^EMPATHY_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+
+ git submodule init
+ git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
+ git submodule update
+
+ patch -Np1 -i ../enchant-2.patch
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/empathy \
+ --disable-static \
+ --disable-Werror
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/enchant-2.patch b/enchant-2.patch
new file mode 100644
index 00000000000..f80a52216d4
--- /dev/null
+++ b/enchant-2.patch
@@ -0,0 +1,39 @@
+ configure.ac | 4 ++--
+ libempathy-gtk/empathy-spell.c | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git c/configure.ac i/configure.ac
+index 7aeb6b31c..31e5b847b 100644
+--- c/configure.ac
++++ i/configure.ac
+@@ -72,7 +72,7 @@ WEBKIT_REQUIRED=2.10.0
+ GOA_REQUIRED=3.5.1
+
+ # Optional deps
+-ENCHANT_REQUIRED=1.2.0
++ENCHANT_REQUIRED=2.2.0
+ GEOCLUE_REQUIRED=2.1.0
+ GEOCODE_GLIB_REQUIRED=0.99.1
+ ISO_CODES_REQUIRED=0.35
+@@ -307,7 +307,7 @@ AC_ARG_ENABLE(spell,
+ if test "x$enable_spell" != "xno"; then
+ PKG_CHECK_MODULES(ENCHANT,
+ [
+- enchant >= $ENCHANT_REQUIRED,
++ enchant-2 >= $ENCHANT_REQUIRED,
+ iso-codes >= $ISO_CODES_REQUIRED
+ ], have_enchant="yes", have_enchant="no")
+
+diff --git c/libempathy-gtk/empathy-spell.c i/libempathy-gtk/empathy-spell.c
+index 27f27f902..bb0159fd8 100644
+--- c/libempathy-gtk/empathy-spell.c
++++ i/libempathy-gtk/empathy-spell.c
+@@ -424,7 +424,7 @@ empathy_spell_add_to_dictionary (const gchar *code,
+ if (lang == NULL)
+ return;
+
+- enchant_dict_add_to_pwl (lang->speller, word, strlen (word));
++ enchant_dict_add (lang->speller, word, strlen (word));
+ }
+
+ #else /* not HAVE_ENCHANT */