summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Teles2018-09-09 23:08:20 -0300
committerAlexandre Teles2018-09-09 23:08:20 -0300
commit777e12c252ab8d9491c82e1cd95d9d0edb3d0efb (patch)
tree568ee1b7d583480a63ac5cb239ca1390396279de
parent2d4cd7bacb37c05730a7079774c0302ba18f7ad5 (diff)
downloadaur-777e12c252ab8d9491c82e1cd95d9d0edb3d0efb.tar.gz
update srcinfo
-rw-r--r--.SRCINFO89
1 files changed, 83 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce14403158d..e9d4021ae50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,21 +2,98 @@ pkgbase = deepin-crossover
pkgdesc = Run Windows Programs on Linux (contains the Deepin OS license information)
pkgver = 16.0.6
pkgrel = 1
- provides = crossover-deepin
- provides = crossover
- conflicts = crossover
url = https://www.codeweavers.com/
+ install = deepin-crossover.install
arch = i686
arch = x86_64
- license = CrossOver Linux License Grant
- makedepends = tar
+ license = custom:CrossOver Linux License Grant
depends = python2
depends = desktop-file-utils
depends = pygtk
depends = python2-dbus
+ optdepends = unzip: required to install Guild Wars, automatic installer extraction
+ provides = crossover-deepin
+ provides = crossover
+ conflicts = crossover
noextract = crossover-deepin_16.0.6-1_i386.deb
source = http://mirrors.deepin.com/deepin/pool/non-free/c/crossover-deepin/crossover-deepin_16.0.6-1_i386.deb
- sha256sums = c5f59fd1d4ed2b1df597e0d4290fbbaf
+ sha256sums = a3cbec7ad524cf87acf9b880b1134821bca5c36b14dd8151dbe9041d7e0c10a6
+ depends_i686 = glibc>=2.11
+ depends_i686 = libice
+ depends_i686 = libsm
+ depends_i686 = libx11
+ depends_i686 = libxext
+ depends_i686 = libxi
+ depends_i686 = freetype2
+ depends_i686 = libpng
+ depends_i686 = zlib
+ depends_i686 = lcms2
+ depends_i686 = libgl
+ depends_i686 = libxcursor
+ depends_i686 = libxrandr
+ depends_i686 = glu
+ optdepends_i686 = alsa-lib: This is the preferred way to provide audio support to Windows applications.
+ optdepends_i686 = fontconfig: Makes it possible to find and use the system's TrueType fonts. This is strongly recommended for office-type applications.
+ optdepends_i686 = gnutls: This is needed by applications that perform encryption or check online certificates.
+ optdepends_i686 = gsm: Lets Windows applications use the GSM codec for audio compression and decompression.
+ optdepends_i686 = gstreamer0.10: This is needed by some games and multimedia applications.
+ optdepends_i686 = gstreamer0.10-base: This is needed by some games and multimedia applications.
+ optdepends_i686 = isdn4k-utils: (libcapi)Provides support for some ISDN cards. Very few applications need this.
+ optdepends_i686 = libcups: Needed to print to printers managed by the CUPS system, which is most likely the case. It is strongly recommended for office-type applications.
+ optdepends_i686 = libdbus: This is needed for Windows applications to automatically detect CD-ROM and USB key insertion.
+ optdepends_i686 = libexif: Some applications need to parse EXIF and read their data tags.
+ optdepends_i686 = libgphoto2: Lets Windows applications access digital cameras.
+ optdepends_i686 = libldap: Lets Windows applications access LDAP servers.
+ optdepends_i686 = libpulse: A featureful, general-purpose sound server (client library).
+ optdepends_i686 = libxcomposite: This is needed for most CAD-like applications and some games.
+ optdepends_i686 = libxinerama: This is needed if your display spans multiple screens. If your computer has a single screen then you don't need it.
+ optdepends_i686 = libxml2: This library makes it possible for Windows applications read and write XML files.
+ optdepends_i686 = libxslt: This library lets Windows applications perform queries and transformations on XML files.
+ optdepends_i686 = libxxf86vm: This is needed to let games perform some gamma adjustments (essentially to adjust the brightness).
+ optdepends_i686 = libxxf86dga: X11 Direct Graphics Access extension library.
+ optdepends_i686 = mpg123: Needed by some Windows applications to play MP3 files.
+ optdepends_i686 = nss-mdns: Host name resolution via mDNS
+ optdepends_i686 = ocl-icd: OpenCL ICD Bindings
+ optdepends_i686 = openal: Provides audio support to Windows applications.
+ optdepends_i686 = openssl: This library provides support for secure Internet communication.
+ optdepends_i686 = sane: Lets Windows applications access scanners.
+ optdepends_i686 = v4l-utils: Lets Windows applications access video devices.
+ depends_x86_64 = lib32-glibc>=2.11
+ depends_x86_64 = lib32-libice
+ depends_x86_64 = lib32-libsm
+ depends_x86_64 = lib32-libx11
+ depends_x86_64 = lib32-libxext
+ depends_x86_64 = lib32-libxi
+ depends_x86_64 = lib32-freetype2
+ depends_x86_64 = lib32-libpng
+ depends_x86_64 = lib32-zlib
+ depends_x86_64 = lib32-lcms2
+ depends_x86_64 = lib32-libgl
+ depends_x86_64 = lib32-libxcursor
+ depends_x86_64 = lib32-libxrandr
+ depends_x86_64 = lib32-glu
+ optdepends_x86_64 = lib32-alsa-lib: This is the preferred way to provide audio support to Windows applications.
+ optdepends_x86_64 = lib32-fontconfig: Makes it possible to find and use the system's TrueType fonts. This is strongly recommended for office-type applications.
+ optdepends_x86_64 = lib32-libcups: Needed to print to printers managed by the CUPS system, which is most likely the case. It is strongly recommended for office-type applications.
+ optdepends_x86_64 = lib32-libdbus: This is needed for Windows applications to automatically detect CD-ROM and USB key insertion.
+ optdepends_x86_64 = lib32-libexif: (aur) Some applications need to parse EXIF and read their data tags.
+ optdepends_x86_64 = lib32-libldap: Lets Windows applications access LDAP servers.
+ optdepends_x86_64 = lib32-libpulse: A featureful, general-purpose sound server (client library).
+ optdepends_x86_64 = lib32-gnutls: This is needed by applications that perform encryption or check online certificates.
+ optdepends_x86_64 = lib32-gsm: (aur) Lets Windows applications use the GSM codec for audio compression and decompression.
+ optdepends_x86_64 = lib32-gstreamer0.10: (aur) This is needed by some games and multimedia applications.
+ optdepends_x86_64 = lib32-gstreamer0.10-base: (aur) This is needed by some games and multimedia applications.
+ optdepends_x86_64 = lib32-libxcomposite: This is needed for most CAD-like applications and some games.
+ optdepends_x86_64 = lib32-libxinerama: This is needed if your display spans multiple screens. If your computer has a single screen then you don't need it.
+ optdepends_x86_64 = lib32-libxml2: This library makes it possible for Windows applications read and write XML files.
+ optdepends_x86_64 = lib32-libxslt: This library lets Windows applications perform queries and transformations on XML files.
+ optdepends_x86_64 = lib32-libxxf86vm: This is needed to let games perform some gamma adjustments (essentially to adjust the brightness).
+ optdepends_x86_64 = lib32-libxxf86dga: X11 Direct Graphics Access extension library.
+ optdepends_x86_64 = lib32-mpg123: Needed by some Windows applications to play MP3 files.
+ optdepends_x86_64 = lib32-nss-mdns: (aur) host name resolution via mDNS
+ optdepends_x86_64 = lib32-openal: Provides audio support to Windows applications.
+ optdepends_x86_64 = lib32-openssl: This library provides support for secure Internet communication.
+ optdepends_x86_64 = lib32-v4l-utils: Lets Windows applications access video devices.
pkgname = deepin-crossover