summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomislav Ivek2019-10-01 15:09:52 +0200
committerTomislav Ivek2019-10-01 15:09:52 +0200
commit5b14eda832f2559abefddf7d34faf8bd86579e6b (patch)
treefd78230f845fa0bf497cae3f5c59fadfd1113ac7
parentfc495cf12915fc2a2896bcaa81bcf5c0fcbe29a0 (diff)
downloadaur-5b14eda832f2559abefddf7d34faf8bd86579e6b.tar.gz
Conan 1.19.0 devel
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--arch-reqs.patch31
3 files changed, 29 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbcb2db855e..855d94b7e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = conan-git
pkgdesc = A distributed, open source, C/C++ package manager.
- pkgver = 1.13.2.r23.g7c829c84
+ pkgver = 1.19.0.r3.g5acac3b2
pkgrel = 1
url = https://conan.io
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pyjwt>=1.4.0
- depends = python-requests>=2.7.0
+ depends = python-requests>=2.8.1
depends = python-colorama>=0.3.3
depends = python-yaml>=3.11
depends = python-patch>=1.16
@@ -17,20 +17,20 @@ pkgbase = conan-git
depends = python-bottle>=0.12.8
depends = python-distro>=1.0.2
depends = python-pluginbase>=0.5
- depends = python-pylint>=1.9.3
- depends = python-pylint<2.3.0
+ depends = python-pylint>=2.3.1
depends = python-future>=0.16.0
depends = python-pygments>=2.0
depends = python-astroid>=1.6.5
depends = python-deprecation>=2.0
depends = python-tqdm>=4.28.1
depends = python-jinja>=2.3
+ depends = python-dateutil>=2.7.0
provides = conan
conflicts = conan
source = conan-git::git+https://github.com/conan-io/conan.git
source = arch-reqs.patch
md5sums = SKIP
- md5sums = 31ca8bdab90284da36e0aec704ce2955
+ md5sums = 96d55422ed2b25562ea659098046e407
pkgname = conan-git
diff --git a/PKGBUILD b/PKGBUILD
index 2fbdf314a4e..c9b6d5b1021 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tomislav Ivek <tomislav.ivek@gmail.com>
pkgname=conan-git
-pkgver=1.13.2.r23.g7c829c84
+pkgver=1.19.0.r3.g5acac3b2
pkgrel=1
pkgdesc="A distributed, open source, C/C++ package manager."
arch=('any')
@@ -9,7 +9,7 @@ url="https://conan.io"
license=('MIT')
makedepends=('python-setuptools')
depends=('python-pyjwt>=1.4.0'
- 'python-requests>=2.7.0'
+ 'python-requests>=2.8.1'
'python-colorama>=0.3.3'
'python-yaml>=3.11'
'python-patch>=1.16'
@@ -19,19 +19,19 @@ depends=('python-pyjwt>=1.4.0'
'python-bottle>=0.12.8'
'python-distro>=1.0.2'
'python-pluginbase>=0.5'
- 'python-pylint>=1.9.3'
- 'python-pylint<2.3.0'
+ 'python-pylint>=2.3.1'
'python-future>=0.16.0'
'python-pygments>=2.0'
'python-astroid>=1.6.5'
'python-deprecation>=2.0'
'python-tqdm>=4.28.1'
- 'python-jinja>=2.3')
+ 'python-jinja>=2.3'
+ 'python-dateutil>=2.7.0')
provides=('conan')
conflicts=('conan')
source=("conan-git::git+https://github.com/conan-io/conan.git" "arch-reqs.patch")
md5sums=('SKIP'
- '31ca8bdab90284da36e0aec704ce2955')
+ '96d55422ed2b25562ea659098046e407')
pkgver() {
diff --git a/arch-reqs.patch b/arch-reqs.patch
index 6c14a4da0e1..e2c22750ae0 100644
--- a/arch-reqs.patch
+++ b/arch-reqs.patch
@@ -1,6 +1,6 @@
-diff -aur conan-1.13.0-pristine/conans/requirements_server.txt conan-1.13.0-new/conans/requirements_server.txt
---- conan-1.13.0-pristine/conans/requirements_server.txt 2019-03-08 16:28:47.496665636 +0100
-+++ conan-1.13.0-new/conans/requirements_server.txt 2019-03-08 16:33:02.447026160 +0100
+diff -aur conan-git-pristine/conans/requirements_server.txt conan-git-new/conans/requirements_server.txt
+--- conan-git-pristine/conans/requirements_server.txt 2019-10-01 15:04:40.002101092 +0200
++++ conan-git-new/conans/requirements_server.txt 2019-10-01 15:07:22.342561193 +0200
@@ -1,3 +1,3 @@
# Server
-bottle>=0.12.8, < 0.13
@@ -8,17 +8,18 @@ diff -aur conan-1.13.0-pristine/conans/requirements_server.txt conan-1.13.0-new/
\ No newline at end of file
+bottle>=0.12.8
+pluginbase>=0.5
-diff -aur conan-1.13.0-pristine/conans/requirements.txt conan-1.13.0-new/conans/requirements.txt
---- conan-1.13.0-pristine/conans/requirements.txt 2019-03-08 16:28:47.496665636 +0100
-+++ conan-1.13.0-new/conans/requirements.txt 2019-03-08 16:32:45.027001391 +0100
-@@ -1,16 +1,16 @@
+diff -aur conan-git-pristine/conans/requirements.txt conan-git-new/conans/requirements.txt
+--- conan-git-pristine/conans/requirements.txt 2019-10-01 15:04:39.982101036 +0200
++++ conan-git-new/conans/requirements.txt 2019-10-01 15:07:16.432544450 +0200
+@@ -1,19 +1,17 @@
-PyJWT>=1.4.0, <2.0.0
--requests>=2.7.0, <3.0.0
+-requests>=2.8.1, <3.0.0
+-urllib3!=1.25.4,!=1.25.5
-colorama>=0.3.3, <0.5.0
--PyYAML>=3.11, <3.14.0
+-PyYAML>=3.11, <6.0
-patch==1.16
+PyJWT>=1.4.0
-+requests>=2.7.0
++requests>=2.8.1
+colorama>=0.3.3
+PyYAML>=3.11
+patch>=1.16
@@ -26,17 +27,21 @@ diff -aur conan-1.13.0-pristine/conans/requirements.txt conan-1.13.0-new/conans/
six>=1.10.0
-node-semver==0.6.1
-distro>=1.0.2, <1.2.0
+-pylint>=1.9.3,!=2.3.0
+-future>=0.16.0, <0.19.0
+-pygments>=2.0, <3.0
+node-semver>=0.6.1
+distro>=1.0.2
- pylint>=1.9.3,!=2.3.0
--future==0.16.0
--pygments>=2.0, <3.0
++pylint>=2.3.1
+future>=0.16.0
+pygments>=2.0
astroid>=1.6.5
-deprecation>=2.0, <2.1
-tqdm>=4.28.1, <5
-Jinja2>=2.3, <3
+-python-dateutil>=2.7.0, <3
+-typed-ast<1.4; python_version == '3.4' and platform_system=='Windows'
+deprecation>=2.0
+tqdm>=4.28.1
+Jinja2>=2.3
++python-dateutil>=2.7.0