summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomislav Ivek2018-01-14 02:10:56 +0100
committerTomislav Ivek2018-01-14 02:10:56 +0100
commit1100fad3fab2727dc9d91de6fee7b60835b7c9e1 (patch)
tree15614b6bec2435b2f8933a94b48f9a829852fe46
parent8e0c457a3b26129948ed221030170cb2b6a0fbb9 (diff)
downloadaur-1100fad3fab2727dc9d91de6fee7b60835b7c9e1.tar.gz
update dependency versions for 1.0.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--arch-reqs.patch36
-rw-r--r--pylint-1.6.4.patch11
4 files changed, 63 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbf6a446719..8b255657ae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,32 @@
pkgbase = conan-git
pkgdesc = A distributed, open source, C/C++ package manager.
- pkgver = 0.25.0.r83.g42552fc
+ pkgver = 1.0.0.r18.gee1c7c43
pkgrel = 1
url = https://conan.io
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pyjwt>=1.4.0
- depends = python-pyjwt<2.0.0
depends = python-requests>=2.7.0
- depends = python-requests<3.0.0
depends = python-colorama>=0.3.3
- depends = python-colorama<0.4.0
depends = python-yaml>=3.11
- depends = python-yaml<3.13.0
depends = python-patch=1.16
depends = python-fasteners>=0.14.1
depends = python-six>=1.10.0
- depends = python-node-semver=0.1.1
- depends = python-distro>=1.0.2
- depends = python-distro<1.1.0
- depends = python-pylint>=1.6.4
+ depends = python-node-semver>=0.2.0
depends = python-bottle>=0.12.8
- depends = python-bottle<0.13
depends = python-distro>=1.0.2
- depends = python-distro<1.1.0
depends = python-pluginbase>=0.5
- depends = python-pluginbase<1.0
- depends = python-pylint>=1.6.5
- depends = python-pylint<=1.8.0
+ depends = python-pylint>=1.8.1
depends = python-future=0.16.0
depends = python-pygments>=2.0
- depends = python-pygments<3.0
+ depends = python-astroid>=1.6
provides = conan
conflicts = conan
source = conan-git::git+https://github.com/conan-io/conan.git
+ source = arch-reqs.patch
md5sums = SKIP
+ md5sums = b364c94510b7bc7ec9f46d8adff31494
pkgname = conan-git
diff --git a/PKGBUILD b/PKGBUILD
index be7835a0d60..56f55e1130e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Tomislav Ivek <tomislav.ivek@gmail.com>
pkgname=conan-git
-pkgver=0.25.0.r83.g42552fc
+pkgver=1.0.0.r18.gee1c7c43
pkgrel=1
pkgdesc="A distributed, open source, C/C++ package manager."
arch=('any')
url="https://conan.io"
license=('MIT')
-depends=('python-pyjwt>=1.4.0' 'python-pyjwt<2.0.0'
- 'python-requests>=2.7.0' 'python-requests<3.0.0'
- 'python-colorama>=0.3.3' 'python-colorama<0.4.0'
- 'python-yaml>=3.11' 'python-yaml<3.13.0'
+makedepends=('python-setuptools')
+depends=('python-pyjwt>=1.4.0'
+ 'python-requests>=2.7.0'
+ 'python-colorama>=0.3.3'
+ 'python-yaml>=3.11'
'python-patch=1.16'
'python-fasteners>=0.14.1'
'python-six>=1.10.0'
- 'python-node-semver=0.1.1'
- 'python-distro>=1.0.2' 'python-distro<1.1.0'
- 'python-pylint>=1.6.4'
- 'python-bottle>=0.12.8' 'python-bottle<0.13'
- 'python-distro>=1.0.2' 'python-distro<1.1.0'
- 'python-pluginbase>=0.5' 'python-pluginbase<1.0'
- 'python-pylint>=1.6.5' 'python-pylint<=1.8.0'
+ 'python-node-semver>=0.2.0'
+ 'python-bottle>=0.12.8'
+ 'python-distro>=1.0.2'
+ 'python-pluginbase>=0.5'
+ 'python-pylint>=1.8.1'
'python-future=0.16.0'
- 'python-pygments>=2.0' 'python-pygments<3.0')
-makedepends=('python-setuptools')
+ 'python-pygments>=2.0'
+ 'python-astroid>=1.6')
provides=('conan')
conflicts=('conan')
-source=("conan-git::git+https://github.com/conan-io/conan.git")
-md5sums=('SKIP')
+source=("conan-git::git+https://github.com/conan-io/conan.git" "arch-reqs.patch")
+md5sums=('SKIP'
+ 'b364c94510b7bc7ec9f46d8adff31494')
pkgver() {
@@ -35,6 +35,11 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i "${srcdir}/arch-reqs.patch"
+}
+
build() {
cd "$srcdir/$pkgname"
python setup.py build
diff --git a/arch-reqs.patch b/arch-reqs.patch
new file mode 100644
index 00000000000..2d0de1b5c1f
--- /dev/null
+++ b/arch-reqs.patch
@@ -0,0 +1,36 @@
+diff -aur conan-1.0.1-pristine/conans/requirements.txt conan-1.0.1-new/conans/requirements.txt
+--- conan-1.0.1-pristine/conans/requirements.txt 2018-01-14 01:32:39.272876273 +0100
++++ conan-1.0.1-new/conans/requirements.txt 2018-01-14 01:33:30.379989810 +0100
+@@ -1,13 +1,13 @@
+-PyJWT>=1.4.0, <2.0.0
+-requests>=2.7.0, <3.0.0
+-colorama>=0.3.3, <0.4.0
+-PyYAML>=3.11, <3.13.0
++PyJWT>=1.4.0
++requests>=2.7.0
++colorama>=0.3.3
++PyYAML>=3.11
+ patch==1.16
+ fasteners>=0.14.1
+ six>=1.10.0
+-node-semver==0.2.0
+-distro>=1.0.2, <1.2.0
+-pylint>=1.8.1, <1.9.0
++node-semver>=0.2.0
++distro>=1.0.2
++pylint>=1.8.1
+ future==0.16.0
+-pygments>=2.0, <3.0
+-astroid>=1.6, <1.7
++pygments>=2.0
++astroid>=1.6
+diff -aur conan-1.0.1-pristine/conans/requirements_server.txt conan-1.0.1-new/conans/requirements_server.txt
+--- conan-1.0.1-pristine/conans/requirements_server.txt 2018-01-14 01:32:39.272876273 +0100
++++ conan-1.0.1-new/conans/requirements_server.txt 2018-01-14 01:33:52.881039797 +0100
+@@ -1,3 +1,3 @@
+ # Server
+-bottle>=0.12.8, < 0.13
+-pluginbase>=0.5, < 1.0
+\ No newline at end of file
++bottle>=0.12.8
++pluginbase>=0.5
diff --git a/pylint-1.6.4.patch b/pylint-1.6.4.patch
deleted file mode 100644
index ec836f20c5c..00000000000
--- a/pylint-1.6.4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur conan-0.22.1-pristine/conans/requirements.txt conan-0.22.1-archlinux_pylint_patch/conans/requirements.txt
---- conan-0.22.1-pristine/conans/requirements.txt 2017-04-18 18:13:51.406244188 +0200
-+++ conan-0.22.1-archlinux_pylint_patch/conans/requirements.txt 2017-04-18 18:14:17.012930202 +0200
-@@ -7,6 +7,6 @@
- six>=1.10.0
- node-semver==0.1.1
- distro>=1.0.2, <1.1.0
--pylint==1.6.5
-+pylint>=1.6.4
- future==0.16.0
-