summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-03 04:52:08 +0100
committerCarsten Teibes2014-01-03 04:52:08 +0100
commitbe816e60fe29ade50e8bd4638c4208a0d502efdb (patch)
tree79db9047293c6c7a211d8c9fe8942de65e5023b5
parent372b84dd6a80506430220bd5dee3a820c2379b5e (diff)
downloadaur-be816e60fe29ade50e8bd4638c4208a0d502efdb.tar.gz
[fix] Use correct lua and python version and disable
additional renderers
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def3a1e676d..30a59950344 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = cegui-0.7
- pkgdesc = A free library providing windowing and widgets for graphics APIs/engines
+ pkgdesc = A free library providing windowing and widgets for graphics APIs/engines (legacy version)
pkgver = 0.7.9
- pkgrel = 3
+ pkgrel = 4
url = http://crayzedsgui.sourceforge.net
arch = i686
arch = x86_64
license = MIT
makedepends = python2
makedepends = doxygen
- makedepends = ogre
makedepends = gtk2
makedepends = boost
makedepends = graphviz
- makedepends = irrlicht
- depends = pcre
depends = glew
- depends = expat
depends = freetype2
depends = libxml2
depends = devil
@@ -26,9 +22,8 @@ pkgbase = cegui-0.7
depends = glm
depends = glfw
optdepends = python2: python bindings
- optdepends = ogre: ogre module
+ optdepends = boost-libs: null renderer with python2
optdepends = gtk2: gtk2 module
- optdepends = irrlicht: irrlicht module
provides = cegui
conflicts = cegui
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index 65d430b3bb4..9932cba3992 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,18 @@
pkgname=cegui-0.7
pkgver=0.7.9
-pkgrel=3
-pkgdesc="A free library providing windowing and widgets for graphics APIs/engines"
+pkgrel=4
+pkgdesc="A free library providing windowing and widgets for graphics APIs/engines (legacy version)"
arch=('i686' 'x86_64')
url="http://crayzedsgui.sourceforge.net"
license=("MIT")
-depends=('pcre' 'glew' 'expat' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51'
- 'silly' 'mesa' 'glm' 'glfw')
-makedepends=('python2' 'doxygen' 'ogre' 'gtk2' 'boost' 'graphviz' 'irrlicht')
+depends=('glew' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51' 'silly' 'mesa' 'glm' 'glfw')
+makedepends=('python2' 'doxygen' 'gtk2' 'boost' 'graphviz') # 'ogre' 'irrlicht')
optdepends=("python2: python bindings"
- "ogre: ogre module"
- "gtk2: gtk2 module"
- "irrlicht: irrlicht module")
+ "boost-libs: null renderer with python2"
+ #"ogre: ogre module"
+ #"irrlicht: irrlicht module"
+ "gtk2: gtk2 module")
provides=('cegui')
conflicts=('cegui')
options=('!libtool')
@@ -29,18 +29,22 @@ md5sums=('a8b682daf82e383edc169c2e6eb2b321')
sha256sums=('7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c')
build() {
- cd "$srcdir/CEGUI-$pkgver"
+ cd CEGUI-$pkgver
./bootstrap
- ./configure --prefix=/usr --sysconfdir=/etc --enable-null-renderer --with-gtk2
+ Lua_CFLAGS="$(pkg-config --cflags lua5.1)" \
+ Lua_LIBS="$(pkg-config --libs lua5.1)" \
+ PYTHON="/usr/bin/python2" ./configure --prefix=/usr --sysconfdir=/etc \
+ --enable-null-renderer --with-gtk2 --disable-samples \
+ --disable-ogre-renderer --disable-irrlicht-renderer
make
}
package() {
- cd "$srcdir/CEGUI-$pkgver"
+ cd CEGUI-$pkgver
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir/" install
- install -Dm644 doc/COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 doc/COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}